- Update to 4.2.1

- Rework rc script
- Handle nicely configuration files
- Use SUB_FILES

PR:		ports/76179
Submitted by:	Paul Everlund <tdv94ped@cs.umu.se> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-01-14 22:28:10 +00:00
parent 37072f805a
commit eba6967c97
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126467
11 changed files with 89 additions and 355 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= hylafax
PORTVERSION= 4.2.0
PORTVERSION= 4.2.1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
@ -30,6 +30,8 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none \
--with-DIR_HTML="${DOCSDIR}"
SUB_FILES= pkg-message hylafax.sh.sample
# Defaults to "North American Letter". Use "ISO A4" for A4.
.if defined(PAGESIZE)
CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
@ -95,16 +97,10 @@ post-patch:
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
@if [ ! -f ${PREFIX}/etc/rc.d/hylafax-faxq.sh.sample ]; then \
${SED} 's^/usr/local^${PREFIX}^g' \
< ${FILESDIR}/hylafax-faxq.sh.sample \
> ${PREFIX}/etc/rc.d/hylafax-faxq.sh.sample; \
fi
@if [ ! -f ${PREFIX}/etc/rc.d/hylafax-hfaxd.sh.sample ]; then \
${SED} 's^/usr/local^${PREFIX}^g' \
< ${FILESDIR}/hylafax-hfaxd.sh.sample \
> ${PREFIX}/etc/rc.d/hylafax-hfaxd.sh.sample; \
fi
@${SED} 's^/usr/local^${PREFIX}^g' < ${PKGMESSAGE}
${INSTALL_SCRIPT} ${WRKDIR}/hylafax.sh.sample ${PREFIX}/etc/rc.d
if [ ! -f ${PREFIX}/lib/fax/hfaxd.conf ]; then ${CP} -p ${PREFIX}/lib/fax/hfaxd.conf-dist ${PREFIX}/lib/fax/hfaxd.conf; fi
if [ ! -f ${PREFIX}/lib/fax/pagesizes ]; then ${CP} -p ${PREFIX}/lib/fax/pagesizes-dist ${PREFIX}/lib/fax/pagesizes; fi
if [ ! -f ${PREFIX}/lib/fax/typerules ]; then ${CP} -p ${PREFIX}/lib/fax/typerules-dist ${PREFIX}/lib/fax/typerules; fi
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (hylafax/hylafax-4.2.0.tar.gz) = 463726ed21cfdac730c5d6915e0840cf
SIZE (hylafax/hylafax-4.2.0.tar.gz) = 1351870
MD5 (hylafax/hylafax-4.2.1.tar.gz) = 05430e41a279d0fff6d6e4b444440829
SIZE (hylafax/hylafax-4.2.1.tar.gz) = 1412035

View file

@ -1,23 +0,0 @@
#! /bin/sh
# hylafax faxq startup example.
# be sure to initialize the followings:
# server: /usr/local/sbin/faxsetup
# modems: /usr/local/sbin/faxaddmodem
# incoming calls: /etc/ttys
case "$1" in
start)
if [ -x /usr/local/sbin/faxq ]; then
/usr/local/sbin/faxq && echo -n ' hylafax-faxq'
fi
;;
stop)
killall faxq && echo -n ' hylafax-faxq'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
exit 64
;;
esac
exit 0

View file

@ -1,27 +0,0 @@
#! /bin/sh
# hylafax hfaxd startup example.
# be sure to initialize the followings:
# server........: /usr/local/sbin/faxsetup
# modems........: /usr/local/sbin/faxaddmodem
# incoming calls: /etc/ttys
#
# add switch to use old protocol (not recommended): -o [port]
# add switch to use paging protocol (SNPP)........: -s [port]
# read more about these options in 'man hfaxd'.
case "$1" in
start)
if [ -x /usr/local/sbin/hfaxd ]; then
/usr/local/sbin/hfaxd && echo -n ' hylafax-hfaxd'
fi
;;
stop)
killall hfaxd && echo -n ' hylafax-hfaxd'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
exit 64
;;
esac
exit 0

View file

@ -0,0 +1,25 @@
#! /bin/sh
# hylafax startup example.
# be sure to initialize the following:
# server: %%PREFIX%%/sbin/faxsetup
# modems: %%PREFIX%%/sbin/faxaddmodem
# incoming calls: /etc/ttys
case "$1" in
start)
if [ -x %%PREFIX%%/sbin/hylafax ]; then
%%PREFIX%%/sbin/hylafax start
fi
;;
stop)
if [ -x %%PREFIX%%/sbin/hylafax ]; then
%%PREFIX%%/sbin/hylafax stop
fi
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
exit 64
;;
esac
exit 0

View file

@ -1,5 +1,5 @@
--- configure.orig Fri Sep 3 14:08:03 2004
+++ configure Fri Sep 3 14:14:34 2004
--- configure.orig Tue Dec 28 05:45:03 2004
+++ configure Wed Jan 12 23:15:17 2005
@@ -43,8 +43,8 @@
DIR_LIB=/usr/local/lib
DIR_LIBEXEC=$DIR_SBIN
@ -29,81 +29,16 @@
-target|--target) ac_prev=TARGET;;
-target=*|--target=*) TARGET="$ac_optarg" ;;
- -disable-pam|--disable-pam) DISABLE_PAM="yes" ;;
+ -disable-pam|--disable-pam) DISABLE_PAM="yes" ;;
+ -disable-pam|--disable-pam) DISABLE_PAM="yes" ;;
-version|--version)
echo "This is HylaFAX configure $Revision: 1.102 $"
echo "This is HylaFAX configure $Revision: 1.106 $"
exit 0
@@ -1519,10 +1519,16 @@
#
CheckForLibrary()
{
+ incls=$1; shift
+ vars=$1; shift
f=$1; shift
libs="$@";
- cat>t.c<<EOF
-int t() { $f(); return 0; }
+ echo "">t.c
+ for i in $incls; do
+ echo "#include "$i>>t.c
+ done
+ cat>>t.c<<EOF
+int t() { $vars $f; return 0; }
int main(){ t(); return 0; }
EOF
capture cat t.c
@@ -1542,39 +1548,41 @@
}
if [ "$SGI2FAX" = auto ]; then
- if CheckForLibrary iopen -limage && CheckForIncludeFile gl/image.h; then
+ if CheckForLibrary "<gl/image.h>" "char *a,*b;" "iopen(a,b)" -limage && CheckForIncludeFile gl/image.h; then
Note "Looks like there is support for SGI RGB images, configuring sgi2fax."
SGI2FAX=yes
else
SGI2FAX=no
fi
fi
-if [ "$LIBMALLOC" = auto ]; then
- if CheckForLibrary mallopt -lmalloc; then
- Note "Looks like -lmalloc is here, using it for memory allocation."
- LIBMALLOC=yes
- else
+### FreeBSD have malloc in -lc, which is checked elsewhere.
+#if [ "$LIBMALLOC" = auto ]; then
+# if CheckForLibrary mallopt -lmalloc; then
+# Note "Looks like -lmalloc is here, using it for memory allocation."
+# LIBMALLOC=yes
+# else
LIBMALLOC=no
- fi
-fi
-if [ "$LIBSUN" = auto ]; then
- if CheckForLibrary getpwnam -lsun; then
- Note "Looks like -lsun is here, using it for NIS passwd & group stuff."
- LIBSUN=yes
- else
+# fi
+#fi
+### FreeBSD have getpwnam in -lc, which is checked elsewhere.
+#if [ "$LIBSUN" = auto ]; then
+# if CheckForLibrary getpwnam -lsun; then
+# Note "Looks like -lsun is here, using it for NIS passwd & group stuff."
+# LIBSUN=yes
+# else
LIBSUN=no
- fi
-fi
+# fi
+#fi
HAVE_PAM="/*#define HAVE_PAM 1*/"
PAMLIBS=""
@@ -1578,11 +1578,11 @@
if [ "$DISABLE_PAM" != "yes" ]; then
Note "Checking for PAM (Pluggable Authentication Module) support"
- CheckForLibrary pam_authenticate -lpam &&
CheckForLibrary pam_authenticate -lpam &&
- CheckForLibrary misc_conv -lpam_misc -lpam &&
+ CheckForLibrary "<sys/types.h> <security/pam_appl.h>" "pam_handle_t *a; int b;" "pam_authenticate(a,b)" -lpam &&
+ CheckForLibrary "<security/pam_misc.h>" "int a; const struct pam_message **b; struct pam_response **c; void *d;" "misc_conv(a,b,c,d)" -lpam &&
+ CheckForLibrary misc_conv -lpam &&
CheckForIncludeFile security/pam_appl.h &&
CheckForIncludeFile security/pam_misc.h && {
HAVE_PAM="#define HAVE_PAM 1"
@ -112,184 +47,7 @@
}
if [ "x$PAMLIBS" = "x" ]; then
Note "... not found. Disabling PAM support"
@@ -1584,25 +1592,25 @@
else
Note "Disabling PAM support"
fi
-CheckForLibrary crypt -lc || {
+CheckForLibrary "<unistd.h>" "const char *a,*b;" "crypt(a,b)" -lc || {
#
# FreeBSD-2.1 in particular needs -lcrypt.
# SCO sometime has -lcrypt_d (domestic) and
# sometimes -lcrypt_i (import?)
#
for i in -lcrypt -lcrypt_d -lcrypt_i; do
- if CheckForLibrary crypt $i; then
+ if CheckForLibrary "" "" "crypt()" $i; then
Note "Looks like $i is needed for crypt."
MACHDEPLIBS="$MACHDEPLIBS $i"
break;
fi
done
}
-CheckForLibrary strftime -lc || {
+CheckForLibrary "<sys/types.h> <time.h>" "char *a; size_t b; const char *c; const struct tm *d;" "strftime(a,b,c,d)" -lc || {
#
# SCO has strftime in -lintl.
#
- if CheckForLibrary strftime -lintl; then
+ if CheckForLibrary "" "" "strftime()" -lintl; then
Note "Looks like -lintl is needed for strftime."
MACHDEPLIBS="$MACHDEPLIBS -lintl"
else
@@ -1620,18 +1628,18 @@
boom
fi
}
-CheckForLibrary socket -lc || {
+CheckForLibrary "<sys/types.h> <sys/socket.h>" "int a,b,c;" "socket(a,b,c)" -lc || {
#
# Socket support is not in normal C library, check
# for SVR4-style networking w/ -lsocket & -lnsl
#
- if CheckForLibrary socket -lsocket -lnsl; then
+ if CheckForLibrary "" "" "socket()" -lsocket -lnsl; then
Note "Looks like -lsocket & -lnsl are needed for socket support."
MACHDEPLIBS="$MACHDEPLIBS -lsocket -lnsl"
- elif CheckForLibrary socket -linet -lnsl_s; then
+ elif CheckForLibrary "" "" "socket()" -linet -lnsl_s; then
Note "Looks like -linet & -lnsl_s are needed for socket support."
MACHDEPLIBS="$MACHDEPLIBS -linet -lnsl_s"
- elif CheckForLibrary socket -lsocket; then
+ elif CheckForLibrary "" "" "socket()" -lsocket; then
Note "Looks like -lsocket is needed for socket support."
MACHDEPLIBS="$MACHDEPLIBS -lsocket"
else
@@ -1650,39 +1658,43 @@
boom
fi
}
-if CheckForLibrary logwtmp -lutil; then
+if CheckForLibrary "<sys/types.h> <libutil.h>" "const char *a,*b,*c;" "logwtmp(a,b,c)" -lutil; then
Note "Looks like -lutil is needed for wtmp file logging."
MACHDEPLIBS="$MACHDEPLIBS -lutil"
HAS_LOGWTMP=yes
else
HAS_LOGWTMP=no
fi
-CheckForLibrary ftruncate -lc || {
- CheckForLibrary chsize -lx && {
+CheckForLibrary "<unistd.h>" "int a; off_t b;" "ftruncate(a,b)" -lc || {
+ CheckForLibrary "" "" "chsize()" -lx && {
Note "Looks like -lx is needed for chsize (used to emulate ftruncate)."
MACHDEPLIBS="$MACHDEPLIBS -lx"
}
}
-CheckForLibrary flock -lc || {
- CheckForLibrary flock -lbsd && {
+CheckForLibrary "<sys/file.h>" "int a,b;" "flock(a,b)" -lc || {
+ CheckForLibrary "" "" "flock()" -lbsd && {
Note "Looks like -lbsd is needed for flock."
MACHDEPLIBS="$MACHDEPLIBS -lbsd"
}
}
-for f in openlog pututxline; do
- CheckForLibrary $f -lc || {
- CheckForLibrary $f -lgen && {
- Note "Looks like -lgen is needed for $f."
- MACHDEPLIBS="$MACHDEPLIBS -lgen"
- break;
- }
+CheckForLibrary "<syslog.h> <stdarg.h>" "const char *a; int b,c;" "openlog(a,b,c)" -lc || {
+ CheckForLibrary "" "" "openlog()" -lgen && {
+ Note "Looks like -lgen is needed for openlog."
+ MACHDEPLIBS="$MACHDEPLIBS -lgen"
}
-done
+}
+### FreeBSD do not have pututxline.
+#CheckForLibrary pututxline -lc || {
+# CheckForLibrary pututxline -lgen && {
+# Note "Looks like -lgen is needed for pututxline."
+# MACHDEPLIBS="$MACHDEPLIBS -lgen"
+# }
+#}
if [ "$ISGXX" = yes ]; then
if [ -z "$CXXRUNTIME" ]; then
- for f in memmove strdup; do
- CheckForLibrary $f -lc || {
- CheckForLibrary $f -lg++ && {
+ for f in "memmove(a,b,c)" "strdup(d)"; do
+ CheckForLibrary "<string.h>" "void *a; const void *b; size_t c; const char *d;" $f -lc || {
+ CheckForLibrary "" "" "$f()" -lg++ && {
Note "Looks like we need -lg++ for $f"
MACHDEPLIBS="$MACHDEPLIBS -lg++"
break;
@@ -1690,9 +1702,9 @@
}
done
fi
- for f in strtoul strerror memmove random; do
- CheckForLibrary $f -lc || {
- CheckForLibrary $f -liberty && {
+ for f in "strtoul(a,b,c)" "strerror(c)" "memmove(d,e,f)" "random()"; do
+ CheckForLibrary "<stdlib.h> <limits.h> <string.h>" "const char *a; char **b; int c; void *d; const void *e; size_t f;" $f -lc || {
+ CheckForLibrary "" "" "$f()" -liberty && {
Note "Looks like we need -liberty for $f"
MACHDEPLIBS="$MACHDEPLIBS -liberty"
break;
@@ -1700,12 +1712,12 @@
}
done
fi
-CheckForLibrary floor -lm && {
+CheckForLibrary "<math.h>" "double a;" "floor(a)" -lm && {
Note "Looks like -lm is the library for math functions."
MACHDEPLIBS="$MACHDEPLIBS -lm"
}
MACHDEPLIBS="$MACHDEPLIBS $CXXRUNTIME"
-test "$LIBSUN" = yes && MACHDEPLIBS="$MACHDEPLIBS -lsun"
+test "$LIBSUN" = yes && MACHDEPLIBS="$MACHDEPLIBS -lc"
test "$LIBMALLOC" = yes && MACHDEPLIBS="$MACHDEPLIBS -lmalloc"
#
@@ -2364,5 +2364,5 @@
if [ "${lib_ver}" = "3.4" ]; then
tiff_runlen_t="uint16"
- elif [ "${lib_ver}" = "3.5" -o "${lib_ver}" = "3.6" ]; then
+ elif [ "${lib_ver}" = "3.5" -o "${lib_ver}" = "3.6" -o "${lib_ver}" = "3.7" ]; then
tiff_runlen_t="uint32"
fi
@@ -2401,7 +2401,7 @@
Incompatible TIFF Library.
-HylaFAX ${VERSION} requires TIFF software distribution ver 3.4, 3.5, or
-3.6. If you do not have up to date TIFF software on your system then
-you can retrieve it from the location where you obtained this software.
+HylaFAX ${VERSION} requires TIFF software distribution ver 3.4, 3.5,
+3.6, or 3.7. If you do not have up to date TIFF software on your system
+then you can retrieve it from the location where you obtained this software.
The Home Page for version 3.5 and later is http://www.libtiff.org
EOF
@@ -2640,7 +2652,7 @@
}
CheckFuncDecl unlink 'extern int unlink(const char*);' unistd.h
CheckFuncDecl read 'extern int read(int, const void*, unsigned int);' unistd.h
- CheckFuncDecl ioctl 'extern int ioctl(int, int, ...);' unistd.h sys/ioctl.h
+ CheckFuncDecl ioctl 'extern int ioctl(int, unsigned long, ...);' sys/ioccom.h
CheckForFunc fchown && {
echo '#define HAS_FCHOWN 1'
Note "... configure use of fchown"
@@ -2852,7 +2864,7 @@
AddFuncDecl logwtmp \
'int logwtmp(const char*, const char*, const char*);'
}
- CheckForLibrary logout -lutil && {
+ CheckForLibrary "<sys/types.h> <libutil.h>" "const char *a;" "logout(a)" -lutil && {
echo '#define HAS_LOGOUT 1'
Note "... configure use of logout (BSD-style utmp support)"
CheckForFuncDecl logout utmp.h || {
@@ -4307,18 +4319,8 @@
@@ -4326,18 +4326,8 @@
HylaFAX configuration parameters (part 1 of 2) are:
@ -308,7 +66,7 @@
[13] Default page size: $PAGESIZE
[14] Default vertical res (lpi): $DEFVRES
@@ -4334,16 +4336,9 @@
@@ -4353,16 +4343,11 @@
[15] Location of getty program: $PATH_GETTY
[16] Location of voice getty program: $PATH_VGETTY
[17] Location of sendmail program: $PATH_SENDMAIL
@ -318,17 +76,15 @@
-[21] Location of SysV stop scripts: $DIR_SYSVINITSTOP
-[22] Name of SysV start script: $NAME_SYSVINITSTART
-[23] Name of SysV stop script: $NAME_SYSVINITSTOP
-[24] Init script starts faxq: $FAXQ_SERVER
-[25] Init script starts hfaxd $HFAXD_SERVER
-[26] Start old protocol: $HFAXD_OLD_PROTOCOL
-[27] Start paging protocol: $HFAXD_SNPP_SERVER
+[26] Use old protocol: $HFAXD_OLD_PROTOCOL
+[27] Use paging protocol: $HFAXD_SNPP_SERVER
[24] Init script starts faxq: $FAXQ_SERVER
[25] Init script starts hfaxd $HFAXD_SERVER
[26] Start old protocol: $HFAXD_OLD_PROTOCOL
[27] Start paging protocol: $HFAXD_SNPP_SERVER
+
EOF
}
@@ -4444,7 +4439,7 @@
@@ -4463,7 +4448,7 @@
ok=skip
while [ "$ok" != y ] && [ "$ok" != yes ]; do
if [ "$ok" != skip ]; then
@ -337,12 +93,12 @@
promptForParameter $i;
done
fi
@@ -4473,7 +4468,7 @@
@@ -4492,7 +4477,7 @@
ok=skip
while [ "$ok" != y ] && [ "$ok" != yes ]; do
if [ "$ok" != skip ]; then
- for i in 15 16 17 18 19 20 21 22 23 24 25 26 27 ; do
+ for i in 15 16 17 26 27 ; do
+ for i in 15 16 17 24 25 26 27 ; do
promptForParameter $i;
done
fi

View file

@ -1,11 +0,0 @@
--- util/faxcron.sh.in.ORIG Sun Apr 15 05:38:55 2001
+++ util/faxcron.sh.in Fri Dec 28 22:41:41 2001
@@ -41,7 +41,7 @@
AGELOG=30 # keep log info for last 30 days
AGERCV=7 # purge received facsimile after 7 days
AGETMP=1 # purge orphaned temp files after 1 day
-FAXUSER=fax # owner of log files
+FAXUSER=@FAXUID@ # owner of log files
LOGMODE=0644 # mode for log files
XFERLOG=etc/xferfaxlog # HylaFAX xferfaxlog file location
LAST=etc/lastrun # file where time+date of last run recorded

View file

@ -0,0 +1,8 @@
--- hfaxd/Makefile.in.orig Thu Nov 20 16:20:39 2003
+++ hfaxd/Makefile.in Fri Jan 14 22:59:19 2005
@@ -99,4 +99,4 @@
${INSTALL} -F ${LIBEXEC} -u root -m 755 \
-idb ${PRODUCT}.sw.server -O hfaxd
${INSTALL} -F ${LIBDATA} -m 644 -idb ${PRODUCT}.sw.server \
- -idb "config(noupdate)" -src ${SRCDIR}/hfaxd.conf -O hfaxd.conf
+ -idb "config(noupdate)" -src ${SRCDIR}/hfaxd.conf -O hfaxd.conf-dist

View file

@ -0,0 +1,13 @@
--- util/Makefile.in.orig Mon Aug 16 14:58:22 2004
+++ util/Makefile.in Fri Jan 14 23:17:11 2005
@@ -161,8 +161,8 @@
installClient: default
${PUTCLIENT} -F ${LIBEXEC} -m 755 -O textfmt
- ${PUTCLIENT} -F ${LIBDATA} -m 444 -O pagesizes
- ${PUTCLIENT} -F ${LIBDATA} -m 444 -src ${SRCDIR}/typerules -O typerules
+ ${PUTCLIENT} -F ${LIBDATA} -m 444 -src ${SRCDIR}/pagesizes -O pagesizes-dist
+ ${PUTCLIENT} -F ${LIBDATA} -m 444 -src ${SRCDIR}/typerules -O typerules-dist
install: installClient
${PUTSBIN} -m 755 -O faxmsg faxadduser faxconfig faxdeluser faxmodem \

View file

@ -2,18 +2,18 @@ Hylafax was installed. You'll need manual configurations to actually
activate it.
Setting up: (for impatients)
Invoke /usr/local/sbin/faxsetup, and answer the questions.
Invoke %%PREFIX%%/sbin/faxsetup, and answer the questions.
Mostly, accepting the defaults should work well.
When you are asked to specify the name of tty device, use "cuaa1"
instead of "ttyd1". Otherwise it does not work well.
Consult /usr/local/etc/rc.d/hylafax.sh.sample for startups.
Consult %%PREFIX%%/etc/rc.d/hylafax.sh.sample for startups.
For accepting incoming FAX/data calls, modify /etc/ttys as below
and send SIGHUP to init process:
>cuaa1 "/usr/local/sbin/faxgetty" dialup on secure
>cuaa1 "%%PREFIX%%/sbin/faxgetty" dialup on secure
Documentation:
On Line Manuals: man hylafax-client

View file

@ -5,14 +5,19 @@ bin/faxrm
bin/faxstat
bin/sendfax
bin/sendpage
etc/rc.d/hylafax-faxq.sh.sample
etc/rc.d/hylafax-hfaxd.sh.sample
etc/rc.d/hylafax.sh.sample
lib/fax/faxcover.ps
lib/fax/faxcover_example_sgi.ps
lib/fax/faxmail.ps
lib/fax/hfaxd.conf
lib/fax/pagesizes
lib/fax/typerules
@unexec if cmp -s %D/lib/fax/hfaxd.conf %D/lib/fax/hfaxd.conf-dist; then rm -f %D/lib/fax/hfaxd.conf; fi
lib/fax/hfaxd.conf-dist
@exec [ -f %B/hfaxd.conf ] || cp %B/%f %B/hfaxd.conf
@unexec if cmp -s %D/lib/fax/pagesizes %D/lib/fax/pagesizes-dist; then rm -f %D/lib/fax/pagesizes; fi
lib/fax/pagesizes-dist
@exec [ -f %B/pagesizes ] || cp %B/%f %B/pagesizes
@unexec if cmp -s %D/lib/fax/typerules %D/lib/fax/typerules-dist; then rm -f %D/lib/fax/typerules; fi
lib/fax/typerules-dist
@exec [ -f %B/typerules ] || cp %B/%f %B/typerules
@dirrm lib/fax
sbin/choptest
sbin/cqtest
@ -176,7 +181,7 @@ hylafax/COPYRIGHT
@exec mkfifo %D/hylafax/FIFO
@exec chown uucp:dialer %D/hylafax/FIFO
@exec chmod 0600 %D/hylafax/FIFO
@unexec rm %D/hylafax/FIFO*
@unexec rm %D/hylafax/FIFO
@exec mkdir %D/hylafax/archive
@exec chown uucp:dialer %D/hylafax/archive
@exec chmod 0700 %D/hylafax/archive
@ -185,9 +190,9 @@ hylafax/bin/faxrcvd
hylafax/bin/mkcover
hylafax/bin/notify
hylafax/bin/notify-4.1
hylafax/bin/pcl2fax
@unexec if [ -f %D/hylafax/bin/pdf2fax ]; then rm %D/hylafax/bin/pdf2fax; fi
hylafax/bin/pdf2fax.gs
hylafax/bin/pcl2fax
hylafax/bin/pollrcvd
@unexec if [ -f %D/hylafax/bin/ps2fax ]; then rm %D/hylafax/bin/ps2fax; fi
hylafax/bin/ps2fax.dps
@ -267,7 +272,6 @@ hylafax/config/zyxel-2864
@exec mkdir %D/hylafax/dev
@exec chown uucp:dialer %D/hylafax/dev
@exec chmod 0755 %D/hylafax/dev
@unexec if [ -f %D/hylafax/dev/null ]; then rm %D/hylafax/dev/null; fi
@exec mkdir %D/hylafax/docq
@exec chown uucp:dialer %D/hylafax/docq
@exec chmod 0700 %D/hylafax/docq
@ -279,9 +283,7 @@ hylafax/etc/dialrules
hylafax/etc/dialrules.europe
hylafax/etc/dialrules.sf-ba
hylafax/etc/dpsprinter.ps
hylafax/etc/hosts.hfaxd
hylafax/etc/lutRS18.pcf
hylafax/etc/xferfaxlog
@exec mkdir %D/hylafax/info
@exec chown uucp:dialer %D/hylafax/info
@exec chmod 755 %D/hylafax/info
@ -303,19 +305,14 @@ hylafax/etc/xferfaxlog
@exec mkdir %D/hylafax/tmp
@exec chown uucp:dialer %D/hylafax/tmp
@exec chmod 700 %D/hylafax/tmp
@dirrm hylafax/archive
@dirrm hylafax/bin
@dirrm hylafax/client
@dirrm hylafax/config
@dirrm hylafax/dev
@dirrm hylafax/docq
@dirrm hylafax/doneq
@dirrm hylafax/etc
@dirrm hylafax/info
@dirrm hylafax/log
@dirrm hylafax/pollq
@dirrm hylafax/recvq
@dirrm hylafax/sendq
@dirrm hylafax/status
@dirrm hylafax/tmp
@dirrm hylafax
@unexec rmdir %D/hylafax 2>/dev/null || echo "If you are permanently removing this port, you should do a ''rm -rf /var/spool/hylafax'' to remove any binary, configuration and log files left." | fmt
@unexec echo "-----------------"