Support staging.

Poked by:	bapt
Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2014-03-25 15:20:34 +00:00
parent 78c9c144e5
commit ebb3dd1acc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=349153
3 changed files with 22 additions and 37 deletions

View file

@ -3,16 +3,18 @@
PORTNAME= SGMLSpm
PORTVERSION= 1.03
DISTVERSIONSUFFIX= ii
PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= SGMLS
MASTER_SITES= CPAN/SGMLS
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION}ii
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for postprocessing the output from sgmls and nsgmls
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_PERL5= run
USES= shebangfix perl5
NO_BUILD= yes
@ -22,30 +24,16 @@ SHEBANG_FILES= sgmlspl.pl \
DOC/HTML/SGMLSpm/sample.pl \
DOC/HTML/SGMLSpm/example.html
INSTALL_TARGET= install BINDIR=${PREFIX}/bin \
PERL5DIR=${SITE_PERL} SPECDIR=${EXAMPLESDIR}
NO_STAGE= yes
INSTALL_TARGET= install BINDIR=${STAGEDIR}${PREFIX}/bin \
PERL5DIR=${STAGEDIR}${SITE_PERL} SPECDIR=${STAGEDIR}${EXAMPLESDIR}
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
PORTDOCS= *
.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
INSTALL_TARGET+=docs install_html HTMLDIR=${DOCSDIR}
.endif
DOCS_INSTALL_TARGET= docs install_html HTMLDIR=${STAGEDIR}${DOCSDIR}
.if ! ${PORT_OPTIONS:MEXAMPLES}
EXTRA_PATCHES= ${PATCHDIR}/noportexamples-patch-Makefile
.endif
pre-su-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
.endif
pre-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

View file

@ -1,12 +0,0 @@
--- ./Makefile.orig 2008-06-13 18:15:13.832720857 +0300
+++ ./Makefile 2008-06-13 18:15:23.574652218 +0300
@@ -41,8 +41,7 @@
FILES = ${BINDIR}/sgmlspl \
${PERL5DIR}/SGMLS.pm \
${MODULEDIR}/Output.pm \
- ${MODULEDIR}/Refs.pm \
- ${SPECDIR}/skel.pl
+ ${MODULEDIR}/Refs.pm
all: install docs

View file

@ -1,5 +1,5 @@
--- Makefile.orig Tue May 4 10:39:40 2004
+++ Makefile Tue May 4 10:39:57 2004
--- ./Makefile.orig 1995-12-05 13:26:11.000000000 +0100
+++ ./Makefile 2014-03-25 15:52:27.000000000 +0100
@@ -36,7 +36,7 @@
# End of user options.
#
@ -9,3 +9,12 @@
FILES = ${BINDIR}/sgmlspl \
${PERL5DIR}/SGMLS.pm \
@@ -62,7 +62,7 @@
${MODULEDIR}:
if [ ! -d ${MODULEDIR} ]; then\
- mkdir ${MODULEDIR}; \
+ mkdir -p ${MODULEDIR}; \
chmod a+x ${MODULEDIR}; \
fi