databases/db: update to 1.26 and simplify

ChangeLog: http://cvsweb.netbsd.org/bsdweb.cgi/src/usr.bin/db/db.c

PR:	257930
Reported by:	freebsd@oldach.net
This commit is contained in:
Helge Oldach 2021-08-19 12:57:43 +02:00 committed by Fernando Apesteguía
parent 47af927eed
commit ebb7c74c21
5 changed files with 22 additions and 67 deletions

View file

@ -1,34 +1,33 @@
# Created by: Edwin Groothuis (edwin@mavetju.org)
PORTNAME= db
PORTVERSION= 1.16
PORTVERSION= 1.26
PORTEPOCH= 2
CATEGORIES= databases
MASTER_SITES= http://www.mavetju.org/download/
MASTER_SITES= https://ftp.netbsd.org/pub/NetBSD/NetBSD-current/src/usr.bin/db/
DISTFILES= Makefile db.c db.1
DIST_SUBDIR= ${PKGNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Manipulate db(3)'s btree(3) and hash(3) databases - NetBSD port
LICENSE= BSD4CLAUSE
USES= uidfix
MAKE_ENV= BINDIR=${PREFIX}/bin SHAREDIR=${PREFIX}
CFLAGS+= -D__dead=""
DIST_CVS= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/src/usr.bin/db/db
DB1VERSION= 1.19
MAKEVERSION= 1.2
DIST_DB1= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/src/usr.bin/db/db.1?rev=${DB1VERSION}&content-type=text/plain&only_with_tag=HEAD
DIST_DBC= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/src/usr.bin/db/db.c?rev=${PORTVERSION}&content-type=text/plain
DIST_MAKEFILE= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/src/usr.bin/db/Makefile?rev=${MAKEVERSION}&content-type=text/plain
NO_WRKSUBDIR= yes
PLIST_FILES= bin/db \
man/man1/db.1.gz
tarball:
do-extract:
${MKDIR} ${WRKSRC}
fetch -o ${WRKSRC}/db.1 "${DIST_DB1}"
fetch -o ${WRKSRC}/db.c "${DIST_DBC}"
fetch -o ${WRKSRC}/Makefile "${DIST_MAKEFILE}"
cd ${WRKDIR} && ${TAR} zcvf ${DISTFILES} ${PORTNAME}-${PORTVERSION}
${MV} ${WRKDIR}/${DISTFILES} ${DISTDIR}
. for distfile in ${DISTFILES}
${CP} ${_DISTDIR}/${distfile} ${WRKSRC}
. endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/db ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/db.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>

View file

@ -1,3 +1,7 @@
TIMESTAMP = 1612663351
SHA256 (db-1.16.tar.gz) = e2cc18621932fb9769ef4fdf17a538e619a358ec0ab14c085c666b022afef359
SIZE (db-1.16.tar.gz) = 6860
TIMESTAMP = 1629369890
SHA256 (db-1.26,2/Makefile) = fd19fa7f61662f92826dd7bdb734767f28e82634746363bf84db3a395b4064d9
SIZE (db-1.26,2/Makefile) = 128
SHA256 (db-1.26,2/db.c) = afcba6fe3bccc2fd14f9525ad386847a0f689f643fe22ebd7d598d5a5b1be44b
SIZE (db-1.26,2/db.c) = 16971
SHA256 (db-1.26,2/db.1) = dc6a135fa61041700b2889b8bbea286ebdbd452535eb63b6c359e51cd16e9f80
SIZE (db-1.26,2/db.1) = 7257

View file

@ -1,26 +0,0 @@
--- db.1.orig 2005-06-20 02:53:38 UTC
+++ db.1
@@ -67,8 +67,6 @@ databases
.Op Fl T Ar visspec
.Ek
.Bk -words
-.Op Fl X Ar extravis
-.Ek
.Ar type
.Ar dbfile
.Bk -words
@@ -266,14 +264,6 @@ corresponding options for the meaning of
.It Fl V
Display value.
.
-.It Fl X Ar extravis
-When encoding items with
-.Fl S
-option also encode characters in
-.Ar extravis ,
-per
-.Xr svis 3 .
-.
.El
.Pp
.Bd -ragged -offset indent

View file

@ -1,18 +0,0 @@
--- db.c.orig 2005-06-20 02:53:38 UTC
+++ db.c
@@ -551,11 +551,11 @@ encode_data(size_t len, char *data, char
buflen = elen;
}
*edata = buf;
- if (extra_echars) {
- return (strsvisx(buf, data, len, encflags, extra_echars));
- } else {
+// if (extra_echars) {
+// return (strsvisx(buf, data, len, encflags, extra_echars));
+// } else {
return (strvisx(buf, data, len, encflags));
- }
+// }
}
int

View file

@ -1,7 +1,3 @@
db allows manipulation of btree(3) and hash(3) (db(3)) databases.
See NetBSD Problem Report #39254
(http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=39254) for
the issues with the version 1.15 and higher.
WWW: http://cvsweb.netbsd.org/bsdweb.cgi/src/usr.bin/db/