Remove expired port:

2014-04-05 www/privoxy+ipv6: www/privoxy natively supports ipv6
This commit is contained in:
Rene Ladan 2014-04-06 11:00:29 +00:00
parent 8837b7122d
commit ebfba9aea8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=350349
9 changed files with 1 additions and 204 deletions

1
MOVED
View file

@ -5879,3 +5879,4 @@ databases/aolserver-nsmysql||2014-04-03|Has expired: abandonware, messing up on
security/aolserver-nssha1||2014-04-03|Has expired: abandonware, messing up on clusters
www/webobjects||2014-04-04|Has expired: Unmaintained, interactive and restricted
devel/p5-Devel-LeakTrace-Fast||2014-04-04|Has expired: Broken for more than 6 months
www/privoxy+ipv6|www/privoxy|2014-04-06|Has expired: www/privoxy natively supports ipv6

View file

@ -1460,7 +1460,6 @@
SUBDIR += pound
SUBDIR += prado
SUBDIR += privoxy
SUBDIR += privoxy+ipv6
SUBDIR += protovis
SUBDIR += pserv
SUBDIR += publicfile

View file

@ -1,45 +0,0 @@
# Created by: Lars Eggert
# $FreeBSD$
PORTNAME= privoxy+ipv6
PORTVERSION= 20030523
PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.deepspace6.net/pub/ds6/sources/privoxy/
DISTNAME= privoxy_CVS_${PORTVERSION}_ipv6_5
MAINTAINER= lars.eggert@gmx.net
COMMENT= Privoxy is a web proxy with advanced filtering capabilities
DEPRECATED= www/privoxy natively supports ipv6
EXPIRATION_DATE= 2014-04-05
WRKSRC= ${WRKDIR}/privoxy
ETCDIR= ${PREFIX}/etc/privoxy
USER= nobody
GROUP= nobody
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/+ipv6//}
USES= gmake tar:bzip2
USE_AUTOTOOLS= autoheader213
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-user=${USER} --with-group=${GROUP} \
--sysconfdir=${ETCDIR} --localstatedir=/var
MAKEFILE= GNUmakefile
MAN1= privoxy.1
NO_STAGE= yes
post-install:
@for file in config user.action; do \
if [ ! -f ${ETCDIR}/$$file ]; then \
${CP} ${ETCDIR}/$$file.sample ${ETCDIR}/$$file; \
${CHOWN} ${USER}:${GROUP} ${ETCDIR}/$$file; \
${CHMOD} ug+rw ${ETCDIR}/$$file; \
fi; \
done
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (privoxy_CVS_20030523_ipv6_5.tar.bz2) = 33c413adafb317ea3db03725be7697f78e782ea990035cfa72f9d1b902d22c84
SIZE (privoxy_CVS_20030523_ipv6_5.tar.bz2) = 1899788

View file

@ -1,26 +0,0 @@
--- G Wed Jul 30 09:43:10 2003
+++ GNUmakefile.in Wed Jul 30 09:46:00 2003
@@ -174,7 +174,7 @@
#############################################################################
# We include these files in our distributions
#############################################################################
-CONFIGS = config trust default.action standard.action user.action default.filter
+CONFIGS = config.sample trust default.action standard.action user.action.sample default.filter
# take care that no CVS .cvsignore or other crappy files
# are included here
# and escape every '#' in the find. doh.
@@ -945,10 +945,12 @@
$(CAT) config >config~ ;\
$(MV) config.base config ;\
fi
- $(SED) 's+confdir .+confdir $(CONF_DEST)+' config | \
- $(SED) 's+logdir .+logdir $(LOG_DEST)+' >config.updated
+ $(SED) 's+confdir .*+confdir $(CONF_DEST)+' config | \
+ $(SED) 's+logdir .*+logdir $(LOG_DEST)+' >config.updated
$(MV) config config.base
$(MV) config.updated config
+ $(MV) config config.sample
+ $(CP) user.action user.action.sample
@# Install the config support files. Test for root install, and abort
@# if there is no privoxy user, and no other user or group was enabled

View file

@ -1,13 +0,0 @@
--- src/addrlist.c- Fri Oct 3 12:12:29 2003
+++ src/addrlist.c Fri Oct 3 12:12:32 2003
@@ -40,9 +40,8 @@
*
*********************************************************************/
-#include "addrlist.h"
#include <sys/types.h>
-#include <sys/socket.h>
+#include "addrlist.h"
#include <netdb.h>
#include <string.h>

View file

@ -1,11 +0,0 @@
Privoxy is a web proxy with advanced filtering capabilities for protecting
privacy, filtering web page content, managing cookies, controlling access,
and removing ads, banners, pop-ups and other obnoxious Internet junk.
Privoxy has a very flexible configuration and can be customized to suit
individual needs and tastes. Privoxy has application for both stand-alone
systems and multi-user networks.
This is a port of Lionel Mamane's patched CVS version that supports IPv6.
WWW: http://www.privoxy.org/
WWW: http://www.deepspace6.net/sections/sources.html

View file

@ -1,10 +0,0 @@
***********************************************************
** Before running privoxy you must modify the file **
** %%PREFIX%%/etc/privoxy/config **
** **
** Start privoxy with: **
** %%PREFIX%%/sbin/privoxy %%PREFIX%%/etc/privoxy/config **
** **
** For documentation see: **
** %%PREFIX%%/share/doc/privoxy-manual or 'man privoxy' **
***********************************************************

View file

@ -1,96 +0,0 @@
@unexec cmp %D/etc/privoxy/config.sample %D/etc/privoxy/config && rm %D/etc/privoxy/config
@unexec cmp %D/etc/privoxy/user.action.sample %D/etc/privoxy/user.action && rm %D/etc/privoxy/user.action
etc/privoxy/config.sample
etc/privoxy/default.action
etc/privoxy/default.filter
etc/privoxy/standard.action
etc/privoxy/templates/Entries
etc/privoxy/templates/Repository
etc/privoxy/templates/Root
etc/privoxy/templates/blocked
etc/privoxy/templates/cgi-error-404
etc/privoxy/templates/cgi-error-bad-param
etc/privoxy/templates/cgi-error-disabled
etc/privoxy/templates/cgi-error-file
etc/privoxy/templates/cgi-error-file-read-only
etc/privoxy/templates/cgi-error-modified
etc/privoxy/templates/cgi-error-parse
etc/privoxy/templates/cgi-style.css
etc/privoxy/templates/connect-failed
etc/privoxy/templates/default
etc/privoxy/templates/edit-actions-add-url-form
etc/privoxy/templates/edit-actions-for-url
etc/privoxy/templates/edit-actions-for-url-filter
etc/privoxy/templates/edit-actions-list
etc/privoxy/templates/edit-actions-list-button
etc/privoxy/templates/edit-actions-list-section
etc/privoxy/templates/edit-actions-list-url
etc/privoxy/templates/edit-actions-remove-url-form
etc/privoxy/templates/edit-actions-url-form
etc/privoxy/templates/mod-local-help
etc/privoxy/templates/mod-support-and-service
etc/privoxy/templates/mod-title
etc/privoxy/templates/mod-unstable-warning
etc/privoxy/templates/no-such-domain
etc/privoxy/templates/show-request
etc/privoxy/templates/show-status
etc/privoxy/templates/show-status-file
etc/privoxy/templates/show-url-info
etc/privoxy/templates/show-version
etc/privoxy/templates/toggle
etc/privoxy/templates/toggle-mini
etc/privoxy/templates/untrusted
etc/privoxy/trust
etc/privoxy/user.action.sample
sbin/privoxy
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/LICENSE
%%DOCSDIR%%/README
%%DOCSDIR%%/developer-manual/coding.html
%%DOCSDIR%%/developer-manual/contact.html
%%DOCSDIR%%/developer-manual/copyright.html
%%DOCSDIR%%/developer-manual/cvs.html
%%DOCSDIR%%/developer-manual/documentation.html
%%DOCSDIR%%/developer-manual/index.html
%%DOCSDIR%%/developer-manual/introduction.html
%%DOCSDIR%%/developer-manual/newrelease.html
%%DOCSDIR%%/developer-manual/seealso.html
%%DOCSDIR%%/developer-manual/testing.html
%%DOCSDIR%%/developer-manual/webserver-update.html
%%DOCSDIR%%/faq/configuration.html
%%DOCSDIR%%/faq/contact.html
%%DOCSDIR%%/faq/copyright.html
%%DOCSDIR%%/faq/general.html
%%DOCSDIR%%/faq/index.html
%%DOCSDIR%%/faq/installation.html
%%DOCSDIR%%/faq/misc.html
%%DOCSDIR%%/faq/trouble.html
%%DOCSDIR%%/images/files-in-use.jpg
%%DOCSDIR%%/images/proxy_setup.jpg
%%DOCSDIR%%/index.html
%%DOCSDIR%%/man-page/privoxy-man-page.html
%%DOCSDIR%%/p_doc.css
%%DOCSDIR%%/user-manual/actions-file.html
%%DOCSDIR%%/user-manual/appendix.html
%%DOCSDIR%%/user-manual/config.html
%%DOCSDIR%%/user-manual/configuration.html
%%DOCSDIR%%/user-manual/contact.html
%%DOCSDIR%%/user-manual/copyright.html
%%DOCSDIR%%/user-manual/filter-file.html
%%DOCSDIR%%/user-manual/index.html
%%DOCSDIR%%/user-manual/installation.html
%%DOCSDIR%%/user-manual/introduction.html
%%DOCSDIR%%/user-manual/quickstart.html
%%DOCSDIR%%/user-manual/seealso.html
%%DOCSDIR%%/user-manual/startup.html
%%DOCSDIR%%/user-manual/templates.html
%%DOCSDIR%%/user-manual/upgradersnote.html
@dirrm etc/privoxy/templates
@dirrmtry etc/privoxy
@dirrm %%DOCSDIR%%/developer-manual
@dirrm %%DOCSDIR%%/faq
@dirrm %%DOCSDIR%%/images
@dirrm %%DOCSDIR%%/man-page
@dirrm %%DOCSDIR%%/user-manual
@dirrm %%DOCSDIR%%