Fix build on -CURRENT by tweaking #include order.

This commit is contained in:
Christian Weisgerber 2002-12-18 22:00:44 +00:00
parent 69a4ec2aff
commit ec28692edb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71716
2 changed files with 16 additions and 7 deletions

View file

@ -21,14 +21,8 @@ MAN1= gopher.1 gophfilt.1
MAN5= gopherd.conf.5 gopherrc.5
MAN8= gopherd.8 gopherindex.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
BROKEN= "Does not compile"
.endif
pre-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | xargs ${REINPLACE_CMD} -e \
's,<malloc.h>,<stdlib.h>,'
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,15 @@
$FreeBSD$
--- object/Regex.c.orig Wed Dec 18 22:49:17 2002
+++ object/Regex.c Wed Dec 18 22:49:29 2002
@@ -51,8 +51,8 @@
#define REGEX_CODEIT /* only include sysv regex code once.. */
#include "config.h"
-#include "Regex.h"
#include "Malloc.h"
+#include "Regex.h"
/**************************************************
POSIX