- Fix conflicting info files with editors/emacs

Reported by:	marino via IRC
This commit is contained in:
Marcus von Appen 2013-04-23 15:33:16 +00:00
parent 716717649a
commit ec4cb63ce5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=316364
6 changed files with 83 additions and 17 deletions

View file

@ -1,13 +1,9 @@
# New ports collection makefile for: cedet # Created by: Dryice Liu
# Date created: 2004-02-28
# Whom: Dryice Liu
#
# $FreeBSD$ # $FreeBSD$
#
PORTNAME= cedet PORTNAME= cedet
PORTVERSION= 1.1 PORTVERSION= 1.1
PORTREVISION= 4 PORTREVISION= 5
CATEGORIES= devel elisp CATEGORIES= devel elisp
MASTER_SITES= SF/${PORTNAME}/${PORTNAME} MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
PKGNAMESUFFIX= -${EMACS_PORT_NAME} PKGNAMESUFFIX= -${EMACS_PORT_NAME}
@ -21,14 +17,14 @@ USE_GMAKE= yes
CEDET_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME} CEDET_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
INFO= bovine cogre ede-cedet eieio-cedet grammar-fw semantic-cedet \ INFO= bovine-cedet cogre ede-cedet eieio-cedet grammar-fw \
semantic-appdev semantic-langdev semantic-user \ semantic-cedet semantic-appdev semantic-langdev semantic-user \
wisent speedbar-cedet srecode wisent-cedet speedbar-cedet srecode-cedet
SEMANTIC_ELISP_SUBDIRS= bovine wisent SEMANTIC_ELISP_SUBDIRS= bovine wisent
SEMANTIC_INFOS= bovine.info grammar-fw.info semantic-appdev.info \ SEMANTIC_INFOS= bovine-cedet.info grammar-fw.info semantic-appdev.info \
semantic-langdev.info semantic-user.info semantic-cedet.info \ semantic-langdev.info semantic-user.info semantic-cedet.info \
wisent.info wisent-cedet.info
CONFLICTS= eieio-[0-9]* semantic-[0-9]* speedbar-[0-9]* CONFLICTS= eieio-[0-9]* semantic-[0-9]* speedbar-[0-9]*
@ -112,7 +108,7 @@ do-install:
.for i in *.srt .for i in *.srt
${INSTALL_DATA} ${WRKSRC}/srecode/templates/${i} ${CEDET_LISPDIR}/srecode/templates ${INSTALL_DATA} ${WRKSRC}/srecode/templates/${i} ${CEDET_LISPDIR}/srecode/templates
.endfor .endfor
${INSTALL_DATA} ${WRKSRC}/srecode/srecode.info ${PREFIX}/info ${INSTALL_DATA} ${WRKSRC}/srecode/srecode-cedet.info ${PREFIX}/info
#contrib #contrib
${MKDIR} ${CEDET_LISPDIR}/contrib ${MKDIR} ${CEDET_LISPDIR}/contrib

View file

@ -1,5 +1,5 @@
--- semantic/doc/Makefile.orig 2010-05-17 18:57:36.000000000 +0200 --- semantic/doc/Makefile.orig 2012-04-15 17:28:43.000000000 +0200
+++ semantic/doc/Makefile 2010-05-17 18:59:11.000000000 +0200 +++ semantic/doc/Makefile 2013-04-21 16:51:13.000000000 +0200
@@ -11,7 +11,7 @@ @@ -11,7 +11,7 @@
images_MISC=grammar-fw-ov.png grammar-fw-ov.txt images_MISC=grammar-fw-ov.png grammar-fw-ov.txt
@ -14,7 +14,7 @@
-all: images grammar-fw.info semantic.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine.info wisent.info -all: images grammar-fw.info semantic.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine.info wisent.info
+all: images grammar-fw.info semantic-cedet.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine.info wisent.info +all: images grammar-fw.info semantic-cedet.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine-cedet.info wisent-cedet.info
images: images:
@ @
@ -27,15 +27,28 @@
$(MAKEINFO) $< $(MAKEINFO) $<
semantic-user.info: $(semantic-user_info_TEXINFOS) semantic-user.info: $(semantic-user_info_TEXINFOS)
@@ -43,10 +43,10 @@
semantic-langdev.info: $(semantic-langdev_info_TEXINFOS)
$(MAKEINFO) $<
-bovine.info: $(bovine_info_TEXINFOS)
+bovine-cedet.info: $(bovine_info_TEXINFOS)
$(MAKEINFO) $<
-wisent.info: $(wisent_info_TEXINFOS)
+wisent-cedet.info: $(wisent_info_TEXINFOS)
$(MAKEINFO) $<
tags:
@@ -57,9 +57,9 @@ @@ -57,9 +57,9 @@
.PHONY: dist .PHONY: dist
-dist: grammar-fw.info semantic.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine.info wisent.info -dist: grammar-fw.info semantic.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine.info wisent.info
+dist: grammar-fw.info semantic-cedet.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine.info wisent.info +dist: grammar-fw.info semantic-cedet.info semantic-user.info semantic-appdev.info semantic-langdev.info bovine-cedet.info wisent-cedet.info
mkdir $(DISTDIR) mkdir $(DISTDIR)
- cp $(images_MISC) $(semantic-grammar_TEXINFOS) grammar-fw.info* $(Documentation_TEXINFOS) semantic.info* $(semantic-user_info_TEXINFOS) semantic-user.info* $(semantic-appdev_info_TEXINFOS) semantic-appdev.info* $(semantic-langdev_info_TEXINFOS) semantic-langdev.info* $(bovine_info_TEXINFOS) bovine.info* $(wisent_info_TEXINFOS) wisent.info* $(ede_FILES) $(DISTDIR) - cp $(images_MISC) $(semantic-grammar_TEXINFOS) grammar-fw.info* $(Documentation_TEXINFOS) semantic.info* $(semantic-user_info_TEXINFOS) semantic-user.info* $(semantic-appdev_info_TEXINFOS) semantic-appdev.info* $(semantic-langdev_info_TEXINFOS) semantic-langdev.info* $(bovine_info_TEXINFOS) bovine.info* $(wisent_info_TEXINFOS) wisent.info* $(ede_FILES) $(DISTDIR)
+ cp $(images_MISC) $(semantic-grammar_TEXINFOS) grammar-fw.info* $(Documentation_TEXINFOS) semantic-cedet.info* $(semantic-user_info_TEXINFOS) semantic-user.info* $(semantic-appdev_info_TEXINFOS) semantic-appdev.info* $(semantic-langdev_info_TEXINFOS) semantic-langdev.info* $(bovine_info_TEXINFOS) bovine.info* $(wisent_info_TEXINFOS) wisent.info* $(ede_FILES) $(DISTDIR) + cp $(images_MISC) $(semantic-grammar_TEXINFOS) grammar-fw.info* $(Documentation_TEXINFOS) semantic-cedet.info* $(semantic-user_info_TEXINFOS) semantic-user.info* $(semantic-appdev_info_TEXINFOS) semantic-appdev.info* $(semantic-langdev_info_TEXINFOS) semantic-langdev.info* $(bovine_info_TEXINFOS) bovine-cedet.info* $(wisent_info_TEXINFOS) wisent-cedet.info* $(ede_FILES) $(DISTDIR)
Makefile: Project.ede Makefile: Project.ede
@echo Makefile is out of date! It needs to be regenerated by EDE. @echo Makefile is out of date! It needs to be regenerated by EDE.

View file

@ -0,0 +1,12 @@
--- semantic/doc/bovine.texi.orig 2012-04-15 17:28:43.000000000 +0200
+++ semantic/doc/bovine.texi 2013-04-21 16:30:15.000000000 +0200
@@ -1,7 +1,7 @@
\input texinfo @c -*-texinfo-*-
@c %**start of header
-@setfilename bovine.info
-@set TITLE Bovine parser development
+@setfilename bovine-cedet.info
+@set TITLE Bovine parser development (cedet version)
@set AUTHOR Eric M. Ludlam, David Ponce, and Richard Y. Kim
@settitle @value{TITLE}

View file

@ -0,0 +1,12 @@
--- semantic/doc/wisent.texi.orig 2013-04-21 16:52:26.000000000 +0200
+++ semantic/doc/wisent.texi 2013-04-21 16:50:29.000000000 +0200
@@ -1,7 +1,7 @@
\input texinfo @c -*-texinfo-*-
@c %**start of header
-@setfilename wisent.info
-@set TITLE Wisent Parser Development
+@setfilename wisent-cedet.info
+@set TITLE Wisent Parser Development (cedet version)
@set AUTHOR Eric M. Ludlam, David Ponce, and Richard Y. Kim
@settitle @value{TITLE}

View file

@ -0,0 +1,20 @@
--- srecode/Makefile.orig 2013-04-21 16:46:26.000000000 +0200
+++ srecode/Makefile 2013-04-21 16:46:51.000000000 +0200
@@ -29,7 +29,7 @@
-all: autoloads lang srecode srecode.info tests document templates
+all: autoloads lang srecode srecode-cedet.info tests document templates
.PHONY: autoloads
autoloads:
@@ -62,7 +62,7 @@
@echo "(setq debug-on-error t)" >> $@-compile-script
"$(EMACS)" $(EMACSFLAGS) -l $@-compile-script -f batch-byte-compile $^
-srecode.info: $(doc_TEXINFOS)
+srecode-cedet.info: $(doc_TEXINFOS)
$(MAKEINFO) $<
.PHONY: tests

View file

@ -0,0 +1,13 @@
--- srecode/srecode.texi.orig 2013-04-21 16:48:19.000000000 +0200
+++ srecode/srecode.texi 2013-04-21 16:47:13.000000000 +0200
@@ -3,8 +3,8 @@
@c $Id: srecode.texi,v 1.24 2010-05-30 20:22:40 scymtym Exp $
@c
@c %**start of header
-@setfilename srecode.info
-@set TITLE SRecoder Manual
+@setfilename srecode-cedet.info
+@set TITLE SRecoder Manual (cedet version)
@set AUTHOR Eric M. Ludlam
@settitle @value{TITLE}
@c %**end of header