Add scigraphica - a scientific application for data analysis and technical
graphics for Gnome desktop.
This commit is contained in:
parent
05f612a149
commit
ec85bad9f6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32100
7 changed files with 125 additions and 0 deletions
|
@ -55,6 +55,7 @@
|
|||
SUBDIR += rng
|
||||
SUBDIR += ruby-bigfloat
|
||||
SUBDIR += sc
|
||||
SUBDIR += scigraphica
|
||||
SUBDIR += siag
|
||||
SUBDIR += simpack
|
||||
SUBDIR += slsc
|
||||
|
|
42
math/scigraphica/Makefile
Normal file
42
math/scigraphica/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# New ports collection makefile for: scigraphica
|
||||
# Date created: 29 August 2000
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= scigraphica
|
||||
PORTVERSION= 0.4
|
||||
CATEGORIES= math gnome
|
||||
MASTER_SITES= http://magnet.fsu.edu/~feiguin/scigraphica/src/
|
||||
DISTNAME= sg-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
|
||||
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
|
||||
gtkextra.10:${PORTSDIR}/x11-toolkits/gtkextra \
|
||||
xml.5:${PORTSDIR}/textproc/libxml
|
||||
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
|
||||
python:${PORTSDIR}/lang/python
|
||||
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
|
||||
--datadir=${PREFIX}/share/gnome
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
GTK_CONFIG="${GTK_CONFIG}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
|
||||
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
|
||||
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
|
||||
|
||||
.include <bsd.port.mk>
|
1
math/scigraphica/distinfo
Normal file
1
math/scigraphica/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (sg-0.4.tar.gz) = f7a7faeff2942451a82e57a8b923e441
|
11
math/scigraphica/files/patch-ac
Normal file
11
math/scigraphica/files/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure 2000/08/29 12:12:11 1.1
|
||||
+++ configure 2000/08/29 12:13:43
|
||||
@@ -3409,7 +3409,7 @@
|
||||
PY_VERSION=`python -c 'import sys ; print sys.version[0:3]'`
|
||||
if test -f $PY_PREFIX/include/python$PY_VERSION/Python.h; then
|
||||
PY_LIBS="python$PY_VERSION"
|
||||
- PY_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
|
||||
+ PY_LIB_LOC="-pthread -L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
|
||||
array_loc=`find $PY_PREFIX/include/python$PY_VERSION/ -name arrayobject.h -printf %h`
|
||||
echo arrayobject.h location: $array_loc
|
||||
PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
|
1
math/scigraphica/pkg-comment
Normal file
1
math/scigraphica/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A scientific application for data analysis and technical graphics
|
20
math/scigraphica/pkg-descr
Normal file
20
math/scigraphica/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
|||
SciGraphica is a scientific application for data analysis and technical
|
||||
graphics. It pretends to be a clone of the popular commercial (and expensive)
|
||||
application "Microcal Origin". Although it is in a very early development
|
||||
stage, it fully supplies plotting features for 2D charts. The aim is to obtain
|
||||
a fully-featured, cross-plattform, user-friendly, self-growing scientific
|
||||
application. It is free and open-source, released under the GPL license.
|
||||
|
||||
Main features:
|
||||
--------------
|
||||
o You can open several worksheets and plots and work with them at the same
|
||||
time.
|
||||
o The plots are fully configurable using a control panel dialog.
|
||||
o The look and feel is completely WYSIWYG.
|
||||
o Publication quality PostScript output.
|
||||
o You can interact with the plots double-clicking, dragging and moving objects
|
||||
with the mouse.
|
||||
o Import/Export features in XML format.
|
||||
o You can insert Python expressions in the worksheets.
|
||||
|
||||
WWW: http://magnet.fsu.edu/~feiguin/scigraphica/
|
49
math/scigraphica/pkg-plist
Normal file
49
math/scigraphica/pkg-plist
Normal file
|
@ -0,0 +1,49 @@
|
|||
bin/sga
|
||||
share/gnome/apps/Applications/sg.desktop
|
||||
share/gnome/pixmaps/sg/arrow.xpm
|
||||
share/gnome/pixmaps/sg/arrow2.xpm
|
||||
share/gnome/pixmaps/sg/arrow_down.xpm
|
||||
share/gnome/pixmaps/sg/arrow_left.xpm
|
||||
share/gnome/pixmaps/sg/arrow_right.xpm
|
||||
share/gnome/pixmaps/sg/arrow_up.xpm
|
||||
share/gnome/pixmaps/sg/autoscale.xpm
|
||||
share/gnome/pixmaps/sg/bold.xpm
|
||||
share/gnome/pixmaps/sg/bullet.xpm
|
||||
share/gnome/pixmaps/sg/center.xpm
|
||||
share/gnome/pixmaps/sg/color.xpm
|
||||
share/gnome/pixmaps/sg/dennied.xpm
|
||||
share/gnome/pixmaps/sg/empty.xpm
|
||||
share/gnome/pixmaps/sg/error.xpm
|
||||
share/gnome/pixmaps/sg/fitpage.xpm
|
||||
share/gnome/pixmaps/sg/folder.xpm
|
||||
share/gnome/pixmaps/sg/font.xpm
|
||||
share/gnome/pixmaps/sg/font_large.xpm
|
||||
share/gnome/pixmaps/sg/italic.xpm
|
||||
share/gnome/pixmaps/sg/layer.xpm
|
||||
share/gnome/pixmaps/sg/left.xpm
|
||||
share/gnome/pixmaps/sg/logo.xpm
|
||||
share/gnome/pixmaps/sg/new.xpm
|
||||
share/gnome/pixmaps/sg/new_plot.xpm
|
||||
share/gnome/pixmaps/sg/new_sheet.xpm
|
||||
share/gnome/pixmaps/sg/open.xpm
|
||||
share/gnome/pixmaps/sg/paint.xpm
|
||||
share/gnome/pixmaps/sg/plot_icon.xpm
|
||||
share/gnome/pixmaps/sg/plot_icon2.xpm
|
||||
share/gnome/pixmaps/sg/plot_small.xpm
|
||||
share/gnome/pixmaps/sg/point.xpm
|
||||
share/gnome/pixmaps/sg/pointers.xpm
|
||||
share/gnome/pixmaps/sg/right.xpm
|
||||
share/gnome/pixmaps/sg/save.xpm
|
||||
share/gnome/pixmaps/sg/save_as.xpm
|
||||
share/gnome/pixmaps/sg/sg.xpm
|
||||
share/gnome/pixmaps/sg/sg_icon.xpm
|
||||
share/gnome/pixmaps/sg/sheet_icon.xpm
|
||||
share/gnome/pixmaps/sg/sheet_icon2.xpm
|
||||
share/gnome/pixmaps/sg/sorry.xpm
|
||||
share/gnome/pixmaps/sg/target.xpm
|
||||
share/gnome/pixmaps/sg/text.xpm
|
||||
share/gnome/pixmaps/sg/warning.xpm
|
||||
share/gnome/pixmaps/sg/zoom.xpm
|
||||
share/gnome/pixmaps/sg/zoom_minus.xpm
|
||||
share/gnome/pixmaps/sg/zoom_plus.xpm
|
||||
@dirrm share/gnome/pixmaps/sg
|
Loading…
Reference in a new issue