Upgrade to v370. The port now unconditionally depends on Cairo

graphics.  Additional upstream changes include:
 - The conservative garbage collector (CGC) has been replaced with a
   precise garbage collector (3m) in the standard build.  For most
   users, this change simply amounts to "better performance in space
   and time".  Use the port knob 'CGC' to build DrScheme with
   the conservative garbage collector.
 - Unit-based servlets are no longer supported in the web server.
   Use module-based servlets, instead.
 - A new `(lib "unit.ss")' library replaces the old one and provides
   a simpler and more flexible syntax.
 - The HtDP "world.ss" and "image.ss" teachpacks have been revised,
   including support for the creation of animated GIFs and DrScheme's
   teachpack GUI now works only with the HtDP languages.  In other
   languages, use `require' to access teachpacks.
This commit is contained in:
Joseph Koshy 2007-06-07 09:07:27 +00:00
parent ae92c46ef4
commit ec956c5dfb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=192990
5 changed files with 383 additions and 240 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= drscheme
PORTVERSION= 360
PORTREVISION= 1
PORTVERSION= 370
CATEGORIES= lang scheme
MASTER_SITES= http://download.plt-scheme.org/bundles/${PORTVERSION}/plt/ \
http://www.cs.utah.edu/plt/download/${PORTVERSION}/plt/ \
@ -24,13 +23,17 @@ MAINTAINER= jkoshy@FreeBSD.org
COMMENT= An interactive, integrated, graphical Scheme programming environment
LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft \
Xrender.1:${PORTSDIR}/x11/libXrender \
cairo.2:${PORTSDIR}/graphics/cairo \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared \
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared --enable-xft --enable-gl \
--enable-xrender --enable-cairo --with-x --enable-pthread \
--enable-lt=${LIBTOOL} \
--x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib \
--enable-lt=${LIBTOOL} CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include"
# Force the "configure" script to look in $LOCALBASE for -lpng and -ljpeg
@ -38,15 +41,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/plt-${PORTVERSION}/src
USE_ICONV= yes
USE_GL= yes
USE_LDCONFIG= yes
USE_XLIB= yes
USE_GL= yes
USE_AUTOTOOLS= libtool:15:env
MAN1= drscheme.1 help-desk.1 mred.1 mzscheme.1 tex2page.1
OPTIONS= CAIRO "use Cairo graphics" off \
MMM "use 3m garbage collection" off
OPTIONS= CGC "With CGC garbage collector" off
ONLY_FOR_ARCHS= i386 amd64
@ -56,19 +58,12 @@ PLTPATCHES= # none yet for this version
.include <bsd.port.pre.mk>
.if defined(WITH_CAIRO)
CONFIGURE_ARGS+= --enable-cairo --enable-pthread
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
.if defined(WITH_CGC)
ALL_TARGET= both
INSTALL_TARGET= install-both
PLIST_SUB+= CGC=""
.else
CONFIGURE_ARGS+= --disable-cairo
.endif
.if defined(WITH_MMM)
ALL_TARGET= 3m
INSTALL_TARGET+= install-3m
PLIST_SUB+= MMM=""
.else
PLIST_SUB+= MMM="@comment "
PLIST_SUB+= CGC="@comment "
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (drscheme/360/plt-360-src-unix.tgz) = 84bcab3ff30c333ae3c6b732518bdf27
SHA256 (drscheme/360/plt-360-src-unix.tgz) = 014cd5c91231a5b6dd67c90ca9d2c26a7466abe0d072a37a40a605b29870f3bd
SIZE (drscheme/360/plt-360-src-unix.tgz) = 14106005
MD5 (drscheme/370/plt-370-src-unix.tgz) = 481e4f7cc699668a96093942456da595
SHA256 (drscheme/370/plt-370-src-unix.tgz) = 844f788cb5995da2b2790eb076e212d59291217ee32957619e8ad629d3e5a8d3
SIZE (drscheme/370/plt-370-src-unix.tgz) = 14459769

View file

@ -1,36 +0,0 @@
--- configure.orig Mon Jul 17 15:23:27 2006
+++ configure Fri Nov 10 18:15:30 2006
@@ -5331,6 +5331,7 @@
;;
FreeBSD)
LIBS="$LIBS -rdynamic"
+ DYN_CFLAGS="-fPIC"
;;
OpenBSD)
LIBS="$LIBS -rdynamic"
@@ -11114,16 +11115,16 @@
plt_lib_version=`grep " MZSCHEME_VERSION " ${srcdir}/mzscheme/src/schvers.h | cut -d '"' -f 2`
fi
- AR="${LIBTOOLPROG} --mode=link $CC${need_gcc_static_libgcc}${ar_libtool_no_undefined} -release ${plt_lib_version} -rpath ${absprefix}/lib -o"
- STATIC_AR="${LIBTOOLPROG} --mode=link $CC -o"
+ AR="${LIBTOOLPROG} --mode=link --tag=CC $CC${need_gcc_static_libgcc}${ar_libtool_no_undefined} -release ${plt_lib_version} -rpath ${absprefix}/lib -o"
+ STATIC_AR="${LIBTOOLPROG} --mode=link --tag=CC $CC -o"
ARFLAGS=""
RANLIB=":"
- MZLINKER="${LIBTOOLPROG} --mode=link $CC${need_gcc_static_libgcc} -rpath ${absprefix}/lib"
- MREDLINKER="${LIBTOOLPROG} --mode=link $CXX${need_gcc_static_libgcc} -rpath ${absprefix}/lib"
+ MZLINKER="${LIBTOOLPROG} --mode=link --tag=CC $CC${need_gcc_static_libgcc} -rpath ${absprefix}/lib"
+ MREDLINKER="${LIBTOOLPROG} --mode=link --tag=CXX $CXX${need_gcc_static_libgcc} -rpath ${absprefix}/lib"
PLAIN_CC="$CC"
- CC="${LIBTOOLPROG} --mode=compile $CC"
- CXX="${LIBTOOLPROG} --mode=compile $CXX"
- AS="${LIBTOOLPROG} --mode=compile $AS"
+ CC="${LIBTOOLPROG} --mode=compile --tag=CC $CC"
+ CXX="${LIBTOOLPROG} --mode=compile --tag=CXX $CXX"
+ AS="${LIBTOOLPROG} --mode=compile --tag=AS $AS"
LIBSFX=la
WXLIBS=WXLIBSDYN
ICP="${LIBTOOLPROG} --mode=install cp"

View file

@ -1,10 +0,0 @@
--- foreign/gcc/libffi/configure.orig Mon Apr 17 22:28:43 2006
+++ foreign/gcc/libffi/configure Thu Sep 21 13:48:18 2006
@@ -5377,6 +5377,7 @@
TARGETDIR="unknown"
case "$host" in
+amd64-*-freebsd* ) TARGET=X86_64; TARGETDIR=x86;;
i*86-*-linux*) TARGET=X86; TARGETDIR=x86;;
i*86-*-gnu*) TARGET=X86; TARGETDIR=x86;;
i*86-*-solaris2.1[0-9]*) TARGET=X86_64; TARGETDIR=x86;;

File diff suppressed because it is too large Load diff