- Update to 1.7

- Switch maintainer to the submitter

PR:		ports/135950
Submitted by:	bf <bf1783@gmail.com>
Approved by:	old maintainer
This commit is contained in:
Pav Lucistnik 2009-06-30 13:49:05 +00:00
parent 1e399410b6
commit ecab794ccc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=236813
4 changed files with 25 additions and 24 deletions

View file

@ -6,30 +6,24 @@
#
PORTNAME= udis86
PORTVERSION= 1.4
PORTVERSION= 1.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lboehne@damogran.de
MAINTAINER= bf1783@gmail.com
COMMENT= Minimalistic x86 and x86-64 disassembler library
GNU_CONFIGURE= yes
USE_GMAKE= yes
.if !defined(NOPORTDOCS)
DOCS= doc.html index.html ss.jpg style.css
PORTDOCS= index.html ss.jpg style.css udis86.odt udis86.pdf x86optable.xml x86optable.xsl
.else
post-patch:
${REINPLACE_CMD} -e '/SUBDIRS \=/s/\. docs//' ${WRKSRC}/Makefile.in
.endif
post-configure:
${REINPLACE_CMD} -e 's, $$(INSTALL_PROGRAM), $$(INSTALL_DATA),' ${WRKSRC}/libudis86/Makefile
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
.endfor
.endif
regression-test: build
@(cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} check)
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (udis86-1.4.tar.gz) = 73033e2fbdc42c8ef0e17c0ede8c8be6
SHA256 (udis86-1.4.tar.gz) = cdfd5b8320cef00f4f9b5fe4acbc046d17ff2ca9342d7aa23a9def02a1aa0c5a
SIZE (udis86-1.4.tar.gz) = 106330
MD5 (udis86-1.7.tar.gz) = e279108e10f774e6c3af83caa18f5dc3
SHA256 (udis86-1.7.tar.gz) = 6128d266abcabed6077fdeebd2fbb7fb48eb599efbdae98922de2f6acd82ce3a
SIZE (udis86-1.7.tar.gz) = 696651

View file

@ -0,0 +1,11 @@
--- udcli/udcli.c.orig 2009-06-23 02:05:47.000000000 -0400
+++ udcli/udcli.c 2009-06-23 02:06:25.000000000 -0400
@@ -46,7 +46,7 @@
" -o <pc> : Set the value of program counter to <pc>. (default = 0)\n"
" -s <n> : Set the number of bytes to skip before disassembly to <n>.\n"
" -c <n> : Set the number of bytes to disassemble to <n>.\n"
- " -x : Set the input mode to whitespace seperated 8-bit numbers in\n"
+ " -x : Set the input mode to whitespace-separated 8-bit numbers in\n"
" hexadecimal representation. Example: 0f 01 ae 00\n"
" -noff : Do not display the offset of instructions.\n"
" -nohex : Do not display the hexadecimal code of instructions.\n"

View file

@ -1,12 +1,8 @@
bin/udcli
lib/libudis86.a
lib/libudis86.la
include/udis86.h
include/libudis86/types.h
include/libudis86/extern.h
include/libudis86/mnemonics.h
%%PORTDOCS%%%%DOCSDIR%%/doc.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/ss.jpg
%%PORTDOCS%%%%DOCSDIR%%/style.css
include/libudis86/itab.h
include/libudis86/types.h
@dirrm include/libudis86
%%PORTDOCS%%@dirrm %%DOCSDIR%%