- Update to 3.03

- Take maintainership

PR:		ports/87620
Submitted by:	Jean Milanez Melo <jmelo@freebsdbrasil.com.br>
This commit is contained in:
Renato Botelho 2005-10-18 17:34:16 +00:00
parent 60ed2235aa
commit ed19a25f0d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145781
6 changed files with 30 additions and 85 deletions

View file

@ -6,19 +6,19 @@
#
PORTNAME= dbench
PORTVERSION= 1.3
PORTVERSION= 3.03
CATEGORIES= benchmarks
MASTER_SITES= http://samba.org/ftp/tridge/dbench/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= jmelo@freebsdbrasil.com.br
COMMENT= A simulation of the Ziff-Davis netbench benchmark
WRKSRC= ${WRKDIR}/dbench
USE_REINPLACE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
PLIST_FILES= bin/dbench bin/tbench bin/tbench_srv
GNU_CONFIGURE= yes
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PLIST_FILES:T} ${PREFIX}/bin
.include <bsd.port.pre.mk>
.include <bsd.port.mk>
.if ${OSVERSION} < 500000
BROKEN= "Doesn't build on FreeBSD < 5.x"
.endif
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (dbench-1.3.tar.gz) = 38d6e6dcb6a4482e3e210f0f9c4050f9
SIZE (dbench-1.3.tar.gz) = 266746
MD5 (dbench-3.03.tar.gz) = 8bdfa26c7cb0b400223d9be22d761257
SIZE (dbench-3.03.tar.gz) = 2076982

View file

@ -1,22 +0,0 @@
*** dbench.h.orig Fri Jan 5 06:49:41 2001
--- dbench.h Sun Feb 17 02:06:34 2002
***************
*** 42,49 ****
#define MSG_WAITALL 0x100
#endif
#define MIN(x,y) ((x)<(y)?(x):(y))
!
#define TCP_PORT 7003
#define TCP_OPTIONS "TCP_NODELAY SO_REUSEADDR"
--- 42,50 ----
#define MSG_WAITALL 0x100
#endif
+ #ifndef MIN
#define MIN(x,y) ((x)<(y)?(x):(y))
! #endif /* MIN */
#define TCP_PORT 7003
#define TCP_OPTIONS "TCP_NODELAY SO_REUSEADDR"

View file

@ -1,52 +0,0 @@
*** fileio.c.orig Mon Sep 10 08:21:01 2001
--- fileio.c Sun Feb 17 02:06:34 2002
***************
*** 18,23 ****
--- 18,27 ----
Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
+ #if (defined(__unix__) || defined(unix)) && !defined(USG)
+ #include <sys/param.h>
+ #endif
+
#include "dbench.h"
#define MAX_FILES 1000
***************
*** 58,64 ****
--- 62,73 ----
copy_name,
strerror(errno));
} else {
+ #ifdef BSD
+ if (fsync(dir_fd) == -1) {
+ #else
if (fdatasync(dir_fd) == -1) {
+ #endif /* BSD */
+
printf("datasync directory \"%s\" failed: %s\n",
copy_name,
strerror(errno));
***************
*** 111,118 ****
if (size == 0) flags |= O_TRUNC;
if (sync_open)
flags |= O_SYNC;
!
fd = open(fname, flags, 0600);
if (fd == -1) {
printf("(%d) open %s failed for handle %d (%s)\n",
--- 120,130 ----
if (size == 0) flags |= O_TRUNC;
if (sync_open)
+ #ifdef BSD
+ flags |= O_FSYNC;
+ #else
flags |= O_SYNC;
! #endif /* BSD */
fd = open(fname, flags, 0600);
if (fd == -1) {
printf("(%d) open %s failed for handle %d (%s)\n",

View file

@ -0,0 +1,11 @@
--- configure.old Tue Oct 18 11:18:21 2005
+++ configure Tue Oct 18 11:19:00 2005
@@ -339,7 +339,7 @@
bindir='${exec_prefix}/bin'
sbindir='${exec_prefix}/sbin'
libexecdir='${exec_prefix}/libexec'
-datadir='${prefix}/share'
+datadir='${prefix}/share/dbench'
sysconfdir='${prefix}/etc'
sharedstatedir='${prefix}/com'
localstatedir='${prefix}/var'

View file

@ -0,0 +1,8 @@
bin/dbench
bin/tbench
bin/tbench_srv
man/dbench.1
man/tbench.1
man/tbench_srv.1
share/dbench/client.txt
@dirrm share/dbench