A tool to "stamp" photos taken with digital camera with a location, where they

were taken.  It uses the GPS coordinates saved in GPX format.

WWW: http://freefoote.dview.net/linux_gpscorr.html

PR:		ports/120837
Submitted by:	Lukas Maly <Iam@LukasMaly.NET>
This commit is contained in:
Pav Lucistnik 2008-03-07 20:18:17 +00:00
parent 523e2ae653
commit ed1faa1acb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=208617
8 changed files with 297 additions and 0 deletions

View file

@ -20,6 +20,7 @@
SUBDIR += glunarclock
SUBDIR += google-earth
SUBDIR += gpsbabel
SUBDIR += gpscorrelate
SUBDIR += gpsd
SUBDIR += gpsdrive
SUBDIR += gpsman

View file

@ -0,0 +1,36 @@
# New ports collection makefile for: gpscorrelate
# Date created: Feb 2008
# Whom: Lukas Maly
#
# $FreeBSD$
PORTNAME= gpscorrelate
PORTVERSION= 1.5.6
CATEGORIES= astro geography
MASTER_SITES= http://freefoote.dview.net/linux/
MAINTAINER= Iam@LukasMaly.NET
COMMENT= A gps file gpx correlate exif tag in photos
LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
MAN1= gpscorrelate.1 gpscorrelate-gui.1
post-patch:
@${REINPLACE_CMD} -e "s|-I/usr/include|-I${LOCALBASE}/include|" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate-gui ${PREFIX}/bin
${INSTALL_MAN} ${FILESDIR}/gpscorrelate* ${PREFIX}/man/man1
${MKDIR} ${PREFIX}/share/doc/gpscorrelate
${MKDIR} ${PREFIX}/share/gpscorrelate
${MKDIR} ${PREFIX}/share/doc/gpscorrelate/html
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/gpscorrelate/html
${INSTALL_DATA} ${WRKSRC}/doc/*.png ${PREFIX}/share/doc/gpscorrelate/html
${INSTALL_DATA} ${WRKSRC}/*.txt ${PREFIX}/share/gpscorrelate/
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/gpscorrelate/
${INSTALL_DATA} ${WRKSRC}/RELEASES ${PREFIX}/share/gpscorrelate/
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (gpscorrelate-1.5.6.tar.gz) = a76ee92d6f37c7d7d3a3c36dcd07ba62
SHA256 (gpscorrelate-1.5.6.tar.gz) = cbd75278f8707b63c135af5ec83b4323b17313b23cdd0b29fcb1d786c50e1a2e
SIZE (gpscorrelate-1.5.6.tar.gz) = 130623

View file

@ -0,0 +1,115 @@
.\" Title: GPSCORRELATE
.\" Author: Stefano Zacchiroli
.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
.\" Date: 08 Sep 2006
.\" Manual:
.\" Source:
.\"
.TH "GPSCORRELATE" "1" "08 Sep 2006" "" ""
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
.ad l
.SH "NAME"
gpscorrelate \- correlates digital photos with GPS data filling EXIF fields
.SH "SYNOPSIS"
.HP 13
\fBgpscorrelate\fR [\fB\-g\ \fR\fB\fIfile.gpx\fR\fR] [\fIoption\fR...]
.HP 17
\fBgpscorrelate\-gui\fR
.SH "DESCRIPTION"
.PP
This manual page documents briefly the
\fBgpscorrelate\fR
and
\fBgpscorrelate\-gui\fR
commands.
.PP
This manual page was written for the
Debian(TM)
distribution because the original programs do not have a manual page. Instead, they have documentation in HTML format; see below.
.PP
\fBgpscorrelate\fR
is a program that acts on digital photo in JPEG format filling EXIF (Exchangeable Image File Format) fields related to GPS (Global Positioning System) information. Source for the GPS data is a record of GPS information encoded in GPX (GPS Exchange Format) Format. The act of filling those fields is referred to as
\fIcorrelation\fR.
.PP
If GPS data are available at the precise moment the photo was taken (with a 1\-second granularity) the GPS data are stored unmodified in EXIF fields. If they are not linear interpolation of GPS data available at moments before and after the photo was taken can be used.
.PP
\fBgpscorrelate\fR
is a command line tool implementing correlation whereas
\fBgpscorrelate\-gui\fR
is the corresponding GTK+ graphical user interface.
.SH "OPTIONS"
.PP
These programs follow the usual
GNU
command line syntax, with long options starting with two dashes (`\-'). A summary of options is included below. For a complete description, see the HTML documentation.
.TP 3n
\fB\-g\fR, \fB\-\-gps\fR
required, specifies GPX file with GPS data
.TP 3n
\fB\-z\fR, \fB\-\-timeadd\fR \fB+/\-\fR\fIXX\fR[\fB:\fR\fIXX\fR]
time to add to GPS data to make it match photos. GPS data is in UTC; photos are not likely to be in UTC. Enter the timezone used when taking the photos: eg,
\fB+8\fR
for Perth
.TP 3n
\fB\-i\fR, \fB\-\-no\-interpolation\fR
disable interpolation between points. Interpolation is linear, points are rounded if disabled
.TP 3n
\fB\-v\fR, \fB\-\-verbose\fR
show what has been selected
.TP 3n
\fB\-d\fR, \fB\-\-datum\fR \fIdatum\fR
specify measurement datum. If not set, WGS\-84 used
.TP 3n
\fB\-n\fR, \fB\-\-no\-write\fR
do not write the exif data. Useful with
\fB\-\-show\fR
.TP 3n
\fB\-m\fR, \fB\-\-max\-dist\fR \fItime\fR
max time outside points that photo will be matched. Time is in seconds
.TP 3n
\fB\-s\fR, \fB\-\-show\fR
Just show the GPS data from the given files, if it exists
.TP 3n
\fB\-o\fR, \fB\-\-machine\fR
Just show the GPS data from the given files, machine readable output
.TP 3n
\fB\-r\fR, \fB\-\-remove\fR
Strip GPS tags from the given files, and then quit
.TP 3n
\fB\-t\fR, \fB\-\-ignore\-tracksegs\fR
Interpolate between track segments too
.TP 3n
\fB\-M\fR, \fB\-\-no\-mtime\fR
Do not change mtime of modified files
.TP 3n
\fB\-h\fR, \fB\-\-help\fR
Show summary of options.
.SH "SEE ALSO"
.PP
gpsd (1), gpsbabel (1), gpxlogger (1), cgpxlogger (1).
.PP
The documentation of gpscorrelate and gpscorrelate\-gui in HTML format are available on the filesystem at
\fI/usr/local/share/doc/gpscorrelate/html/\fR.
.SH "AUTHOR"
.PP
This manual page was written by Stefano Zacchiroli
<zack@debian.org>
for the
Debian(TM)
system (but may be used by others). Permission is granted to copy, distribute and/or modify this document under the terms of the
GNU
General Public License, Version 2 any later version published by the Free Software Foundation.
.PP
On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL.
.SH "AUTHOR"
.PP
\fBStefano\fR \fBZacchiroli\fR
.sp -1n
.IP "" 3n
Author.
.SH "COPYRIGHT"
Copyright \(co 2006 Stefano Zacchiroli <zack@debian.org>
.br

View file

@ -0,0 +1,115 @@
.\" Title: GPSCORRELATE
.\" Author: Stefano Zacchiroli
.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
.\" Date: 08 Sep 2006
.\" Manual:
.\" Source:
.\"
.TH "GPSCORRELATE" "1" "08 Sep 2006" "" ""
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
.ad l
.SH "NAME"
gpscorrelate \- correlates digital photos with GPS data filling EXIF fields
.SH "SYNOPSIS"
.HP 13
\fBgpscorrelate\fR [\fB\-g\ \fR\fB\fIfile.gpx\fR\fR] [\fIoption\fR...]
.HP 17
\fBgpscorrelate\-gui\fR
.SH "DESCRIPTION"
.PP
This manual page documents briefly the
\fBgpscorrelate\fR
and
\fBgpscorrelate\-gui\fR
commands.
.PP
This manual page was written for the
Debian(TM)
distribution because the original programs do not have a manual page. Instead, they have documentation in HTML format; see below.
.PP
\fBgpscorrelate\fR
is a program that acts on digital photo in JPEG format filling EXIF (Exchangeable Image File Format) fields related to GPS (Global Positioning System) information. Source for the GPS data is a record of GPS information encoded in GPX (GPS Exchange Format) Format. The act of filling those fields is referred to as
\fIcorrelation\fR.
.PP
If GPS data are available at the precise moment the photo was taken (with a 1\-second granularity) the GPS data are stored unmodified in EXIF fields. If they are not linear interpolation of GPS data available at moments before and after the photo was taken can be used.
.PP
\fBgpscorrelate\fR
is a command line tool implementing correlation whereas
\fBgpscorrelate\-gui\fR
is the corresponding GTK+ graphical user interface.
.SH "OPTIONS"
.PP
These programs follow the usual
GNU
command line syntax, with long options starting with two dashes (`\-'). A summary of options is included below. For a complete description, see the HTML documentation.
.TP 3n
\fB\-g\fR, \fB\-\-gps\fR
required, specifies GPX file with GPS data
.TP 3n
\fB\-z\fR, \fB\-\-timeadd\fR \fB+/\-\fR\fIXX\fR[\fB:\fR\fIXX\fR]
time to add to GPS data to make it match photos. GPS data is in UTC; photos are not likely to be in UTC. Enter the timezone used when taking the photos: eg,
\fB+8\fR
for Perth
.TP 3n
\fB\-i\fR, \fB\-\-no\-interpolation\fR
disable interpolation between points. Interpolation is linear, points are rounded if disabled
.TP 3n
\fB\-v\fR, \fB\-\-verbose\fR
show what has been selected
.TP 3n
\fB\-d\fR, \fB\-\-datum\fR \fIdatum\fR
specify measurement datum. If not set, WGS\-84 used
.TP 3n
\fB\-n\fR, \fB\-\-no\-write\fR
do not write the exif data. Useful with
\fB\-\-show\fR
.TP 3n
\fB\-m\fR, \fB\-\-max\-dist\fR \fItime\fR
max time outside points that photo will be matched. Time is in seconds
.TP 3n
\fB\-s\fR, \fB\-\-show\fR
Just show the GPS data from the given files, if it exists
.TP 3n
\fB\-o\fR, \fB\-\-machine\fR
Just show the GPS data from the given files, machine readable output
.TP 3n
\fB\-r\fR, \fB\-\-remove\fR
Strip GPS tags from the given files, and then quit
.TP 3n
\fB\-t\fR, \fB\-\-ignore\-tracksegs\fR
Interpolate between track segments too
.TP 3n
\fB\-M\fR, \fB\-\-no\-mtime\fR
Do not change mtime of modified files
.TP 3n
\fB\-h\fR, \fB\-\-help\fR
Show summary of options.
.SH "SEE ALSO"
.PP
gpsd (1), gpsbabel (1), gpxlogger (1), cgpxlogger (1).
.PP
The documentation of gpscorrelate and gpscorrelate\-gui in HTML format are available on the filesystem at
\fI/usr/local/share/doc/gpscorrelate/html/\fR.
.SH "AUTHOR"
.PP
This manual page was written by Stefano Zacchiroli
<zack@debian.org>
for the
Debian(TM)
system (but may be used by others). Permission is granted to copy, distribute and/or modify this document under the terms of the
GNU
General Public License, Version 2 any later version published by the Free Software Foundation.
.PP
On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL.
.SH "AUTHOR"
.PP
\fBStefano\fR \fBZacchiroli\fR
.sp -1n
.IP "" 3n
Author.
.SH "COPYRIGHT"
Copyright \(co 2006 Stefano Zacchiroli <zack@debian.org>
.br

View file

@ -0,0 +1,10 @@
--- unixtime.h.orig 2008-02-18 12:50:16.000000000 +0100
+++ unixtime.h 2008-02-18 12:50:41.000000000 +0100
@@ -27,6 +27,7 @@
#define EXIF_DATE_FORMAT "%d:%d:%d %d:%d:%d"
#define GPX_DATE_FORMAT "%d-%d-%dT%d:%d:%dZ"
+#include <sys/types.h>
time_t ConvertToUnixTime(char* StringTime, char* Format,
int TZOffsetHours, int TZOffsetMinutes);

View file

@ -0,0 +1,4 @@
A tool to "stamp" photos taken with digital camera with a location, where they
were taken. It uses the GPS coordinates saved in GPX format.
WWW: http://freefoote.dview.net/linux_gpscorr.html

View file

@ -0,0 +1,13 @@
bin/gpscorrelate
bin/gpscorrelate-gui
share/gpscorrelate/README
share/gpscorrelate/RELEASES
share/gpscorrelate/command-line-options.txt
share/doc/gpscorrelate/html/command.html
share/doc/gpscorrelate/html/concepts.html
share/doc/gpscorrelate/html/corr.png
share/doc/gpscorrelate/html/gui.html
share/doc/gpscorrelate/html/index.html
@dirrm share/doc/gpscorrelate/html
@dirrm share/doc/gpscorrelate
@dirrm share/gpscorrelate