- Update to 3.7.0

- Change to new optionsNG

PR:		ports/168771
Submitted by:	Denis Generalov <gd@rambler-co.ru>
This commit is contained in:
Sylvio Cesar Teixeira 2012-06-08 18:08:54 +00:00
parent a203787714
commit ed5ec0efca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298770
5 changed files with 88 additions and 152 deletions

View file

@ -6,12 +6,11 @@
#
PORTNAME= valgrind
PORTVERSION= 3.6.1
PORTREVISION= 4
PORTVERSION= 3.7.0
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}-2
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}-3
MAINTAINER= ports@FreeBSD.org
COMMENT= A (memory) debugging and profiling tool
@ -20,15 +19,26 @@ CONFLICTS= valgrind-snapshot-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
OPTIONS_DEFINE= MPI
MPI_DESC= Enable build of MPI wrappers
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
USE_PERL5_BUILD= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
OPTIONS= MPI "Enable build of MPI wrappers" off
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMPI}
LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
PLIST_SUB+= MPI=""
.else
PLIST_SUB+= MPI="@comment "
.endif
post-install:
@${CAT} ${PKGMESSAGE}
@ -39,13 +49,6 @@ post-install:
IGNORE= your FreeBSD version is not supported
.endif
.if defined(WITH_MPI) || exists(${LOCALBASE}/bin/mpicc)
LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
PLIST_SUB+= MPI=""
.else
PLIST_SUB+= MPI="@comment "
.endif
.if ${ARCH} == "amd64"
PLIST_SUB+= AMD64="" ARCH=amd64
. if !exists(/usr/lib32)

View file

@ -1,2 +1,2 @@
SHA256 (valgrind-freebsd-3.6.1-2.tar.bz2) = 152aee48896ca5e7a17ac4e8fe70f7db1a98b46a1a2c6c4dfa32b7112acca094
SIZE (valgrind-freebsd-3.6.1-2.tar.bz2) = 5630521
SHA256 (valgrind-freebsd-3.7.0-3.tar.bz2) = 0a11ebf01634f148b0be637a34d48420093dbe1c194b57f4ca948c1f3d556b21
SIZE (valgrind-freebsd-3.7.0-3.tar.bz2) = 6069934

View file

@ -1,105 +0,0 @@
Index: coregrind/m_debuginfo/readdwarf.c
===================================================================
--- coregrind/m_debuginfo/readdwarf.c (revision 11855)
+++ coregrind/m_debuginfo/readdwarf.c (revision 11856)
@@ -2899,6 +2899,22 @@
op = Cop_And; opname = "and"; goto binop;
case DW_OP_mul:
op = Cop_Mul; opname = "mul"; goto binop;
+ case DW_OP_shl:
+ op = Cop_Shl; opname = "shl"; goto binop;
+ case DW_OP_shr:
+ op = Cop_Shr; opname = "shr"; goto binop;
+ case DW_OP_eq:
+ op = Cop_Eq; opname = "eq"; goto binop;
+ case DW_OP_ge:
+ op = Cop_Ge; opname = "ge"; goto binop;
+ case DW_OP_gt:
+ op = Cop_Gt; opname = "gt"; goto binop;
+ case DW_OP_le:
+ op = Cop_Le; opname = "le"; goto binop;
+ case DW_OP_lt:
+ op = Cop_Lt; opname = "lt"; goto binop;
+ case DW_OP_ne:
+ op = Cop_Ne; opname = "ne"; goto binop;
binop:
POP( ix );
POP( ix2 );
Index: coregrind/m_debuginfo/debuginfo.c
===================================================================
--- coregrind/m_debuginfo/debuginfo.c (revision 11855)
+++ coregrind/m_debuginfo/debuginfo.c (revision 11856)
@@ -1880,6 +1880,14 @@
case Cop_Sub: return wL - wR;
case Cop_And: return wL & wR;
case Cop_Mul: return wL * wR;
+ case Cop_Shl: return wL << wR;
+ case Cop_Shr: return wL >> wR;
+ case Cop_Eq: return wL == wR ? 1 : 0;
+ case Cop_Ge: return wL >= wR ? 1 : 0;
+ case Cop_Gt: return wL > wR ? 1 : 0;
+ case Cop_Le: return wL <= wR ? 1 : 0;
+ case Cop_Lt: return wL < wR ? 1 : 0;
+ case Cop_Ne: return wL != wR ? 1 : 0;
default: goto unhandled;
}
/*NOTREACHED*/
Index: coregrind/m_debuginfo/storage.c
===================================================================
--- coregrind/m_debuginfo/storage.c (revision 11855)
+++ coregrind/m_debuginfo/storage.c (revision 11856)
@@ -603,6 +603,14 @@
case Cop_Sub: VG_(printf)("-"); break;
case Cop_And: VG_(printf)("&"); break;
case Cop_Mul: VG_(printf)("*"); break;
+ case Cop_Shl: VG_(printf)("<<"); break;
+ case Cop_Shr: VG_(printf)(">>"); break;
+ case Cop_Eq: VG_(printf)("=="); break;
+ case Cop_Ge: VG_(printf)(">="); break;
+ case Cop_Gt: VG_(printf)(">"); break;
+ case Cop_Le: VG_(printf)("<="); break;
+ case Cop_Lt: VG_(printf)("<"); break;
+ case Cop_Ne: VG_(printf)("!="); break;
default: vg_assert(0);
}
}
Index: coregrind/m_debuginfo/priv_storage.h
===================================================================
--- coregrind/m_debuginfo/priv_storage.h (revision 11855)
+++ coregrind/m_debuginfo/priv_storage.h (revision 11856)
@@ -249,7 +249,15 @@
Cop_Add=0x321,
Cop_Sub,
Cop_And,
- Cop_Mul
+ Cop_Mul,
+ Cop_Shl,
+ Cop_Shr,
+ Cop_Eq,
+ Cop_Ge,
+ Cop_Gt,
+ Cop_Le,
+ Cop_Lt,
+ Cop_Ne
}
CfiOp;
Index: coregrind/m_debuginfo/debuginfo.c
===================================================================
--- coregrind/m_debuginfo/debuginfo.c (revision 11903)
+++ coregrind/m_debuginfo/debuginfo.c (revision 11904)
@@ -1883,10 +1883,10 @@
case Cop_Shl: return wL << wR;
case Cop_Shr: return wL >> wR;
case Cop_Eq: return wL == wR ? 1 : 0;
- case Cop_Ge: return wL >= wR ? 1 : 0;
- case Cop_Gt: return wL > wR ? 1 : 0;
- case Cop_Le: return wL <= wR ? 1 : 0;
- case Cop_Lt: return wL < wR ? 1 : 0;
+ case Cop_Ge: return (Word) wL >= (Word) wR ? 1 : 0;
+ case Cop_Gt: return (Word) wL > (Word) wR ? 1 : 0;
+ case Cop_Le: return (Word) wL <= (Word) wR ? 1 : 0;
+ case Cop_Lt: return (Word) wL < (Word) wR ? 1 : 0;
case Cop_Ne: return wL != wR ? 1 : 0;
default: goto unhandled;
}

View file

@ -1,20 +0,0 @@
--- include/vki/vki-x86-freebsd.h.orig 2011-04-27 02:47:18.000000000 -0500
+++ include/vki/vki-x86-freebsd.h 2011-05-08 05:39:46.293802771 -0500
@@ -145,7 +145,7 @@ struct vki_sigcontext {
int fpformat;
int ownedfp;
int spare1[1];
- struct _vki_fpstate fpstate __aligned(16);
+ struct _vki_fpstate fpstate __attribute__((__aligned__(16)));
int fsbase;
int gsbase;
int spare2[6];
@@ -215,7 +215,7 @@ struct vki_mcontext {
int fpformat;
int ownedfp;
int spare1[1];
- struct _vki_fpstate fpstate __aligned(16);
+ struct _vki_fpstate fpstate __attribute__((__aligned__(16)));
int fsbase;
int gsbase;
int spare2[6];

View file

@ -4,10 +4,11 @@ bin/cg_annotate
bin/cg_diff
bin/cg_merge
bin/ms_print
bin/no_op_client_for_valgrind
bin/valgrind
bin/valgrind-listener
bin/vgdb
include/valgrind/callgrind.h
include/valgrind/config.h
include/valgrind/drd.h
include/valgrind/helgrind.h
include/valgrind/libvex.h
@ -18,8 +19,10 @@ include/valgrind/libvex_guest_arm.h
include/valgrind/libvex_guest_offsets.h
include/valgrind/libvex_guest_ppc32.h
include/valgrind/libvex_guest_ppc64.h
include/valgrind/libvex_guest_s390x.h
include/valgrind/libvex_guest_x86.h
include/valgrind/libvex_ir.h
include/valgrind/libvex_s390x_common.h
include/valgrind/libvex_trc_values.h
include/valgrind/memcheck.h
include/valgrind/pub_tool_aspacehl.h
@ -32,12 +35,14 @@ include/valgrind/pub_tool_cpuid.h
include/valgrind/pub_tool_debuginfo.h
include/valgrind/pub_tool_errormgr.h
include/valgrind/pub_tool_execontext.h
include/valgrind/pub_tool_gdbserver.h
include/valgrind/pub_tool_hashtable.h
include/valgrind/pub_tool_libcassert.h
include/valgrind/pub_tool_libcbase.h
include/valgrind/pub_tool_libcfile.h
include/valgrind/pub_tool_libcprint.h
include/valgrind/pub_tool_libcproc.h
include/valgrind/pub_tool_libcsetjmp.h
include/valgrind/pub_tool_libcsignal.h
include/valgrind/pub_tool_machine.h
include/valgrind/pub_tool_mallocfree.h
@ -59,44 +64,74 @@ include/valgrind/pub_tool_xarray.h
include/valgrind/valgrind.h
include/valgrind/vki/vki-amd64-freebsd.h
include/valgrind/vki/vki-amd64-linux.h
include/valgrind/vki/vki-arm-linux.h
include/valgrind/vki/vki-darwin.h
include/valgrind/vki/vki-freebsd.h
include/valgrind/vki/vki-linux.h
include/valgrind/vki/vki-arm-linux.h
include/valgrind/vki/vki-posixtypes-arm-linux.h
include/valgrind/vki/vki-scnums-arm-linux.h
include/valgrind/vki/vki-posixtypes-amd64-linux.h
include/valgrind/vki/vki-posixtypes-arm-linux.h
include/valgrind/vki/vki-posixtypes-ppc32-linux.h
include/valgrind/vki/vki-posixtypes-ppc64-linux.h
include/valgrind/vki/vki-posixtypes-s390x-linux.h
include/valgrind/vki/vki-posixtypes-x86-linux.h
include/valgrind/vki/vki-ppc32-linux.h
include/valgrind/vki/vki-ppc64-linux.h
include/valgrind/vki/vki-s390x-linux.h
include/valgrind/vki/vki-scnums-amd64-linux.h
include/valgrind/vki/vki-scnums-arm-linux.h
include/valgrind/vki/vki-scnums-darwin.h
include/valgrind/vki/vki-scnums-freebsd.h
include/valgrind/vki/vki-scnums-ppc32-linux.h
include/valgrind/vki/vki-scnums-ppc64-linux.h
include/valgrind/vki/vki-scnums-s390x-linux.h
include/valgrind/vki/vki-scnums-x86-linux.h
include/valgrind/vki/vki-x86-freebsd.h
include/valgrind/vki/vki-x86-linux.h
libdata/pkgconfig/valgrind.pc
lib/valgrind/32bit-core-valgrind-s1.xml
lib/valgrind/32bit-core-valgrind-s2.xml
lib/valgrind/32bit-core.xml
lib/valgrind/32bit-linux-valgrind-s1.xml
lib/valgrind/32bit-linux-valgrind-s2.xml
lib/valgrind/32bit-linux.xml
lib/valgrind/32bit-sse-valgrind-s1.xml
lib/valgrind/32bit-sse-valgrind-s2.xml
lib/valgrind/32bit-sse.xml
lib/valgrind/64bit-core-valgrind-s1.xml
lib/valgrind/64bit-core-valgrind-s2.xml
lib/valgrind/64bit-core.xml
lib/valgrind/64bit-linux-valgrind-s1.xml
lib/valgrind/64bit-linux-valgrind-s2.xml
lib/valgrind/64bit-linux.xml
lib/valgrind/64bit-sse-valgrind-s1.xml
lib/valgrind/64bit-sse-valgrind-s2.xml
lib/valgrind/64bit-sse.xml
%%AMD64%%lib/valgrind/amd64-coresse-valgrind.xml
%%AMD64%%lib/valgrind/amd64-linux-valgrind.xml
lib/valgrind/arm-core-valgrind-s1.xml
lib/valgrind/arm-core-valgrind-s2.xml
lib/valgrind/arm-core.xml
lib/valgrind/arm-vfpv3-valgrind-s1.xml
lib/valgrind/arm-vfpv3-valgrind-s2.xml
lib/valgrind/arm-vfpv3.xml
lib/valgrind/arm-with-vfpv3-valgrind.xml
lib/valgrind/arm-with-vfpv3.xml
%%AMD64%%lib/valgrind/cachegrind-amd64-freebsd
%%X86%%lib/valgrind/cachegrind-x86-freebsd
%%AMD64%%lib/valgrind/callgrind-amd64-freebsd
%%X86%%lib/valgrind/callgrind-x86-freebsd
lib/valgrind/default.supp
%%AMD64%%lib/valgrind/exp-dhat-amd64-freebsd
%%X86%%lib/valgrind/exp-dhat-x86-freebsd
%%AMD64%%lib/valgrind/vgpreload_exp-dhat-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_exp-dhat-x86-freebsd.so
%%AMD64%%lib/valgrind/drd-amd64-freebsd
%%X86%%lib/valgrind/drd-x86-freebsd
%%AMD64%%lib/valgrind/exp-bbv-amd64-freebsd
%%X86%%lib/valgrind/exp-bbv-x86-freebsd
%%AMD64%%lib/valgrind/exp-ptrcheck-amd64-freebsd
%%X86%%lib/valgrind/exp-ptrcheck-x86-freebsd
%%AMD64%%lib/valgrind/exp-dhat-amd64-freebsd
%%X86%%lib/valgrind/exp-dhat-x86-freebsd
%%AMD64%%lib/valgrind/exp-sgcheck-amd64-freebsd
%%X86%%lib/valgrind/exp-sgcheck-x86-freebsd
%%AMD64%%lib/valgrind/helgrind-amd64-freebsd
%%X86%%lib/valgrind/helgrind-x86-freebsd
lib/valgrind/i386-coresse-valgrind.xml
lib/valgrind/i386-linux-valgrind.xml
%%AMD64%%lib/valgrind/lackey-amd64-freebsd
%%X86%%lib/valgrind/lackey-x86-freebsd
%%AMD64%%lib/valgrind/libcoregrind-amd64-freebsd.a
@ -111,12 +146,34 @@ lib/valgrind/default.supp
%%X86%%lib/valgrind/memcheck-x86-freebsd
%%AMD64%%lib/valgrind/none-amd64-freebsd
%%X86%%lib/valgrind/none-x86-freebsd
lib/valgrind/power-altivec-valgrind-s1.xml
lib/valgrind/power-altivec-valgrind-s2.xml
lib/valgrind/power-altivec.xml
lib/valgrind/power-core.xml
lib/valgrind/power-fpu-valgrind-s1.xml
lib/valgrind/power-fpu-valgrind-s2.xml
lib/valgrind/power-fpu.xml
lib/valgrind/power-linux-valgrind-s1.xml
lib/valgrind/power-linux-valgrind-s2.xml
lib/valgrind/power-linux.xml
lib/valgrind/power64-core-valgrind-s1.xml
lib/valgrind/power64-core-valgrind-s2.xml
lib/valgrind/power64-core.xml
lib/valgrind/power64-linux-valgrind-s1.xml
lib/valgrind/power64-linux-valgrind-s2.xml
lib/valgrind/power64-linux.xml
lib/valgrind/powerpc-altivec32l-valgrind.xml
lib/valgrind/powerpc-altivec32l.xml
lib/valgrind/powerpc-altivec64l-valgrind.xml
lib/valgrind/powerpc-altivec64l.xml
%%AMD64%%lib/valgrind/vgpreload_core-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_core-x86-freebsd.so
%%AMD64%%lib/valgrind/vgpreload_drd-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_drd-x86-freebsd.so
%%AMD64%%lib/valgrind/vgpreload_exp-ptrcheck-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_exp-ptrcheck-x86-freebsd.so
%%AMD64%%lib/valgrind/vgpreload_exp-dhat-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_exp-dhat-x86-freebsd.so
%%AMD64%%lib/valgrind/vgpreload_exp-sgcheck-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_exp-sgcheck-x86-freebsd.so
%%AMD64%%lib/valgrind/vgpreload_helgrind-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_helgrind-x86-freebsd.so
%%AMD64%%lib/valgrind/vgpreload_massif-amd64-freebsd.so
@ -124,6 +181,7 @@ lib/valgrind/default.supp
%%AMD64%%lib/valgrind/vgpreload_memcheck-amd64-freebsd.so
%%X86%%lib/valgrind/vgpreload_memcheck-x86-freebsd.so
%%MPI%%lib/valgrind/libmpiwrap-%%ARCH%%-freebsd.so
libdata/pkgconfig/valgrind.pc
@dirrm lib/valgrind
@dirrm include/valgrind/vki
@dirrm include/valgrind