Google App Engine Oil (GAEO) is an open-source web framework

running on Google App Engine.

Google App Engine Oil (GAEO) enables the web development on
Google AppEngine quick and less configurations. GAEO enhances
Google AppEngine SDK with new features such as:
    - Well-formed URL Routing
    - Enhanced Request Handler (Controller)
    - Enhanced Object-Relation Mapping (ORM)

PR:		ports/125923
Submitted by:	Yi-Jheng Lin <yzlin at cs.nctu.edu.tw>
This commit is contained in:
Beech Rintoul 2008-07-26 04:31:12 +00:00
parent 229c98f306
commit ed86f41155
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217539
6 changed files with 84 additions and 0 deletions

View file

@ -212,6 +212,7 @@
SUBDIR += fswiki
SUBDIR += g-cows
SUBDIR += g-gcl
SUBDIR += gaeo
SUBDIR += galeon
SUBDIR += gallery
SUBDIR += gallery2

40
www/gaeo/Makefile Normal file
View file

@ -0,0 +1,40 @@
# New ports collection makefile for: gaeo
# Date created: 2008-07-24
# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
#
# $FreeBSD$
#
PORTNAME= gaeo
PORTVERSION= 45
CATEGORIES= www devel python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-trunk-r${PORTVERSION}
MAINTAINER= yzlin@cs.nctu.edu.tw
COMMENT= An open-source web framework running on Google App Engine
RUN_DEPENDS= google-appengine>=1.1.0:${PORTSDIR}/www/google-appengine
PROJECTHOST= google-app-engine-oil
NO_BUILD= yes
USE_PYTHON= 2.5+
USE_ZIP= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
post-patch:
${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR},g" ${WRKSRC}/bin/gaeo.py
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} "gaeo" ${DATADIR}
.if !defined(NOPORTDOCS)
${INSTALL} -d ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}/README
.endif
${INSTALL_SCRIPT} ${WRKSRC}/bin/gaeo.py ${PREFIX}/bin/gaeo.py
${INSTALL_SCRIPT} ${WRKSRC}/bin/gaeogen.py ${PREFIX}/bin/gaeogen.py
.include <bsd.port.mk>

3
www/gaeo/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (gaeo-trunk-r45.zip) = fd5243b6067759cd4d54bd65c5b931f7
SHA256 (gaeo-trunk-r45.zip) = 386d7114841b5af6baeb65a28a8ab8cc69767f3f22b5367349d90d61a6c17a4d
SIZE (gaeo-trunk-r45.zip) = 18299

View file

@ -0,0 +1,11 @@
--- bin/gaeo.py.orig 2008-07-24 15:24:37.000000000 +0800
+++ bin/gaeo.py 2008-07-24 15:25:07.000000000 +0800
@@ -196,7 +196,7 @@
create_file(os.path.join(project_home, 'favicon.ico'), [])
# copy GAEO directory
- copytree(os.path.join(os.path.dirname(__file__), '..', 'gaeo'), os.path.join(project_home, 'gaeo'))
+ copytree(os.path.join(os.path.dirname(__file__), '%%DATADIR%%', 'gaeo'), os.path.join(project_home, 'gaeo'))
# create the eclipse project file
if create_eclipse_proj:

11
www/gaeo/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
Google App Engine Oil (GAEO) is an open-source web framework
running on Google App Engine.
Google App Engine Oil (GAEO) enables the web development on
Google AppEngine quick and less configurations. GAEO enhances
Google AppEngine SDK with new features such as:
- Well-formed URL Routing
- Enhanced Request Handler (Controller)
- Enhanced Object-Relation Mapping (ORM)
WWW: http://gaeo.org

18
www/gaeo/pkg-plist Normal file
View file

@ -0,0 +1,18 @@
bin/gaeo.py
bin/gaeogen.py
%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/gaeo/__init__.py
%%DATADIR%%/gaeo/controller/__init__.py
%%DATADIR%%/gaeo/controller/errors.py
%%DATADIR%%/gaeo/controller/helper.py
%%DATADIR%%/gaeo/dispatch/__init__.py
%%DATADIR%%/gaeo/dispatch/dispatcher.py
%%DATADIR%%/gaeo/dispatch/router.py
%%DATADIR%%/gaeo/session/__init__.py
%%DATADIR%%/gaeo/session/memcache.py
@dirrm %%DATADIR%%/gaeo/session
@dirrm %%DATADIR%%/gaeo/dispatch
@dirrm %%DATADIR%%/gaeo/controller
@dirrm %%DATADIR%%/gaeo
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%