ftp/curl: Update to 8.6.0
ChangeLog: https://curl.se/changes.html#8_6_0 PR: 276879 Approved by: maintainer Exp-run bye: antoine MFH: 2024Q1 Security: 02e33cd1-c655-11ee-8613-08002784c58d
This commit is contained in:
parent
16f370e33f
commit
ed937bd9ad
5 changed files with 39 additions and 44 deletions
|
@ -1,10 +1,12 @@
|
|||
PORTNAME= curl
|
||||
PORTVERSION= 8.5.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 8.6.0
|
||||
CATEGORIES= ftp net www
|
||||
MASTER_SITES= https://curl.se/download/ \
|
||||
https://github.com/curl/curl/releases/download/curl-${PORTVERSION:S|.|_|g}/
|
||||
|
||||
PATCH_SITES= https://github.com/curl/curl/commit/
|
||||
PATCHFILES= e75a48d2c32d92b0321fbb09c25885a706077201.patch:-p1
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Command line tool and library for transferring data with URLs
|
||||
WWW= https://curl.se/ \
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
TIMESTAMP = 1702028046
|
||||
SHA256 (curl-8.5.0.tar.xz) = 42ab8db9e20d8290a3b633e7fbb3cec15db34df65fd1015ef8ac1e4723750eeb
|
||||
SIZE (curl-8.5.0.tar.xz) = 2658520
|
||||
TIMESTAMP = 1707351676
|
||||
SHA256 (curl-8.6.0.tar.xz) = 3ccd55d91af9516539df80625f818c734dc6f2ecf9bada33c76765e99121db15
|
||||
SIZE (curl-8.6.0.tar.xz) = 2630108
|
||||
SHA256 (e75a48d2c32d92b0321fbb09c25885a706077201.patch) = ba977cec34b09820edb26e5edb8a4be3a8aaf7df4784295a081cca753a3eaac8
|
||||
SIZE (e75a48d2c32d92b0321fbb09c25885a706077201.patch) = 750
|
||||
|
|
|
@ -9,17 +9,6 @@
|
|||
DIST_SUBDIRS = $(SUBDIRS) tests packages scripts include docs
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libcurl.pc
|
||||
@@ -1695,10 +1695,8 @@ dist-hook:
|
||||
done)
|
||||
|
||||
html:
|
||||
- cd docs && $(MAKE) html
|
||||
|
||||
pdf:
|
||||
- cd docs && $(MAKE) pdf
|
||||
|
||||
check: test examples check-docs
|
||||
|
||||
@@ -1785,13 +1783,11 @@ cygwinbin:
|
||||
# We extend the standard install with a custom hook:
|
||||
install-data-hook:
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.orig 2023-03-20 11:39:06 UTC
|
||||
--- configure.orig 2024-01-29 15:53:31 UTC
|
||||
+++ configure
|
||||
@@ -4179,9 +4179,10 @@ printf "%s\n" "$as_me: LIBS note: LIBS should only be
|
||||
@@ -4198,9 +4198,10 @@ printf "%s\n" "$as_me: LIBS note: LIBS should only be
|
||||
-I*)
|
||||
xc_bad_var_ldflags=yes
|
||||
;;
|
||||
|
@ -14,7 +14,7 @@
|
|||
esac
|
||||
done
|
||||
if test $xc_bad_var_ldflags = yes; then
|
||||
@@ -4251,9 +4252,10 @@ printf "%s\n" "$as_me: $xc_bad_var_msg libraries. Use
|
||||
@@ -4270,9 +4271,10 @@ printf "%s\n" "$as_me: $xc_bad_var_msg libraries. Use
|
||||
xc_bad_var_cflags=no
|
||||
for xc_word in $CFLAGS; do
|
||||
case "$xc_word" in
|
||||
|
@ -28,7 +28,7 @@
|
|||
-U*)
|
||||
xc_bad_var_cflags=yes
|
||||
;;
|
||||
@@ -17387,7 +17389,7 @@ printf "%s\n" "$as_me: WARNING: failed to figure out c
|
||||
@@ -17400,7 +17402,7 @@ printf "%s\n" "$as_me: WARNING: failed to figure out c
|
||||
flags_dbg_yes="unknown"
|
||||
flags_opt_all="unknown"
|
||||
flags_opt_yes="unknown"
|
||||
|
@ -37,7 +37,7 @@
|
|||
#
|
||||
flags_prefer_cppflags="no"
|
||||
#
|
||||
@@ -17492,7 +17494,7 @@ printf "%s\n" "yes" >&6; }
|
||||
@@ -17505,7 +17507,7 @@ printf "%s\n" "yes" >&6; }
|
||||
flags_dbg_yes="-g2"
|
||||
flags_opt_all="-O -O0 -O1 -O2 -O3 -O4"
|
||||
flags_opt_yes="-O1"
|
||||
|
@ -46,7 +46,7 @@
|
|||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
printf "%s\n" "no" >&6; }
|
||||
@@ -17553,7 +17555,7 @@ printf "%s\n" "yes" >&6; }
|
||||
@@ -17566,7 +17568,7 @@ printf "%s\n" "yes" >&6; }
|
||||
flags_dbg_yes="-g"
|
||||
flags_opt_all="-O +O0 +O1 +O2 +O3 +O4"
|
||||
flags_opt_yes="+O2"
|
||||
|
@ -55,7 +55,7 @@
|
|||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
printf "%s\n" "no" >&6; }
|
||||
@@ -17621,7 +17623,7 @@ printf "%s\n" "yes" >&6; }
|
||||
@@ -17634,7 +17636,7 @@ printf "%s\n" "yes" >&6; }
|
||||
flags_opt_all="$flags_opt_all -qoptimize=4"
|
||||
flags_opt_all="$flags_opt_all -qoptimize=5"
|
||||
flags_opt_yes="-O2"
|
||||
|
@ -64,7 +64,7 @@
|
|||
flags_prefer_cppflags="yes"
|
||||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
@@ -17730,13 +17732,13 @@ rm -f conftest.err conftest.i conftest.$ac_ext
|
||||
@@ -17747,13 +17749,13 @@ rm -f conftest.err conftest.i conftest.$ac_ext
|
||||
flags_dbg_yes="-g"
|
||||
flags_opt_all="-O -O0 -O1 -O2 -O3 -Os"
|
||||
flags_opt_yes="-O2"
|
||||
|
@ -80,7 +80,7 @@
|
|||
fi
|
||||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
@@ -17865,7 +17867,7 @@ printf "%s\n" "no" >&6; }
|
||||
@@ -17905,7 +17907,7 @@ printf "%s\n" "clang '$compiler_num' (raw: '$fullclang
|
||||
flags_dbg_yes="-g"
|
||||
flags_opt_all="-O -O0 -O1 -O2 -Os -O3 -O4"
|
||||
flags_opt_yes="-O2"
|
||||
|
@ -89,16 +89,16 @@
|
|||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
printf "%s\n" "no" >&6; }
|
||||
@@ -17931,7 +17933,7 @@ printf "%s\n" "yes" >&6; }
|
||||
@@ -17980,7 +17982,7 @@ printf "%s\n" "gcc '$compiler_num' (raw: '$gccver')" >
|
||||
flags_dbg_yes="-g"
|
||||
flags_opt_all="-O -O0 -O1 -O2 -O3 -Os -Og -Ofast"
|
||||
flags_opt_yes="-O2"
|
||||
- flags_opt_off="-O0"
|
||||
+ flags_opt_off=""
|
||||
|
||||
OLDCPPFLAGS=$CPPFLAGS
|
||||
# CPPPFLAG comes from CURL_CPP_P
|
||||
@@ -18190,7 +18192,7 @@ printf "%s\n" "yes" >&6; }
|
||||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
printf "%s\n" "no" >&6; }
|
||||
@@ -18241,7 +18243,7 @@ printf "%s\n" "yes" >&6; }
|
||||
flags_dbg_yes="-g"
|
||||
flags_opt_all="-O -O0 -O1 -O2 -O3 -Ofast"
|
||||
flags_opt_yes="-O2"
|
||||
|
@ -107,16 +107,7 @@
|
|||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
printf "%s\n" "no" >&6; }
|
||||
@@ -18298,7 +18300,7 @@ printf "%s\n" "yes" >&6; }
|
||||
flags_dbg_yes="-g"
|
||||
flags_opt_all="-O -O0 -O1 -O2 -O3 -Ofast"
|
||||
flags_opt_yes="-O2"
|
||||
- flags_opt_off="-O0"
|
||||
+ flags_opt_off=""
|
||||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
printf "%s\n" "no" >&6; }
|
||||
@@ -18831,6 +18833,8 @@ printf "%s\n" "$honor_optimize_option" >&6; }
|
||||
@@ -18822,6 +18824,8 @@ printf "%s\n" "$honor_optimize_option" >&6; }
|
||||
#
|
||||
if test "$honor_optimize_option" = "yes"; then
|
||||
|
||||
|
@ -125,7 +116,7 @@
|
|||
ac_var_stripped=""
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@@ -18861,6 +18865,7 @@ printf "%s\n" "$honor_optimize_option" >&6; }
|
||||
@@ -18852,6 +18856,7 @@ printf "%s\n" "$honor_optimize_option" >&6; }
|
||||
done
|
||||
tmp_CPPFLAGS="$ac_var_stripped"
|
||||
squeeze tmp_CPPFLAGS
|
||||
|
@ -133,7 +124,7 @@
|
|||
|
||||
if test "$want_optimize" = "yes"; then
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
|
||||
@@ -29941,31 +29946,31 @@ printf "%s\n" "found" >&6; }
|
||||
@@ -29748,31 +29753,31 @@ printf "%s\n" "found" >&6; }
|
||||
;;
|
||||
off)
|
||||
LIB_RTMP="-lrtmp"
|
||||
|
@ -174,7 +165,7 @@
|
|||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
@@ -45632,9 +45637,10 @@ printf "%s\n" "$as_me: LIBS note: LIBS should only be
|
||||
@@ -45884,9 +45889,10 @@ printf "%s\n" "$as_me: LIBS note: LIBS should only be
|
||||
-I*)
|
||||
xc_bad_var_ldflags=yes
|
||||
;;
|
||||
|
@ -188,7 +179,7 @@
|
|||
esac
|
||||
done
|
||||
if test $xc_bad_var_ldflags = yes; then
|
||||
@@ -45704,9 +45710,10 @@ printf "%s\n" "$as_me: $xc_bad_var_msg libraries. Use
|
||||
@@ -45956,9 +45962,10 @@ printf "%s\n" "$as_me: $xc_bad_var_msg libraries. Use
|
||||
xc_bad_var_cflags=no
|
||||
for xc_word in $CFLAGS; do
|
||||
case "$xc_word" in
|
||||
|
|
|
@ -25,12 +25,14 @@ share/aclocal/libcurl.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/BUGS.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHECKSRC.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CIPHERS.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CLIENT-WRITERS.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CODE_OF_CONDUCT.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CODE_REVIEW.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CODE_STYLE.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONNECTION-FILTERS.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTE.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CURL-DISABLE.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CURLDOWN.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/DEPRECATE.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/DYNBUF.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/EARLY-RELEASE.md
|
||||
|
@ -46,6 +48,7 @@ share/aclocal/libcurl.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/HTTP3.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/HYPER.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL-CMAKE.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INTERNALS.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/KNOWN_BUGS
|
||||
|
@ -67,16 +70,19 @@ share/aclocal/libcurl.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/VERSIONS.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/VULN-DISCLOSURE-POLICY.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/WEBSOCKET.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/curl-config.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/ABI.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/libcurl.m4
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/mksymbolsmanpage.pl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/symbols-in-versions
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/symbols.pl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mk-ca-bundle.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/options-in-versions
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/10-at-a-time.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.example
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.mk
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/address-scope.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/altsvc.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/anyauthput.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cacertinmem.c
|
||||
|
@ -152,6 +158,7 @@ share/aclocal/libcurl.m4
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-single.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-uv.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multithread.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/netrc.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parseurl.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/persistent.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pop3-authzid.c
|
||||
|
@ -171,6 +178,7 @@ share/aclocal/libcurl.m4
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postit2.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/progressfunc.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protofeats.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/range.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resolve.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rtsp-options.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sendrecv.c
|
||||
|
@ -203,6 +211,7 @@ share/aclocal/libcurl.m4
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xmlstream.c
|
||||
share/man/man1/curl-config.1.gz
|
||||
share/man/man1/curl.1.gz
|
||||
share/man/man1/mk-ca-bundle.1.gz
|
||||
share/man/man3/CURLINFO_ACTIVESOCKET.3.gz
|
||||
share/man/man3/CURLINFO_APPCONNECT_TIME.3.gz
|
||||
share/man/man3/CURLINFO_APPCONNECT_TIME_T.3.gz
|
||||
|
@ -244,6 +253,7 @@ share/man/man3/CURLINFO_PROTOCOL.3.gz
|
|||
share/man/man3/CURLINFO_PROXYAUTH_AVAIL.3.gz
|
||||
share/man/man3/CURLINFO_PROXY_ERROR.3.gz
|
||||
share/man/man3/CURLINFO_PROXY_SSL_VERIFYRESULT.3.gz
|
||||
share/man/man3/CURLINFO_QUEUE_TIME_T.3.gz
|
||||
share/man/man3/CURLINFO_REDIRECT_COUNT.3.gz
|
||||
share/man/man3/CURLINFO_REDIRECT_TIME.3.gz
|
||||
share/man/man3/CURLINFO_REDIRECT_TIME_T.3.gz
|
||||
|
@ -511,6 +521,7 @@ share/man/man3/CURLOPT_SASL_IR.3.gz
|
|||
share/man/man3/CURLOPT_SEEKDATA.3.gz
|
||||
share/man/man3/CURLOPT_SEEKFUNCTION.3.gz
|
||||
share/man/man3/CURLOPT_SERVER_RESPONSE_TIMEOUT.3.gz
|
||||
share/man/man3/CURLOPT_SERVER_RESPONSE_TIMEOUT_MS.3.gz
|
||||
share/man/man3/CURLOPT_SERVICE_NAME.3.gz
|
||||
share/man/man3/CURLOPT_SHARE.3.gz
|
||||
share/man/man3/CURLOPT_SOCKOPTDATA.3.gz
|
||||
|
|
Loading…
Reference in a new issue