New port: games/stepmania-devel - Stepmania dance and rhythm game

StepMania is a dance and rhythm video game created by Chris
	Danford. It was originally developed as a simulator of
	Konami's popular arcade game series Dance Dance Revolution,
	and has since evolved into an extensible rhythm game engine
	capable of supporting a wide variety of rhythm-based game
	types.

	Features 3D graphics, visualizations, support for gamepads/dance
	pads, a step recording mode, and more!

	WWW: http://www.stepmania.com

PR:		ports/118769
Submitted by:	Brad Allen <braddo@tranceaddict.net>
This commit is contained in:
Edwin Groothuis 2008-07-05 04:54:54 +00:00
parent 3302de54de
commit edb5a74db9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216349
8 changed files with 1406 additions and 0 deletions

View file

@ -749,6 +749,7 @@
SUBDIR += starfighter
SUBDIR += starlanes
SUBDIR += stepbill
SUBDIR += stepmania-devel
SUBDIR += stormbaancoureur
SUBDIR += stransball2
SUBDIR += stratagus

View file

@ -0,0 +1,77 @@
# New ports collection makefile for: stepmania-devel
# Date created: 16 December 2007
# Whom: Brad Allen <braddo@tranceaddict.net>
#
# $FreeBSD$
#
PORTNAME= stepmania
PORTVERSION= 20071121
PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://surfnet.dl.sourceforge.net/sourceforge/stepmania/ \
http://internap.dl.sourceforge.net/sourceforge/stepmania/
PKGNAMESUFFIX= -devel
DISTNAME= StepMania-CVS-20071121-src
MAINTAINER= braddo@tranceaddict.net
COMMENT= Stepmania dance and rhythm game
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
m.3:${PORTSDIR}/misc/compat5x
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
CONFLICTS= stepmania-[0-9]*
GNU_CONFIGURE= yes
USE_GL= gl glu
USE_XORG= x11 xtst xrandr xau xdmcp xext xrender
USE_ICONV= yes
USE_GNOME= gtk20
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include"
# Not yet implemented
# FFMPEG "Enable ffmpeg support" off \
OPTIONS= VORBIS "Enable Ogg Vorbis support" on \
THEORA "Enable theora support" off \
.include <bsd.port.pre.mk>
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis \
ogg.5:${PORTSDIR}/audio/libogg
.else
CONFIGURE_ARGS+=--without-vorbis
.endif
.if defined(WITH_THEORA)
LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
.else
CONFIGURE_ARGS+=--without-theora
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lrt|-lrt -liconv|' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|@LINUX_TRUE@am__append_19|@UNIX_TRUE@am__append_19|' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|@LINUX_TRUE@am__objects_16|@UNIX_TRUE@am__objects_16|' ${WRKSRC}/src/Makefile.in
do-install:
${MKDIR} ${PREFIX}/share/games
${MKDIR} ${PREFIX}/share/games/stepmania
${MKDIR} ${PREFIX}/share/games/stepmania/Announcers
${MKDIR} ${PREFIX}/share/games/stepmania/Songs
(cd ${WRKSRC} && ${UNZIP_CMD} -o Packages/StepMania.smzip)
(cd ${WRKSRC} && ${COPYTREE_SHARE} "BGAnimations\
BackgroundEffects BackgroundTransitions Characters Courses\
Data NoteSkins Themes" ${PREFIX}/share/games/stepmania)
${INSTALL_PROGRAM} ${WRKSRC}/src/stepmania \
${PREFIX}/share/games/stepmania
${INSTALL_DATA} ${WRKSRC}/src/GtkModule.so \
${PREFIX}/share/games/stepmania
.include <bsd.port.post.mk>

View file

@ -0,0 +1,3 @@
MD5 (StepMania-CVS-20071121-src.tar.gz) = 079c70ff4235e856ad67e70361228746
SHA256 (StepMania-CVS-20071121-src.tar.gz) = 46c35128af7b5055c5e95059c71c364edb5e37ebf7f15c5faa684cd2f13431c7
SIZE (StepMania-CVS-20071121-src.tar.gz) = 12117222

View file

@ -0,0 +1,10 @@
--- Makefile.in.bak 2007-12-16 21:37:14.000000000 +1100
+++ Makefile.in 2007-12-16 21:37:36.000000000 +1100
@@ -201,7 +201,6 @@
AUTOMAKE_OPTIONS = 1.7 foreign
SUBDIRS = src
ACLOCAL_AMFLAGS = -I autoconf/m4
-productID := $(shell sed -nr /define\\s+PRODUCT_ID_BARE/\{s/.*define\\s+PRODUCT_ID_BARE\\s+\(.+\)/\\1/\;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/\;p\;q\} $(srcdir)/src/ProductInfo.h)
installFiles = src/stepmania $(am__append_1)
all: all-recursive

View file

@ -0,0 +1,18 @@
--- src/arch/InputHandler/InputHandler.cpp.orig 2007-03-26 06:06:37.000000000 +0300
+++ src/arch/InputHandler/InputHandler.cpp 2008-01-30 23:20:18.000000000 +0200
@@ -6,6 +6,7 @@
#include "LocalizedString.h"
#include "arch/arch_default.h"
#include "InputHandler_MonkeyKeyboard.h"
+#include "InputHandler_Linux_Joystick.h"
#include "Foreach.h"
void InputHandler::UpdateTimer()
@@ -190,6 +191,7 @@
// Always add
Add.push_back( new InputHandler_MonkeyKeyboard );
+ Add.push_back( new InputHandler_Linux_Joystick );
}

View file

@ -0,0 +1,11 @@
--- src/arch/InputHandler/InputHandler_Linux_Joystick.cpp.orig 2008-01-30 13:54:28.000000000 +0200
+++ src/arch/InputHandler/InputHandler_Linux_Joystick.cpp 2008-01-30 13:55:14.000000000 +0200
@@ -9,6 +9,8 @@
#include <errno.h>
#include <sys/types.h>
+#include <sys/ioctl.h>
+#include <sys/stat.h>
#include <linux/joystick.h>
#include <set>

View file

@ -0,0 +1,9 @@
StepMania is a dance and rhythm video game created by Chris Danford. It was
originally developed as a simulator of Konami's popular arcade game series
Dance Dance Revolution, and has since evolved into an extensible rhythm game
engine capable of supporting a wide variety of rhythm-based game types.
Features 3D graphics, visualizations, support for gamepads/dance pads, a
step recording mode, and more!
WWW: http://www.stepmania.com

File diff suppressed because it is too large Load diff