- Require ${PORTSDIR}/net/libpcap >= 0.9.4 when system libpcap < 0.9.4.

This should also enable pcap on FreeBSD 4/5.
- Backout accidentall committed Makefile change (JIT still does not work on
amd64).
- Notice that dynamips now supports 3600 series.
- Bump PORTREVISION.
This commit is contained in:
Max Khon 2006-11-14 04:22:00 +00:00
parent 83a38e9ea5
commit edd3566211
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177205
6 changed files with 22 additions and 48 deletions

View file

@ -7,12 +7,12 @@
PORTNAME= dynamips
PORTVERSION= 0.2.5
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Cisco 7200 Simulator
COMMENT= Cisco 3600/7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
@ -37,16 +37,19 @@ do-install:
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" #|| ${ARCH} == "amd64"
DYNAMIPS_ARCH= "${ARCH}"
.if ${ARCH} == "i386"
DYNAMIPS_ARCH= "x86"
.elif ${ARCH} == "amd64"
DYNAMIPS_ARCH= "nojit" # JIT does not work on amd64 for some reason
.else
DYNAMIPS_ARCH= "nojit"
.endif
.if ${OSVERSION} < 600029
.if ${OSVERSION} < 602100 || ${OSVERSION} < 700021
#
# Requires libpcap 0.9+
MAKE_ENV+= HAS_PCAP=0
# Requires libpcap 0.9.4
LIB_DEPENDS+= pcap.2:${PORTSDIR}/net/libpcap
BUILD_DEPENDS+= libpcap>=0.9.4:${PORTSDIR}/net/libpcap
.endif
.if ${OSVERSION} >= 700013

View file

@ -1,16 +0,0 @@
--- gen_eth.c.orig Thu Sep 14 17:59:13 2006
+++ gen_eth.c Tue Nov 14 00:28:18 2006
@@ -25,6 +25,13 @@
#include <netinet/in.h>
#include <arpa/inet.h>
#include <pthread.h>
+#ifdef __FreeBSD__
+#include <osreldate.h>
+
+#if __FreeBSD_version < 602100 || __FreeBSD_version < 700021
+#define PCAP_D_IN D_IN
+#endif
+#endif
#ifdef CYGWIN
/* Needed for pcap_open() flags */

View file

@ -1,3 +1,3 @@
Cisco 7200 simulator.
Cisco 3600/7200 simulator.
WWW: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator

View file

@ -7,12 +7,12 @@
PORTNAME= dynamips
PORTVERSION= 0.2.5
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Cisco 7200 Simulator
COMMENT= Cisco 3600/7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
@ -37,16 +37,19 @@ do-install:
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" #|| ${ARCH} == "amd64"
DYNAMIPS_ARCH= "${ARCH}"
.if ${ARCH} == "i386"
DYNAMIPS_ARCH= "x86"
.elif ${ARCH} == "amd64"
DYNAMIPS_ARCH= "nojit" # JIT does not work on amd64 for some reason
.else
DYNAMIPS_ARCH= "nojit"
.endif
.if ${OSVERSION} < 600029
.if ${OSVERSION} < 602100 || ${OSVERSION} < 700021
#
# Requires libpcap 0.9+
MAKE_ENV+= HAS_PCAP=0
# Requires libpcap 0.9.4
LIB_DEPENDS+= pcap.2:${PORTSDIR}/net/libpcap
BUILD_DEPENDS+= libpcap>=0.9.4:${PORTSDIR}/net/libpcap
.endif
.if ${OSVERSION} >= 700013

View file

@ -1,16 +0,0 @@
--- gen_eth.c.orig Thu Sep 14 17:59:13 2006
+++ gen_eth.c Tue Nov 14 00:28:18 2006
@@ -25,6 +25,13 @@
#include <netinet/in.h>
#include <arpa/inet.h>
#include <pthread.h>
+#ifdef __FreeBSD__
+#include <osreldate.h>
+
+#if __FreeBSD_version < 602100 || __FreeBSD_version < 700021
+#define PCAP_D_IN D_IN
+#endif
+#endif
#ifdef CYGWIN
/* Needed for pcap_open() flags */

View file

@ -1,3 +1,3 @@
Cisco 7200 simulator.
Cisco 3600/7200 simulator.
WWW: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator