Update to 3.2.0 and build fix with gcc43.

Spotted by:	pav, brooks
This commit is contained in:
Maho Nakata 2009-02-17 04:48:35 +00:00
parent adbc30aa47
commit edd98c7106
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=228532
7 changed files with 52 additions and 74 deletions

View file

@ -6,12 +6,10 @@
#
PORTNAME= suitesparse
PORTVERSION= 3.1.0
PORTREVISION= 1
PORTVERSION= 3.2.0
CATEGORIES= math
MASTER_SITES= http://www.cise.ufl.edu/research/sparse/SuiteSparse/
DISTNAME= SuiteSparse-${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
COMMENT= SuiteSparse is a set of packages for sparse matrices calculation
@ -66,6 +64,7 @@ WRKSRC_SHARED=${WRKSRC}_shared
CFLAGS_SHARED=${CFLAGS} ${FPIC}
FFLAGS_SHARED=${CFLAGS} ${FPIC}
SVERSION=1
FORTRANRUNTIME=-lgfortran -lgfortranbegin
.if defined (WITH_METIS)
METIS=${LOCALBASE}/lib/libmetis.a
@ -78,9 +77,10 @@ CHOLMOD_CONFIG = -DNPARTITION
post-patch:
${CP} -r ${WRKSRC} ${WRKSRC_SHARED}
@${REINPLACE_CMD} -e 's,%%CC%%,${CC},g' \
-e 's,%%CXX%%,${CXX},g' \
-e 's,%%F77%%,${F77},g' \
-e 's,%%FC%%,${FC},g' \
-e 's,%%BLAS%%,-L${LOCALBASE}/lib ${BLAS},g' \
-e 's,%%FORTRANRUNTIME%%,${FORTRANRUNTIME},g' \
-e 's,%%LAPACK%%,-L${LOCALBASE}/lib ${LAPACK},g' \
-e 's,%%LOCALBASE%%,${LOCALBASE},g' \
-e 's,%%METIS_PATH%%,${METIS_PATH},g' \
@ -89,21 +89,17 @@ post-patch:
${WRKSRC}/UFconfig/UFconfig.mk \
${WRKSRC_SHARED}/UFconfig/UFconfig.mk\
${WRKSRC}/CSparse/Lib/Makefile \
${WRKSRC_SHARED}/CSparse/Lib/Makefile \
${WRKSRC}/CXSparse/Lib/Makefile \
${WRKSRC_SHARED}/CXSparse/Lib/Makefile
${WRKSRC_SHARED}/CSparse/Lib/Makefile
@${REINPLACE_CMD} -e 's,%%CFLAGS%%,${CFLAGS},g' \
-e 's,%%FFLAGS%%,${FFLAGS},g' \
${WRKSRC}/UFconfig/UFconfig.mk \
${WRKSRC}/CSparse/Lib/Makefile \
${WRKSRC}/CXSparse/Lib/Makefile
${WRKSRC}/CSparse/Lib/Makefile
@${REINPLACE_CMD} -e 's,%%CFLAGS%%,${CFLAGS_SHARED},g' \
-e 's,%%FFLAGS%%,${FFLAGS_SHARED},g' \
${WRKSRC_SHARED}/UFconfig/UFconfig.mk \
${WRKSRC_SHARED}/CSparse/Lib/Makefile \
${WRKSRC_SHARED}/CXSparse/Lib/Makefile
${WRKSRC_SHARED}/CSparse/Lib/Makefile
do-build:
cd ${WRKSRC} ; ${GMAKE}

View file

@ -1,3 +1,3 @@
MD5 (suitesparse/3.1.0/SuiteSparse-3.1.0.tar.gz) = 58d90444feef92fc7c265cbd11a757c6
SHA256 (suitesparse/3.1.0/SuiteSparse-3.1.0.tar.gz) = cd27e4a18a8924c3aa867ad03328ba08a94cfb157b0945aa440a2e9b646ce4b4
SIZE (suitesparse/3.1.0/SuiteSparse-3.1.0.tar.gz) = 9051595
MD5 (SuiteSparse-3.2.0.tar.gz) = d1be7abb6227568fec94179cb1300303
SHA256 (SuiteSparse-3.2.0.tar.gz) = 57ed92ac73f9cfcf691d3b239f5d721caebfbde7dc07a82ead54cbc8b8739d58
SIZE (SuiteSparse-3.2.0.tar.gz) = 10259916

View file

@ -1,11 +0,0 @@
--- CHOLMOD/Demo/Makefile~ Fri Aug 25 22:41:39 2006
+++ CHOLMOD/Demo/Makefile Wed Jan 10 07:16:27 2007
@@ -19,7 +19,7 @@
$(LAPACK) $(BLAS) $(XERBLA) $(LIB)
#-------------------------------------------------------------------------------
-C = $(CC) $(CFLAGS) $(CHOLMOD_CONFIG)
+C = $(FC) $(CFLAGS) $(CHOLMOD_CONFIG)
code: library cholmod_demo cholmod_l_demo cholmod_simple

View file

@ -1,11 +0,0 @@
--- CXSparse/Lib/Makefile~ Sun May 6 06:03:41 2007
+++ CXSparse/Lib/Makefile Wed Feb 27 11:59:17 2008
@@ -1,6 +1,6 @@
# Modify the "-O" optimization option for best performance (-O3 on Linux):
-CC = cc
-CFLAGS = -O
+CC = %%CC%%
+CFLAGS = %%CFLAGS%%
I = -I../../UFconfig -I../Include
AR = ar cr

View file

@ -0,0 +1,10 @@
--- SPQR/Source/spqr_factorize.cpp~ 2008-09-22 06:10:37.000000000 +0900
+++ SPQR/Source/spqr_factorize.cpp 2009-02-16 15:47:49.000000000 +0900
@@ -31,6 +31,7 @@
// =============================================================================
#include "spqr.hpp"
+#include <string.h>
#define FCHUNK 32 // FUTURE: make a parameter; Householder block size

View file

@ -1,40 +1,43 @@
--- UFconfig/UFconfig.mk.orig 2007-10-24 22:55:44.000000000 +0900
+++ UFconfig/UFconfig.mk 2008-02-03 12:04:00.000000000 +0900
@@ -32,8 +32,8 @@
--- UFconfig/UFconfig.mk~ 2009-02-16 14:40:18.000000000 +0900
+++ UFconfig/UFconfig.mk 2009-02-16 14:44:33.000000000 +0900
@@ -33,11 +33,11 @@
# C compiler and compiler flags: These will normally not give you optimal
# performance. You should select the optimization parameters that are best
# for your system. On Linux, use "CFLAGS = -O3 -fexceptions" for example.
-CC = cc
-CFLAGS = -O
-# CFLAGS = -O (for example; see below for details)
+CC = %%CC%%
+CFLAGS = %%CFLAGS%%
# C++ compiler (also uses CFLAGS)
-CPLUSPLUS = g++
+CPLUSPLUS = %%CXX%%
# ranlib, and ar, for generating libraries
RANLIB = ranlib
@@ -44,8 +44,9 @@
@@ -48,8 +48,8 @@
MV = mv -f
# Fortran compiler (not normally required)
-F77 = f77
-F77FLAGS = -O
+F77 = %%F77%%
+FC = %%FC%%
+F77FLAGS = %%FFLAGS%%
F77LIB =
# C and Fortran libraries
@@ -85,8 +86,8 @@
# BLAS = -lgoto -lgfortran -lgfortranbegin
@@ -89,8 +89,8 @@
# BLAS = -lgoto -lgfortran -lgfortranbegin -lg2c
# This is probably slow ... it might connect to the Standard Reference BLAS:
-BLAS = -lblas -lgfortran -lgfortranbegin
-BLAS = -lblas -lgfortran -lgfortranbegin -lg2c
-LAPACK = -llapack
+BLAS = %%BLAS%%
+BLAS = %%BLAS%% %%FORTRANRUNTIME%%
+LAPACK = %%LAPACK%%
# The BLAS might not contain xerbla, an error-handling routine for LAPACK and
# the BLAS. Also, the standard xerbla requires the Fortran I/O library, and
@@ -114,8 +115,8 @@
# Using non-optimized versions:
# BLAS = -lblas_plain -lgfortran -lgfortranbegin -lg2c
@@ -122,8 +122,8 @@
# The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
# You may wish to use an absolute path. METIS is optional. Compile
# CHOLMOD with -DNPARTITION if you do not wish to use METIS.
@ -45,16 +48,7 @@
# If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
# options:
@@ -138,7 +139,7 @@
# -DNRECIPROCAL do not multiply by the reciprocal
# -DNO_DIVIDE_BY_ZERO do not divide by zero
-UMFPACK_CONFIG =
+UMFPACK_CONFIG = -DGETRUSAGE
#------------------------------------------------------------------------------
# CHOLMOD configuration
@@ -177,7 +177,7 @@
@@ -184,7 +184,7 @@
# -DNSUNPERF for Solaris only. If defined, do not use the Sun
# Performance Library
@ -62,13 +56,22 @@
+CHOLMOD_CONFIG = %%CHOLMOD_CONFIG%%
#------------------------------------------------------------------------------
# Linux
@@ -184,15 +185,15 @@
# SuiteSparseQR configuration:
@@ -198,7 +198,7 @@
# -DHAVE_TBB enable the use of Intel's Threading Building Blocks (TBB)
# default, without timing, without TBB:
-SPQR_CONFIG =
+SPQR_CONFIG = %%CHOLMOD_CONFIG%%
# with timing and TBB:
# SPQR_CONFIG = -DTIMING -DHAVE_TBB
# with timing
@@ -220,15 +220,15 @@
# Using default compilers:
# CC = gcc
-CFLAGS = -O3
+# CFLAGS = -O3
-CFLAGS = -O3 -fexceptions
+# CFLAGS = -O3 -fexceptions
# alternatives:
# CFLAGS = -g -fexceptions \
@ -83,3 +86,5 @@
+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
# CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
# CFLAGS = -O3
# CFLAGS = -O3 -g -fexceptions

View file

@ -1,11 +0,0 @@
--- UMFPACK/Demo/Makefile.old Wed Jan 10 07:13:07 2007
+++ UMFPACK/Demo/Makefile Wed Jan 10 07:13:22 2007
@@ -10,7 +10,7 @@
include ../../UFconfig/UFconfig.mk
-C = $(CC) $(CFLAGS) $(UMFPACK_CONFIG) -I../Include -I../../AMD/Include \
+C = $(FC) $(CFLAGS) $(UMFPACK_CONFIG) -I../Include -I../../AMD/Include \
-I../../UFconfig
INC = ../Include/umfpack.h ../../AMD/Include/amd.h ../../UFconfig/UFconfig.h