Update to 1.1.5
This commit is contained in:
parent
c7cb60b545
commit
ee5773d574
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=447984
13 changed files with 83 additions and 111 deletions
|
@ -2,12 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= driftnet
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.1.5
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= http://ftp.openbsd.org/pub/OpenBSD/distfiles/ \
|
||||
LOCAL/ehaupt
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
||||
MAINTAINER= ehaupt@FreeBSD.org
|
||||
COMMENT= Tool to grab images out of (your) TCP connections
|
||||
|
@ -21,15 +17,16 @@ BUILD_DEPENDS= makedepend:devel/makedepend
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= autoreconf gettext-runtime gmake jpeg localbase:ldflags pkgconfig
|
||||
USE_CSTD= gnu89
|
||||
USE_GITHUB= yes
|
||||
USE_GNOME= gtk20
|
||||
USE_XORG= x11 xext xi
|
||||
|
||||
GH_ACCOUNT= deiv
|
||||
GH_TAGNAME= upstream/${PORTVERSION}
|
||||
|
||||
PLIST_FILES= bin/driftnet man/man1/driftnet.1.gz
|
||||
PORTDOCS= *
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1484644152
|
||||
SHA256 (driftnet_1.0.orig.tar.gz) = b2e675ec4c8eec126198d4010880b579d728cf17e52106d7f40f0a135000eaa7
|
||||
SIZE (driftnet_1.0.orig.tar.gz) = 151184
|
||||
TIMESTAMP = 1502797595
|
||||
SHA256 (deiv-driftnet-1.1.5-upstream-1.1.5_GH0.tar.gz) = 270fc081965fb9fb2163a0cb511cce45398585a481a85c8a34e71f32fefcb86d
|
||||
SIZE (deiv-driftnet-1.1.5-upstream-1.1.5_GH0.tar.gz) = 166481
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- Makefile.am.orig 2013-05-12 15:16:43 UTC
|
||||
+++ Makefile.am
|
||||
@@ -4,13 +4,13 @@ SUBDIRS = src
|
||||
dist_doc_DATA = README TODO
|
||||
EXTRA_DIST = driftnet.1.in CHANGES CREDITS
|
||||
|
||||
-MANPAGE = driftnet.1.gz
|
||||
+MANPAGE = driftnet.1
|
||||
MAN1DIR = $(DESTDIR)$(mandir)/man1/
|
||||
|
||||
clean-local:
|
||||
rm -f $(MANPAGE)
|
||||
|
||||
install-data-local: driftnet.1.in
|
||||
- cat $(srcdir)/driftnet.1.in | sed s/@*VERSION@*/$(VERSION)/ | GZIP=$(GZIP_ENV) gzip > $(MANPAGE)
|
||||
+ cat $(srcdir)/driftnet.1.in | sed s/@*VERSION@*/$(VERSION)/ > $(MANPAGE)
|
||||
$(MKDIR_P) $(MAN1DIR)
|
||||
$(INSTALL_DATA) $(MANPAGE) $(MAN1DIR) || exit $$?
|
|
@ -1,14 +0,0 @@
|
|||
--- configure.ac.orig 2013-05-12 15:16:43 UTC
|
||||
+++ configure.ac
|
||||
@@ -24,11 +24,6 @@ AC_ARG_ENABLE([debug],
|
||||
,
|
||||
[enable_debug=yes])
|
||||
|
||||
-if test "x$enable_debug" = xyes; then
|
||||
- CFLAGS="-O2 -g -DDEBUG"
|
||||
-else
|
||||
- CFLAGS="-O2 -DNDEBUG"
|
||||
-fi
|
||||
#AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
|
||||
|
||||
#
|
13
net-mgmt/driftnet/files/patch-src_connection.c
Normal file
13
net-mgmt/driftnet/files/patch-src_connection.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/connection.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/connection.c
|
||||
@@ -19,6 +19,10 @@
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <sys/types.h>
|
||||
+#endif
|
||||
+
|
||||
#include "util.h"
|
||||
#include "media.h"
|
||||
#include "driftnet.h"
|
|
@ -1,15 +1,19 @@
|
|||
--- src/display/gif.c.orig 2013-05-12 15:16:43 UTC
|
||||
--- src/display/gif.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/display/gif.c
|
||||
@@ -22,7 +22,7 @@
|
||||
*/
|
||||
@@ -25,12 +25,7 @@
|
||||
int gif_load_hdr(img I) {
|
||||
GifFileType *g;
|
||||
|
||||
-/* GIFLIB_MAJOR is not defined until version 5 of libgif */
|
||||
-#if defined GIFLIB_MAJOR && GIFLIB_MAJOR >= 5
|
||||
g = I->us = DGifOpenFileHandle(fileno(I->fp), NULL);
|
||||
-#else
|
||||
- g = I->us = DGifOpenFileHandle(fileno(I->fp));
|
||||
+ g = I->us = DGifOpenFileHandle(fileno(I->fp), NULL);
|
||||
-#endif
|
||||
|
||||
if (!I->us) {
|
||||
I->err = IE_HDRFORMAT;
|
||||
return 0;
|
||||
@@ -38,7 +38,7 @@ int gif_load_hdr(img I) {
|
||||
@@ -47,7 +42,7 @@ int gif_load_hdr(img I) {
|
||||
* Abort loading a GIF file after the header is done.
|
||||
*/
|
||||
int gif_abort_load(img I) {
|
||||
|
@ -18,7 +22,7 @@
|
|||
return 1;
|
||||
}
|
||||
|
||||
@@ -116,7 +116,7 @@ int gif_load_img(img I) {
|
||||
@@ -125,7 +120,7 @@ int gif_load_img(img I) {
|
||||
ret = 1;
|
||||
fail:
|
||||
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- src/display/img.h.orig 2013-05-12 15:22:44 UTC
|
||||
+++ src/display/img.h
|
||||
@@ -19,11 +19,13 @@
|
||||
|
||||
#include <stdio.h>
|
||||
|
||||
+#include <sys/endian.h>
|
||||
+
|
||||
typedef uint8_t chan;
|
||||
typedef uint32_t pel;
|
||||
|
||||
/* Yuk. GDKRGB expects data in a specific ordering. */
|
||||
-#if defined(DRIFTNET_LITTLE_ENDIAN)
|
||||
+#if defined(LITTLE_ENDIAN)
|
||||
# define PEL(r, g, b) ((pel)((chan)(r) | ((chan)(g) << 8) | ((chan)(b) << 16)))
|
||||
# define PELA(r, g, b, a) ((pel)((chan)(r) | ((chan)(g) << 8) | ((chan)(b) << 16) | ((chan)(a) << 24)))
|
||||
|
||||
@@ -31,7 +33,7 @@ typedef uint32_t pel;
|
||||
# define GETG(p) ((chan)(((p) & (pel)0x0000ff00) >> 8))
|
||||
# define GETB(p) ((chan)(((p) & (pel)0x00ff0000) >> 16))
|
||||
# define GETA(p) ((chan)(((p) & (pel)0xff000000) >> 24))
|
||||
-#elif defined(DRIFTNET_BIG_ENDIAN)
|
||||
+#elif defined(BIG_ENDIAN)
|
||||
# define PEL(r, g, b) ((pel)(((chan)(r) << 24) | ((chan)(g) << 16) | ((chan)(b) << 8)))
|
||||
# define PELA(r, g, b, a) ((pel)(((chan)(r) << 24) | ((chan)(g) << 16) | ((chan)(b) << 8) | ((chan)(a))))
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
--- src/display/png.c.orig 2013-05-12 15:16:43 UTC
|
||||
+++ src/display/png.c
|
||||
@@ -132,9 +132,9 @@ int png_load_img(img I) {
|
||||
/* Convert greyscale images to 8-bit RGB */
|
||||
if (color_type == PNG_COLOR_TYPE_GRAY ||
|
||||
color_type == PNG_COLOR_TYPE_GRAY_ALPHA) {
|
||||
- if (bit_depth < 8) {
|
||||
+ /* if (bit_depth < 8) {
|
||||
png_set_gray_1_2_4_to_8(png_ptr);
|
||||
- }
|
||||
+ } */
|
||||
png_set_gray_to_rgb(png_ptr);
|
||||
}
|
||||
|
|
@ -1,30 +1,36 @@
|
|||
--- src/layer2.c.orig 2013-05-12 15:16:43 UTC
|
||||
--- src/layer2.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/layer2.c
|
||||
@@ -3,7 +3,10 @@
|
||||
#include <string.h>
|
||||
#include <assert.h>
|
||||
@@ -9,7 +9,14 @@
|
||||
|
||||
-#include <netinet/ether.h>
|
||||
+//#include <netinet/ether.h>
|
||||
#include <string.h>
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <sys/types.h>
|
||||
+#include <netinet/in_systm.h>
|
||||
+#include <netinet/in.h>
|
||||
+#else
|
||||
#include <netinet/ether.h>
|
||||
+#endif
|
||||
+
|
||||
#include <netinet/ip.h>
|
||||
#include <netinet/ip6.h>
|
||||
|
||||
@@ -12,6 +15,15 @@
|
||||
#include "log.h"
|
||||
@@ -19,6 +26,18 @@
|
||||
#include "packetcapture.h" /* for datalink_info_t */
|
||||
#include "layer2.h"
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#define ETH_P_IP 0x0800
|
||||
+#define ETH_P_IPV6 0x86DD
|
||||
+#define ETH_ALEN 6
|
||||
+#define ETH_P_ARP 0x0806
|
||||
+struct ethhdr {
|
||||
+ unsigned char h_dest[ETH_ALEN];
|
||||
+ unsigned char h_source[ETH_ALEN];
|
||||
+ u_int16_t h_proto;
|
||||
+ unsigned char h_dest[ETH_ALEN];
|
||||
+ unsigned char h_source[ETH_ALEN];
|
||||
+ u_int16_t h_proto;
|
||||
+} __attribute__((packed));
|
||||
+#endif
|
||||
+
|
||||
int handle_link_layer(datalink_info_t *info, const u_char *pkt, uint8_t *nextproto,
|
||||
int *offsetnext)
|
||||
{
|
||||
/* ETH_P_PAE is named ETHERTYPE_PAE in freebsd, define it */
|
||||
#ifndef ETH_P_PAE
|
||||
#define ETH_P_PAE 0x888E
|
||||
|
|
|
@ -1,15 +1,16 @@
|
|||
--- src/layer3.c.orig 2013-05-12 15:16:43 UTC
|
||||
--- src/layer3.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/layer3.c
|
||||
@@ -3,8 +3,12 @@
|
||||
@@ -10,6 +10,13 @@
|
||||
#include <string.h>
|
||||
#include <assert.h>
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <sys/types.h>
|
||||
+#include <netinet/in_systm.h>
|
||||
+#include <netinet/in.h>
|
||||
+#include <sys/socket.h>
|
||||
+#endif
|
||||
+
|
||||
#include <netinet/ip.h>
|
||||
#include <netinet/ip6.h>
|
||||
+#include <sys/socket.h>
|
||||
|
||||
#include "log.h"
|
||||
#include "layer3.h"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/media/image.c.orig 2013-05-12 15:16:43 UTC
|
||||
--- src/media/image.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/media/image.c
|
||||
@@ -10,6 +10,7 @@
|
||||
@@ -16,6 +16,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h> /* On many systems (Darwin...), stdio.h is a prerequisite. */
|
||||
#include <string.h>
|
||||
|
|
10
net-mgmt/driftnet/files/patch-src_media_media.c
Normal file
10
net-mgmt/driftnet/files/patch-src_media_media.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/media/media.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/media/media.c
|
||||
@@ -17,6 +17,7 @@
|
||||
#include "compat.h"
|
||||
|
||||
#include <string.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#include "util.h"
|
||||
#include "tmpdir.h"
|
13
net-mgmt/driftnet/files/patch-src_pid.c
Normal file
13
net-mgmt/driftnet/files/patch-src_pid.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/pid.c.orig 2014-09-14 19:16:31 UTC
|
||||
+++ src/pid.c
|
||||
@@ -14,7 +14,9 @@
|
||||
|
||||
#include "compat.h"
|
||||
|
||||
-//#include <sys/stat.h>
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <sys/stat.h>
|
||||
+#endif
|
||||
#include <fcntl.h>
|
||||
#include <errno.h>
|
||||
#include <stdio.h>
|
Loading…
Reference in a new issue