- Update to 12.18.2
Approved by: Dan Nelson <dnelson@allantgroup.com> (maintainer)
This commit is contained in:
parent
6069244d09
commit
ee60096ee6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=172229
3 changed files with 26 additions and 26 deletions
|
@ -6,33 +6,34 @@
|
|||
#
|
||||
|
||||
PORTNAME= sox
|
||||
PORTVERSION= 12.18.1
|
||||
PORTVERSION= 12.18.2
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= dnelson@allantgroup.com
|
||||
COMMENT= SOund eXchange - universal sound sample translator
|
||||
|
||||
CONFLICTS= play-[0-9]*
|
||||
|
||||
MAN1= sox.1 play.1 soxexam.1
|
||||
MLINKS= play.1 rec.1 sox.1 soxmix.1
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_ENV= PLAY_SUPPORT=1
|
||||
MAN1= sox.1 play.1 soxexam.1
|
||||
MLINKS= play.1 rec.1 sox.1 soxmix.1
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_ENV= PLAY_SUPPORT=1
|
||||
|
||||
OPTIONS= LAME "Enable mp3 encoding with LAME" off \
|
||||
MAD "Enable mp3 decoding with MAD" off \
|
||||
VORBIS "Enable Ogg Vorbis support" off
|
||||
VORBIS "Enable Ogg Vorbis support" off \
|
||||
GSM "Enable GSM audio codec support" off
|
||||
|
||||
PLIST_FILES= bin/sox bin/soxmix bin/rec bin/play
|
||||
CONFIGURE_ARGS= --disable-alsa-dsp --disable-sun-audio
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_VORBIS) || defined(WITH_LAME) || defined(WITH_MAD)
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
.if defined(WITH_VORBIS) || defined(WITH_LAME) || defined(WITH_MAD) || defined(WITH_GSM)
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_VORBIS)
|
||||
|
@ -56,4 +57,15 @@ LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
|
|||
CONFIGURE_ARGS+= --disable-mad
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GSM)
|
||||
CONFIGURE_ARGS+= --enable-external-gsm
|
||||
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-external-gsm --disable-gsm
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -Ee 's![[:<:]]gsm/!!' ${WRKSRC}/configure ${WRKSRC}/src/Makefile.gcc \
|
||||
${WRKSRC}/src/gsm.c ${WRKSRC}/src/wav.c
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (sox-12.18.1.tar.gz) = b12507493d3c8571fa8b6e70a01d5438
|
||||
SHA256 (sox-12.18.1.tar.gz) = 2fc7bb73436e152a6cdd932bb772f13cc773da9596a45d17a64d88fa6726c283
|
||||
SIZE (sox-12.18.1.tar.gz) = 473181
|
||||
MD5 (sox-12.18.2.tar.gz) = ba25e512a6c824d6e56d76767a18af99
|
||||
SHA256 (sox-12.18.2.tar.gz) = 832bf98c95580af879fe51311c861ba7c57f07a5791628108ef29a027f0271ff
|
||||
SIZE (sox-12.18.2.tar.gz) = 486814
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- ./Makefile.in.orig Mon Nov 8 01:37:20 2004
|
||||
+++ ./Makefile.in Fri Jun 2 10:55:50 2006
|
||||
@@ -30,6 +30,9 @@
|
||||
PLAY_INSTALL_0 =
|
||||
PLAY_INSTALL_1 = install-play
|
||||
|
||||
+PLAY_INSTALL_0 =
|
||||
+PLAY_INSTALL_1 = install-play
|
||||
+
|
||||
install: $(PLAY_INSTALL_$(PLAY_SUPPORT))
|
||||
cd src && $(MAKE) $@
|
||||
$(srcdir)/mkinstalldirs $(mandir)/man1
|
Loading…
Reference in a new issue