Initial import of portscanner, a quick and dirty way to scan ports
similar to strobe, but much quicker, and good for use in scripts and CGI. PR: ports/7582
This commit is contained in:
parent
73d1f77e10
commit
eea0c917c3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14616
6 changed files with 48 additions and 0 deletions
27
security/portscanner/Makefile
Normal file
27
security/portscanner/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# New ports collection makefile for: portscanner
|
||||
# Version required: 1.0
|
||||
# Date created: 11 August 1998
|
||||
# Whom: Bill Fumerola <billf@chc-chimes.com>
|
||||
#
|
||||
# $Id: $
|
||||
#
|
||||
|
||||
DISTNAME= PortScanner-1.0
|
||||
PKGNAME= portscanner-1.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.ameth.org/~veilleux/ \
|
||||
http://www.FreeBSD.org/~billf/
|
||||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
|
||||
do-build:
|
||||
|
||||
${CC} -o ${WRKSRC}/portscanner ${CFLAGS} ${WRKSRC}/portscanner.c
|
||||
|
||||
do-install:
|
||||
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/portscanner ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/portscanner/distinfo
Normal file
1
security/portscanner/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (PortScanner-1.0.tar.gz) = 633e77b3cd66872d7baef0b14bbbf13e
|
11
security/portscanner/files/patch-aa
Normal file
11
security/portscanner/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- portscanner.c.old Tue Aug 11 17:11:20 1998
|
||||
+++ portscanner.c Tue Aug 11 17:11:27 1998
|
||||
@@ -35,7 +35,7 @@
|
||||
int sock = -1;
|
||||
struct sockaddr_in address;
|
||||
int result;
|
||||
-extern char *sys_errlist[];
|
||||
+/* extern char *sys_errlist[]; */
|
||||
extern int errno;
|
||||
int current_port = 0;
|
||||
u_short base_port = 0;
|
1
security/portscanner/pkg-comment
Normal file
1
security/portscanner/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
a simple and easy to use TCP port scanner
|
7
security/portscanner/pkg-descr
Normal file
7
security/portscanner/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
PortScanner is a simple and easy to use TCP port scanner. It is usually used to
|
||||
log the running servers on a remote machine for security purposes and to help
|
||||
people find services.
|
||||
|
||||
http://www.ameth.org/~veilleux/
|
||||
|
||||
Bill Fumerola <billf@chc-chimes.com>
|
1
security/portscanner/pkg-plist
Normal file
1
security/portscanner/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/portscanner
|
Loading…
Reference in a new issue