A build fix.
This commit is contained in:
parent
6f02383274
commit
eeaaf3ac3d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218669
9 changed files with 197 additions and 84 deletions
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
25
editors/openoffice-3/files/patch-i91369
Normal file
25
editors/openoffice-3/files/patch-i91369
Normal file
|
@ -0,0 +1,25 @@
|
|||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
25
editors/openoffice.org-3/files/patch-i91369
Normal file
25
editors/openoffice.org-3/files/patch-i91369
Normal file
|
@ -0,0 +1,25 @@
|
|||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
|
@ -1,16 +1,25 @@
|
|||
Index: store/util/makefile.mk
|
||||
===================================================================
|
||||
RCS file: /cvs/ucb/store/util/makefile.mk,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 makefile.mk
|
||||
--- store/util/makefile.mk 10 Apr 2008 14:23:47 -0000 1.24
|
||||
+++ store/util/makefile.mk 30 Jun 2008 23:52:56 -0000
|
||||
@@ -78,7 +78,7 @@
|
||||
.ELSE
|
||||
.IF "$(OS)"=="NETBSD"
|
||||
#FBSD7+amd64+gcc421 is okay without the patch (w/o -lsupc++ is fine)
|
||||
#FBSD6+amd64+gcc342 is okay with the patch (w/o -lsupc++ is fine)
|
||||
...-lsupc++ is static, and cannot find -lgcc_s
|
||||
#FBSD6+i386+gcc342 is okay with the patch (w/o -lsupc++ -lgcc_s is fine)
|
||||
cannot find -lgcc_s
|
||||
|
||||
--- store/util/makefile.mk.orig 2007-12-12 22:23:13.000000000 +0900
|
||||
+++ store/util/makefile.mk 2008-08-16 20:52:44.000000000 +0900
|
||||
@@ -76,6 +76,7 @@
|
||||
.ENDIF
|
||||
|
||||
# On gcc3 __Unwind_SetIP is not in supc++ but in libgcc_s.so
|
||||
+# FBSD6+amd64+gcc342 does not require -lsupc++. only libsupc++.a is supplied
|
||||
.IF "$(COMID)"=="gcc3" && "$(GUI)"!="OS2"
|
||||
.IF "$(GUI)"=="WNT"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
-.ELIF "$(OS)"=="MACOSX"
|
||||
+.ELIF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
|
||||
@@ -86,6 +87,8 @@
|
||||
.IF "$(CCNUMVER)"<="000399999999"
|
||||
SHL1STDLIBS+= -lsupc++
|
||||
.ENDIF # CCNUMVER
|
||||
+.ELIF "$(OS)"=="FREEBSD"
|
||||
+SHL1STDLIBS+=
|
||||
.ELIF "$(CCNUMVER)"<="000400000999"
|
||||
SHL1STDLIBS+= -lsupc++ -lgcc_s
|
||||
.ENDIF
|
||||
|
|
Loading…
Reference in a new issue