x11-drivers/xf86-video-ati:
On other ARCH then i386/amd64 keep the old version. Since 7.x is KMS which is not available on the other ARCHS. x11-drivers/xf86-video-nv: Fix nv driver on ppc. x11-servers/xorg-server: In the powerpc case of NEW_XORG don't overwrite EXTRA_PATCHES. Patch update: < nathanw> it works around the change in behavior in libpciaccess that the PR mentions < nathanw> by porting the relevant code from the Linux backend PR: ports/188278 Submitted by: jmmv@, nwhitehorn@
This commit is contained in:
parent
55e4a46b72
commit
eeabcd7024
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=355734
4 changed files with 43 additions and 7 deletions
|
@ -14,7 +14,8 @@ USE_XORG= xf86driproto xineramaproto xf86miscproto glproto
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OSVERSION} < 1000051 || !defined(WITH_NEW_XORG)
|
||||
.if ${OSVERSION} < 1000051 || !defined(WITH_NEW_XORG) || \
|
||||
(${ARCH} != i386 && ${ARCH} != amd64)
|
||||
ATI_VERSION= 6.14.6
|
||||
ATI_REVISION= 3
|
||||
CONFIGURE_ARGS+=--disable-kms
|
||||
|
|
14
x11-drivers/xf86-video-nv/files/patch-src-nv_driver.c
Normal file
14
x11-drivers/xf86-video-nv/files/patch-src-nv_driver.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/nv_driver.c.orig 2014-01-19 15:24:45.000000000 -0600
|
||||
+++ src/nv_driver.c 2014-01-19 15:24:07.000000000 -0600
|
||||
@@ -1543,7 +1543,11 @@
|
||||
xf86FreeInt10(pNv->pInt);
|
||||
return FALSE;
|
||||
}
|
||||
+#ifdef __powerpc__ /* XXX probably MI */
|
||||
+ vgaHWSetMmioFuncs(VGAHWPTR(pScrn), pNv->IOAddress, 0);
|
||||
+#else
|
||||
vgaHWSetStdFuncs(VGAHWPTR(pScrn));
|
||||
+#endif
|
||||
|
||||
/* We use a programmable clock */
|
||||
pScrn->progClock = TRUE;
|
|
@ -124,7 +124,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-old-arch-i386
|
|||
|
||||
.if ${ARCH} == ia64
|
||||
PLIST_SUB+= IA64_NA="@comment "
|
||||
EXTRA_PATCHES= ${.CURDIR}/files/extra-arch-ia64
|
||||
EXTRA_PATCHES+= ${.CURDIR}/files/extra-arch-ia64
|
||||
.else
|
||||
PLIST_SUB+= IA64_NA=""
|
||||
.endif
|
||||
|
@ -132,9 +132,9 @@ PLIST_SUB+= IA64_NA=""
|
|||
.if ${ARCH} == powerpc || ${ARCH} == powerpc64
|
||||
PLIST_SUB+= PPC_NA="@comment "
|
||||
.if defined(WITH_NEW_XORG)
|
||||
EXTRA_PATCHES= ${.CURDIR}/files/extra-new-arch-powerpc
|
||||
EXTRA_PATCHES+= ${.CURDIR}/files/extra-new-arch-powerpc
|
||||
.else
|
||||
EXTRA_PATCHES= ${.CURDIR}/files/extra-old-arch-powerpc
|
||||
EXTRA_PATCHES+= ${.CURDIR}/files/extra-old-arch-powerpc
|
||||
.endif
|
||||
.else
|
||||
PLIST_SUB+= PPC_NA=""
|
||||
|
|
|
@ -1,6 +1,27 @@
|
|||
--- hw/xfree86/os-support/bsd/ppc_video.c.orig 2012-05-17 19:09:03.000000000 +0200
|
||||
+++ hw/xfree86/os-support/bsd/ppc_video.c 2013-06-03 13:46:05.165578200 +0200
|
||||
@@ -135,7 +135,11 @@
|
||||
--- ./hw/xfree86/os-support/bsd/ppc_video.c.orig 2012-05-17 12:09:03.000000000 -0500
|
||||
+++ ./hw/xfree86/os-support/bsd/ppc_video.c 2014-01-18 14:36:42.000000000 -0600
|
||||
@@ -115,17 +115,19 @@
|
||||
Bool
|
||||
xf86EnableIO()
|
||||
{
|
||||
- int fd = xf86Info.consoleFd;
|
||||
+ int fd = open(DEV_MEM, O_RDWR);
|
||||
|
||||
xf86MsgVerb(X_WARNING, 3, "xf86EnableIO %d\n", fd);
|
||||
if (ioBase == MAP_FAILED) {
|
||||
ioBase = mmap(NULL, 0x10000, PROT_READ | PROT_WRITE, MAP_SHARED, fd,
|
||||
0xf2000000);
|
||||
xf86MsgVerb(X_INFO, 3, "xf86EnableIO: %08x\n", ioBase);
|
||||
+#if 0 /* Non-fatal */
|
||||
if (ioBase == MAP_FAILED) {
|
||||
xf86MsgVerb(X_WARNING, 3, "Can't map IO space!\n");
|
||||
return FALSE;
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
return TRUE;
|
||||
}
|
||||
@@ -135,7 +137,11 @@
|
||||
{
|
||||
|
||||
if (ioBase != MAP_FAILED) {
|
||||
|
|
Loading…
Reference in a new issue