add missing man page
fix entry in plist merge patches in files/ PR: 36890 Submitted by: Ports Fury
This commit is contained in:
parent
430526536a
commit
eecc33acb3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57485
4 changed files with 52 additions and 22 deletions
|
@ -25,11 +25,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= autogen.1 columns.1 getdefs.1
|
||||
MAN1= autogen.1 autoopts-config.1 columns.1 getdefs.1
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi -e 's|regcomp=no|regcomp=yes|g' ${WRKSRC}/configure
|
||||
@${PERL} -pi -e 's|values.h ||g' ${WRKSRC}/snprintfv/configure
|
||||
@${PERL} -pi -e 's|#include "proto.h"||g' ${WRKSRC}/getdefs/getdefs.h
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,16 +1,32 @@
|
|||
--- config/ltmain.sh.orig Mon Sep 3 18:24:41 2001
|
||||
+++ config/ltmain.sh Thu Dec 6 03:24:42 2001
|
||||
@@ -2408,6 +2408,9 @@
|
||||
--- config/ltmain.sh.orig Fri Feb 22 03:19:44 2002
|
||||
+++ config/ltmain.sh Tue Apr 2 02:40:21 2002
|
||||
@@ -1043,14 +1043,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
@@ -4210,10 +4210,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
|
|
|
@ -1,16 +1,32 @@
|
|||
--- snprintfv/config/ltmain.sh.orig Mon Sep 3 18:24:41 2001
|
||||
+++ snprintfv/config/ltmain.sh Thu Dec 6 03:25:35 2001
|
||||
@@ -2408,6 +2408,9 @@
|
||||
--- snprintfv/config/ltmain.sh.orig Fri Feb 22 03:19:44 2002
|
||||
+++ snprintfv/config/ltmain.sh Tue Apr 2 02:41:01 2002
|
||||
@@ -1043,14 +1043,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
@@ -4210,10 +4210,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
|
|
|
@ -22,7 +22,7 @@ share/aclocal/autoopts.m4
|
|||
share/autogen/aginfo.tpl
|
||||
share/autogen/agman1.tpl
|
||||
share/autogen/confmacs.tpl
|
||||
share/autogen/conftest.tpl
|
||||
share/autogen/conftest.tpl
|
||||
share/autogen/fsm-macro.tpl
|
||||
share/autogen/fsm-trans.tpl
|
||||
share/autogen/fsm.tpl
|
||||
|
|
Loading…
Reference in a new issue