Add x11/virtual.
VirtualGL is an open source program that redirects the 3D rendering commands from Unix and Linux OpenGL applications to 3D accelerator hardware in a dedicated server and displays the rendered output interactively to a thin client located elsewhere on the network, or locally. WWW: http://www.virtualgl.org PR: 192561 Submitted by: David Mackay
This commit is contained in:
parent
7d7ffc02e2
commit
eee3af20d2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=365843
9 changed files with 173 additions and 0 deletions
|
@ -294,6 +294,7 @@
|
|||
SUBDIR += vdesk
|
||||
SUBDIR += videoproto
|
||||
SUBDIR += viewres
|
||||
SUBDIR += virtualgl
|
||||
SUBDIR += wbar
|
||||
SUBDIR += wbarconf
|
||||
SUBDIR += wdm
|
||||
|
|
49
x11/virtualgl/Makefile
Normal file
49
x11/virtualgl/Makefile
Normal file
|
@ -0,0 +1,49 @@
|
|||
# Created by: David Mackay <davidjx8p@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= virtualgl
|
||||
PORTVERSION= 2.3.3
|
||||
CATEGORIES= x11 graphics
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
|
||||
DISTNAME= VirtualGL-${PORTVERSION}
|
||||
|
||||
MAINTAINER= davidjx8p@gmail.com
|
||||
COMMENT= Redirects commands from an OpenGL app to another X server
|
||||
|
||||
LIB_DEPENDS= libGLU.so:${PORTSDIR}/graphics/libGLU \
|
||||
libX11.so:${PORTSDIR}/x11/libX11 \
|
||||
libXext.so:${PORTSDIR}/x11/libXext \
|
||||
libXdamage.so:${PORTSDIR}/x11/libXdamage \
|
||||
libXfixes.so:${PORTSDIR}/x11/libXfixes \
|
||||
libX11-xcb.so:${PORTSDIR}/x11/libX11 \
|
||||
libxcb-glx.so:${PORTSDIR}/x11/libxcb \
|
||||
libxcb-dri2.so:${PORTSDIR}/x11/libxcb \
|
||||
libxcb.so:${PORTSDIR}/x11/libxcb \
|
||||
libXxf86vm.so:${PORTSDIR}/x11/libXxf86vm \
|
||||
libdrm.so:${PORTSDIR}/graphics/libdrm \
|
||||
libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
|
||||
libXau.so:${PORTSDIR}/x11/libXau \
|
||||
libXdmcp.so:${PORTSDIR}/x11/libXdmcp \
|
||||
libturbojpeg.so:${PORTSDIR}/graphics/libjpeg-turbo
|
||||
|
||||
# due to the libjpeg-turbo requirement
|
||||
ONLY_FOR_ARCHS= amd64 i386
|
||||
|
||||
CMAKE_INSTALL_PREFIX= ${LOCALBASE}/VirtualGL
|
||||
DOCSDIR= ${LOCALBASE}/VirtualGL/doc
|
||||
|
||||
USES= cmake
|
||||
CMAKE_ARGS= -DTJPEG_INCLUDE_DIR=${LOCALBASE}/include -DTJPEG_LIBRARY=${LOCALBASE}/lib/libturbojpeg.so
|
||||
USE_LDCONFIG= ${PREFIX}/VirtualGL/fakelib ${PREFIX}/VirtualGL/lib
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
PLIST_SUB+= I386=""
|
||||
PLIST_SUB+= AMD64="@comment "
|
||||
.else
|
||||
PLIST_SUB+= I386="@comment "
|
||||
PLIST_SUB+= AMD64=""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
x11/virtualgl/distinfo
Normal file
2
x11/virtualgl/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (VirtualGL-2.3.3.tar.gz) = 857fd5c51c64016a1687cbda62ca5dcdf7073181df86b57be010501b565e5d45
|
||||
SIZE (VirtualGL-2.3.3.tar.gz) = 2614988
|
11
x11/virtualgl/files/patch-common__CMakeLists.txt
Normal file
11
x11/virtualgl/files/patch-common__CMakeLists.txt
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./common/CMakeLists.txt.orig 2011-12-23 19:15:16.000000000 +0000
|
||||
+++ ./common/CMakeLists.txt 2014-08-10 17:43:04.000000000 +0100
|
||||
@@ -4,6 +4,8 @@
|
||||
|
||||
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
|
||||
|
||||
+ADD_DEFINITIONS(-fPIC)
|
||||
+
|
||||
add_library(rrframe STATIC rrframe.cpp)
|
||||
target_link_libraries(rrframe rrutil ${TJPEG_LIBRARY})
|
||||
|
34
x11/virtualgl/files/patch-server__CMakeLists.txt
Normal file
34
x11/virtualgl/files/patch-server__CMakeLists.txt
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- ./server/CMakeLists.txt.orig 2013-09-27 06:10:02.000000000 +0100
|
||||
+++ ./server/CMakeLists.txt 2014-08-10 17:43:04.000000000 +0100
|
||||
@@ -36,9 +36,9 @@
|
||||
set_source_files_properties(faker-sym.cpp PROPERTIES
|
||||
OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/faker-mapfile)
|
||||
set_target_properties(rrfaker PROPERTIES
|
||||
- LINK_FLAGS "-z defs ${MAPFLAG}${CMAKE_CURRENT_BINARY_DIR}/faker-mapfile")
|
||||
+ LINK_FLAGS "-Wl,-z,defs ${MAPFLAG}${CMAKE_CURRENT_BINARY_DIR}/faker-mapfile")
|
||||
else()
|
||||
- set_target_properties(rrfaker PROPERTIES LINK_FLAGS "-z defs")
|
||||
+ set_target_properties(rrfaker PROPERTIES LINK_FLAGS "-Wl,-z,defs")
|
||||
endif()
|
||||
target_link_libraries(rrfaker rrframe ${FBXFAKERLIB} rrsocket m
|
||||
${OPENGL_gl_LIBRARY} ${LIBDL})
|
||||
@@ -59,7 +59,7 @@
|
||||
install(TARGETS dlfaker DESTINATION ${VGL_LIBDIR})
|
||||
|
||||
add_library(gefaker SHARED gefaker.c)
|
||||
-set_target_properties(gefaker PROPERTIES LINK_FLAGS "-z defs")
|
||||
+set_target_properties(gefaker PROPERTIES LINK_FLAGS "-Wl,-z,defs")
|
||||
target_link_libraries(gefaker ${LIBDL})
|
||||
install(TARGETS gefaker DESTINATION ${VGL_LIBDIR})
|
||||
|
||||
@@ -119,8 +119,8 @@
|
||||
add_library(GLdlfakerut SHARED libGLdlfakerut.c)
|
||||
|
||||
add_executable(fakerut fakerut.cpp)
|
||||
-target_link_libraries(fakerut "-z now ${OPENGL_gl_LIBRARY}"
|
||||
- ${OPENGL_glu_LIBRARY} "-z now ${X11_X11_LIB}" ${LIBDL} pthread)
|
||||
+target_link_libraries(fakerut "-Wl,-z,now ${OPENGL_gl_LIBRARY}"
|
||||
+ ${OPENGL_glu_LIBRARY} "-Wl,-z,now ${X11_X11_LIB}" ${LIBDL} pthread)
|
||||
|
||||
add_library(vgltrans_test SHARED testplugin.cpp vgltransconn.cpp)
|
||||
if(VGL_USESSL AND CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
8
x11/virtualgl/files/patch-util__CMakeLists.txt
Normal file
8
x11/virtualgl/files/patch-util__CMakeLists.txt
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- ./util/CMakeLists.txt.orig 2014-08-10 17:44:08.000000000 +0100
|
||||
+++ ./util/CMakeLists.txt 2014-08-10 17:44:16.000000000 +0100
|
||||
@@ -1,3 +1,5 @@
|
||||
+ADD_DEFINITIONS(-fPIC)
|
||||
+
|
||||
add_library(rrutil STATIC rrlog.cpp genericQ.cpp bmp.c)
|
||||
if(UNIX)
|
||||
target_link_libraries(rrutil pthread)
|
11
x11/virtualgl/files/patch-util__rrsocket.cpp
Normal file
11
x11/virtualgl/files/patch-util__rrsocket.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./util/rrsocket.cpp.orig 2011-12-22 18:27:13.000000000 +0000
|
||||
+++ ./util/rrsocket.cpp 2014-08-10 17:43:04.000000000 +0100
|
||||
@@ -120,7 +120,7 @@
|
||||
#endif // USESSL
|
||||
|
||||
|
||||
-rrsocket::rrsocket(bool dossl=false)
|
||||
+rrsocket::rrsocket(bool dossl)
|
||||
#ifdef USESSL
|
||||
: _dossl(dossl)
|
||||
#endif
|
6
x11/virtualgl/pkg-descr
Normal file
6
x11/virtualgl/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
VirtualGL is an open source program that redirects the 3D rendering commands
|
||||
from Unix and Linux OpenGL applications to 3D accelerator hardware in a
|
||||
dedicated server and displays the rendered output interactively to a thin
|
||||
client located elsewhere on the network, or locally.
|
||||
|
||||
WWW: http://www.virtualgl.org
|
51
x11/virtualgl/pkg-plist
Normal file
51
x11/virtualgl/pkg-plist
Normal file
|
@ -0,0 +1,51 @@
|
|||
%%AMD64%%VirtualGL/bin/.vglrun.vars64
|
||||
%%I386%%VirtualGL/bin/.vglrun.vars32
|
||||
VirtualGL/bin/glreadtest
|
||||
VirtualGL/bin/glxinfo
|
||||
%%AMD64%%VirtualGL/bin/glxspheres64
|
||||
%%I386%%VirtualGL/bin/glxspheres
|
||||
VirtualGL/bin/nettest
|
||||
VirtualGL/bin/tcbench
|
||||
VirtualGL/bin/vglclient
|
||||
VirtualGL/bin/vglconfig
|
||||
VirtualGL/bin/vglconnect
|
||||
VirtualGL/bin/vglgenkey
|
||||
VirtualGL/bin/vgllogin
|
||||
VirtualGL/bin/vglrun
|
||||
VirtualGL/bin/vglserver_config
|
||||
%%DOCSDIR%%/411.gif
|
||||
%%DOCSDIR%%/422.gif
|
||||
%%DOCSDIR%%/444.gif
|
||||
%%DOCSDIR%%/ChangeLog.txt
|
||||
%%DOCSDIR%%/LGPL.txt
|
||||
%%DOCSDIR%%/LICENSE-FLTK.txt
|
||||
%%DOCSDIR%%/LICENSE-PuTTY.txt
|
||||
%%DOCSDIR%%/LICENSE-xauth.txt
|
||||
%%DOCSDIR%%/LICENSE.txt
|
||||
%%DOCSDIR%%/chromium-displaywall.png
|
||||
%%DOCSDIR%%/chromium-sortfirst.png
|
||||
%%DOCSDIR%%/chromium-sortlast.png
|
||||
%%DOCSDIR%%/configdialog.gif
|
||||
%%DOCSDIR%%/exceed1.png
|
||||
%%DOCSDIR%%/exceed2.png
|
||||
%%DOCSDIR%%/exceed3.png
|
||||
%%DOCSDIR%%/exceed6.png
|
||||
%%DOCSDIR%%/index.html
|
||||
%%DOCSDIR%%/somerights20.png
|
||||
%%DOCSDIR%%/sshtunnel.png
|
||||
%%DOCSDIR%%/vgltransport.png
|
||||
%%DOCSDIR%%/vgltransportservernetwork.png
|
||||
%%DOCSDIR%%/virtualgl.css
|
||||
%%DOCSDIR%%/x11transport.png
|
||||
VirtualGL/fakelib/libGL.so
|
||||
VirtualGL/include/rr.h
|
||||
VirtualGL/include/rrtransport.h
|
||||
VirtualGL/lib/libdlfaker.so
|
||||
VirtualGL/lib/libgefaker.so
|
||||
VirtualGL/lib/librrfaker.so
|
||||
@dirrmtry VirtualGL/bin
|
||||
@dirrmtry VirtualGL/doc
|
||||
@dirrmtry VirtualGL/fakelib
|
||||
@dirrmtry VirtualGL/include
|
||||
@dirrmtry VirtualGL/lib
|
||||
@dirrmtry VirtualGL
|
Loading…
Reference in a new issue