Upgrade libtorrent-rasterbar to 1.0.6 and qbittorrent -- to 3.2.3.
PR: 202118 (maybe)
This commit is contained in:
parent
65e2839aca
commit
eeecd54d9c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=394700
5 changed files with 20 additions and 31 deletions
|
@ -2,9 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libtorrent-rasterbar
|
||||
PORTVERSION= 1.0.4
|
||||
PORTVERSION= 1.0.6
|
||||
CATEGORIES?= net-p2p ipv6
|
||||
MASTER_SITES= SF/${PORTNAME:S/-rasterbar//}/${PORTNAME:S/-rasterbar//}/
|
||||
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT?= C++ library implementing a BitTorrent client
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (libtorrent-rasterbar-1.0.4.tar.gz) = 1f567823133b1493b9717afc8334eed691bf0ab452d4a2e0f644989f13ce9db0
|
||||
SIZE (libtorrent-rasterbar-1.0.4.tar.gz) = 3297242
|
||||
SHA256 (libtorrent-rasterbar-1.0.6.tar.gz) = c97de804b77f44591801631aca3869567671df2d3e2afe7f5453d8db2478fd61
|
||||
SIZE (libtorrent-rasterbar-1.0.6.tar.gz) = 3307491
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= qbittorrent
|
||||
PORTVERSION= 3.2.0
|
||||
PORTVERSION= 3.2.3
|
||||
DISTVERSIONPREFIX= release-
|
||||
CATEGORIES= net-p2p ipv6
|
||||
|
||||
|
@ -44,17 +44,17 @@ CONFIGURE_ENV+= zlib_CFLAGS=-I/usr/include
|
|||
CONFIGURE_ENV+= zlib_LIBS=-lz
|
||||
CONFIGURE_ARGS+= CXXFLAGS=-DBOOST_ASIO_DYN_LINK
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_OPENSSL= yes
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/bin/qmake-qt4,' \
|
||||
${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
do-configure:
|
||||
.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "no"
|
||||
@cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} \
|
||||
./configure --prefix=${PREFIX} ${CONFIGURE_ARGS}
|
||||
.else
|
||||
@cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} \
|
||||
./configure --prefix=${PREFIX} ${CONFIGURE_ARGS} --disable-gui
|
||||
.if !defined(SLAVE_PORT) || ${SLAVE_PORT:tl} != "no"
|
||||
CONFIGURE_ARGS+= --disable-gui
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (qBittorrent-qBittorrent-release-3.2.0_GH0.tar.xz) = 1ca59b532c36c1c4e5b87ddfb13789104ecfbf79cd09afc3b05a5871011d0a75
|
||||
SIZE (qBittorrent-qBittorrent-release-3.2.0_GH0.tar.xz) = 4467597
|
||||
SHA256 (qBittorrent-qBittorrent-release-3.2.3_GH0.tar.xz) = 816d611a0af50c469f52946c94b88c003f908ee031ee0e55a45273e4c64897c5
|
||||
SIZE (qBittorrent-qBittorrent-release-3.2.3_GH0.tar.xz) = 4601930
|
||||
|
|
|
@ -1,22 +1,11 @@
|
|||
--- configure.orig 2015-05-10 01:20:19 UTC
|
||||
+++ configure
|
||||
@@ -4263,7 +4263,7 @@ fi
|
||||
# Detect OS
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether OS is FreeBSD" >&5
|
||||
$as_echo_n "checking whether OS is FreeBSD... " >&6; }
|
||||
-if test "x$host_os" = "x*FreeBSD*"; then :
|
||||
+if expr "$host_os" : ".*freebsd.*" > /dev/null; then :
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
$as_echo "yes" >&6; }
|
||||
LIBS="-lexecinfo $LIBS"
|
||||
@@ -5808,8 +5808,8 @@ extract() {
|
||||
return 1
|
||||
--- configure 2015-08-02 13:18:04 UTC
|
||||
+++ configure 2015-08-19 00:00:14 -0400
|
||||
@@ -5809,7 +5809,7 @@
|
||||
fi
|
||||
|
||||
- # Convert " -" to "\n" if not between quotes
|
||||
- string=$(echo " $*" | $SED -e 's: -:\n:g' -e 's:"\(.*\)\n\(.*\)":\"\1 -\2":g' -e "s:'\(.*\)\n\(.*\)':\'\1 -\2':g")
|
||||
+ # Convert " -" to "\n" if not between quotes and remove possible leading white spaces
|
||||
+ string=$(echo " $*" | tr ' -' '\n' | $SED -e 's:"\(.*\)\n\(.*\)":\"\1 -\2":g' -e "s:'\(.*\)\n\(.*\)':\'\1 -\2':g" -e 's/^[:space:]*//')
|
||||
# Convert " -" to "\n" if not between quotes and remove possible leading white spaces
|
||||
- string=$(echo " $*" | $SED -e 's: -:\n:g' -e 's:"\(.*\)\n\(.*\)":\"\1 -\2":g' -e "s:'\(.*\)\n\(.*\)':\'\1 -\2':g" -e 's/^[:space:]*//')
|
||||
+ string=$(echo " $*" | tr ' -' '\n' | $SED -e 's: -:\n:g' -e 's:"\(.*\)\n\(.*\)":\"\1 -\2":g' -e "s:'\(.*\)\n\(.*\)':\'\1 -\2':g" -e 's/^[:space:]*//')
|
||||
SAVEIFS=$IFS
|
||||
IFS=$(printf "\n\b")
|
||||
for i in $string; do
|
||||
|
|
Loading…
Reference in a new issue