Stage support

This commit is contained in:
Antoine Brodin 2014-08-12 13:31:07 +00:00
parent f2981d087b
commit eeee16a3a9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364702
2 changed files with 10 additions and 12 deletions

View file

@ -13,7 +13,6 @@ COMMENT= Interface to record user sessions to utmp and wtmp files
USES= gmake tar:bzip2
USE_LDCONFIG= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 900004

View file

@ -1,31 +1,30 @@
--- Makefile.orig 2007-02-19 13:14:08.000000000 +0100
+++ Makefile 2007-07-17 23:42:11.000000000 +0200
@@ -30,18 +30,18 @@
--- Makefile.orig 2007-02-19 12:14:08 UTC
+++ Makefile
@@ -30,9 +30,9 @@ MAP = lib$(PROJECT).map
TARGETS = $(PROJECT) $(SHAREDLIB) $(STATICLIB)
INSTALL = install
-libdir = /usr/lib
-libexecdir = /usr/lib
-includedir = /usr/include
-DESTDIR =
+libdir = /lib
+libexecdir = /libexec
+includedir = /include
+DESTDIR = $(PREFIX)
+libdir = $(PREFIX)/lib
+libexecdir = $(PREFIX)/libexec
+includedir = $(PREFIX)/include
DESTDIR =
WARNINGS = -W -Wall -Waggregate-return -Wcast-align -Wconversion \
-Wdisabled-optimization -Wmissing-declarations \
@@ -40,8 +40,8 @@ WARNINGS = -W -Wall -Waggregate-return -
-Wmissing-format-attribute -Wmissing-noreturn \
-Wmissing-prototypes -Wpointer-arith -Wredundant-decls \
-Wshadow -Wstrict-prototypes -Wwrite-strings
-CPPFLAGS = -std=gnu99 $(WARNINGS) -DLIBEXECDIR=\"$(libexecdir)\"
-CFLAGS = $(RPM_OPT_FLAGS)
+CPPFLAGS = -std=gnu99 $(WARNINGS)
+CFLAGS+= -DLIBEXECDIR=\"$(PREFIX)$(libexecdir)\"
+CFLAGS+= -DLIBEXECDIR=\"$(libexecdir)\"
LDLIBS =
all: $(TARGETS)
@@ -63,15 +63,20 @@
@@ -63,15 +63,20 @@ $(STATICLIB): iface.o
iface.o: iface.c utempter.h