Fix-up yet another port, that broke, because it did not use the USE_TCL

knob, but uses itcl/itk... We will rely on USE_TK here now and explitly
set the wish-version in itk.sh in the post-patch.

Approved by:	portmgr	(pav)
Feature safe:	yes
This commit is contained in:
Mikhail Teterin 2010-06-25 17:06:03 +00:00
parent e402d91f8a
commit ef1f9231cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=256960
2 changed files with 6 additions and 18 deletions

View file

@ -18,15 +18,14 @@ COMMENT= Graphical mudclient with mapper
RUN_DEPENDS= ${LOCALBASE}/lib/iwidgets4.0.1/iwidgets.tcl:${PORTSDIR}/x11-toolkits/iwidgets
BUILD_DEPENDS= ${LOCALBASE}/lib/libitk.so:${PORTSDIR}/x11-toolkits/itk \
${LOCALBASE}/lib/libitcl.so.3:${PORTSDIR}/lang/itcl
${LOCALBASE}/lib/libitcl.so:${PORTSDIR}/lang/itcl
WRKSRC= ${WRKDIR}/smm/Install.unix
USE_GMAKE= yes
#USE_GMAKE= yes
USE_TK= 84+
EXTRACT_AFTER_ARGS+=|${TAR} -xpf - --exclude CVS
post-extract:
${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -rf
do-configure:
@echo "No configure needed"
post-patch:
${REINPLACE_CMD} -e 's,itkarray=.*,itkarray=${WISH},' ${WRKSRC}/itk.sh
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- itk.sh.orig Tue Jan 22 18:48:12 2002
+++ itk.sh Tue Jan 22 18:48:48 2002
@@ -4,7 +4,7 @@
#
# all possible itkwish executables
-itkarray="itkwish3.1 itkwish3 itkwish30 itkwish3.0 itkwish"
+itkarray="itkwish3.1 itkwish3 itkwish30 itkwish3.0 itkwish wish8.4 wish8.3 wish8.2"
set $itkarray
while [ ! -z "$1" ]; do