Finish removal of emulators/snes9x
This commit is contained in:
parent
0d35359389
commit
ef2fbd063d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=476314
6 changed files with 1 additions and 88 deletions
1
MOVED
1
MOVED
|
@ -10415,3 +10415,4 @@ security/py-python-social-auth||2018-08-02|Has expired: Upstream Deprecated
|
|||
www/py-django-social-auth||2018-08-02|Has expired: no support for new django
|
||||
audio/libmusicbrainz3|audio/libmusicbrainz5|2018-08-03|Has expired: Web Service 1.0 support ending 2018-08-01
|
||||
emulators/snes9x||2018-08-03|Removed: Please use emulators/snes9x-gtk instead of
|
||||
emulators/snes9express||2018-08-03|Please use emulators/snes9x-gtk instead
|
||||
|
|
|
@ -132,7 +132,6 @@
|
|||
SUBDIR += rubygem-fission
|
||||
SUBDIR += simh
|
||||
SUBDIR += skyeye
|
||||
SUBDIR += snes9express
|
||||
SUBDIR += snes9x-gtk
|
||||
SUBDIR += spim
|
||||
SUBDIR += stella
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
# Created by: Travis Poppe <tlp@liquidx.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= snes9express
|
||||
PORTVERSION= 1.43
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GTK interface for snes9x
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN_sparc64= does not compile on sparc64
|
||||
|
||||
RUN_DEPENDS= snes9x:emulators/snes9x
|
||||
|
||||
USES= gettext pkgconfig
|
||||
USE_GNOME= gtk20
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PORTDOCS= AUTHORS ChangeLog NEWS README
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
%%DATADIR%%/snes.s9xskin \
|
||||
%%DATADIR%%/snsp.s9xskin
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|(gzFile\*)||' \
|
||||
-e 's|\*fptr;|fptr;|' ${WRKSRC}/rom.cc
|
||||
@${REINPLACE_CMD} -e 's|<endian\.h>|<sys/endian.h>|' \
|
||||
${WRKSRC}/s9xskin.cc
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.s9xskin ${STAGEDIR}${DATADIR}
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (snes9express-1.43.tar.gz) = e54a811db4e4a8a261ffb8363ab7e81b4b46bec61678c2cb991ae632f6121b56
|
||||
SIZE (snes9express-1.43.tar.gz) = 398369
|
|
@ -1,35 +0,0 @@
|
|||
--- frend.cc.orig 2009-12-21 22:38:54 UTC
|
||||
+++ frend.cc
|
||||
@@ -379,7 +379,7 @@ void dimension<T>::input(std::istream& i
|
||||
i >> buf;
|
||||
unsigned int l = buf.size(), xpos = 0, ypos = 0;
|
||||
if(l < 3)
|
||||
- return i;
|
||||
+ return;
|
||||
if(buf[0]=='(')
|
||||
xpos++;
|
||||
if(buf[l-1]==',')
|
||||
@@ -400,13 +400,12 @@ void dimension<T>::input(std::istream& i
|
||||
const char*buf3 = buf.c_str();
|
||||
_x = strtol(&(buf[xpos]), NULL, 0);
|
||||
_y = strtol(&(buf[ypos]), NULL, 0);
|
||||
- return i;
|
||||
}
|
||||
|
||||
template <class T>
|
||||
void dimension<T>::print(std::ostream& o) const
|
||||
{
|
||||
- return o << "(" << _x << ", " << _y << ")";
|
||||
+ o << "(" << _x << ", " << _y << ")";
|
||||
}
|
||||
|
||||
/* ############################## Color ################################ */
|
||||
@@ -2527,7 +2526,7 @@ void Window::addMenu(const char*label, M
|
||||
{
|
||||
if(strcmp(items[i].label, "-"))
|
||||
{
|
||||
- if(items[i].icon > 0)
|
||||
+ if(items[i].icon)
|
||||
{
|
||||
menu_item = gtk_menu_item_new();
|
||||
GtkWidget *hbox = gtk_hbox_new(false, false);
|
|
@ -1,4 +0,0 @@
|
|||
Snes9express is a graphical interface for the X11 versions of snes9x,
|
||||
featuring an organized layout of common snes9x options.
|
||||
|
||||
WWW: http://www.linuxgames.com/snes9express/
|
Loading…
Reference in a new issue