Update to 1.2-beta2, based on the PR below with a few extra changes,
such as using a bz2 distfile and fetching the restricted file automatically. PR: ports/53761 Submitted by: Rob Evers <rob@debank.tv> Reviewed by: brian
This commit is contained in:
parent
b6d65070d7
commit
ef36a0ffab
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84612
6 changed files with 21 additions and 45 deletions
|
@ -6,41 +6,38 @@
|
|||
#
|
||||
|
||||
PORTNAME= pppoa
|
||||
PORTVERSION= 1.1b
|
||||
PORTVERSION= 1.2b2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://www.xsproject.org/speedtouch/files/ \
|
||||
http://www.alcatel.com/consumer/dsl/ \
|
||||
http://benoit.papillault.free.fr/speedtouch/
|
||||
MASTER_SITES= http://download.ethomson.com/download/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= speedtouch
|
||||
DISTFILES= ${SPEEDTOUCH}.tar.gz ${ALCATELDRIVER}
|
||||
DISTFILES= ${SPEEDTOUCH}.tar.bz2 ${ALCATELDRIVER}
|
||||
EXTRACT_ONLY= ${SPEEDTOUCH}.tar.bz2
|
||||
|
||||
MAINTAINER= brian@FreeBSD.org
|
||||
COMMENT= Run PPP over Alcatel's USB Speedtouch device
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
SPEEDTOUCH= speedtouch-1.1b
|
||||
SPEEDTOUCH= speedtouch-1.2-beta2
|
||||
ALCATELDRIVER= speedmgmt.tar.gz
|
||||
NO_CDROM= "http://www.alcatel.com/consumer/dsl/disclaimer_lx.htm"
|
||||
NO_PACKAGE= "http://www.alcatel.com/consumer/dsl/disclaimer_lx.htm"
|
||||
NO_CDROM= "http://www.speedtouchdsl.com/disclaimer_lx.htm"
|
||||
NO_PACKAGE= "http://www.speedtouchdsl.com/disclaimer_lx.htm"
|
||||
RESTRICTED_FILES= ${ALCATELDRIVER}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${SPEEDTOUCH}
|
||||
|
||||
MAN1= modem_run.1 pppoa2.1 pppoa3.1
|
||||
USE_BZIP2= yes
|
||||
|
||||
post-extract:
|
||||
${TAR} -zxf ${DISTDIR}/${ALCATELDRIVER} -C ${WRKSRC}
|
||||
|
||||
post-install:
|
||||
${INSTALL} -m 0755 -o root -g wheel -d ${LOCALBASE}/libdata
|
||||
${INSTALL_DATA} ${WRKSRC}/../mgmt/mgmt.o ${LOCALBASE}/libdata
|
||||
${INSTALL_DATA} ${WRKSRC}/mgmt/mgmt.o ${LOCALBASE}/libdata
|
||||
${INSTALL_DATA} ${FILESDIR}/quick-install \
|
||||
${LOCALBASE}/share/doc/speedtouch/.
|
||||
@${CAT} ${LOCALBASE}/share/doc/speedtouch/quick-install
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !exists(${DISTDIR}/${ALCATELDRIVER})
|
||||
IGNORE= You must manually fetch the Alcatel driver distribution (${DISTDIR}/${ALCATELDRIVER}) via http://www.speedtouchdsl.com/dvrreg_lx.htm (select binary release 1.3.3), place it in ${DISTDIR} and then run make again
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (speedtouch-1.1b.tar.gz) = 6335423ffec64478cb01ad33f2cc9c82
|
||||
MD5 (speedtouch-1.2-beta2.tar.bz2) = 450005ae68dc6b0323c54d4117460031
|
||||
MD5 (speedmgmt.tar.gz) = 102dc7a457c3942ee21dc834db68eac2
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- doc-bsd/ppp.conf.sample.orig Sat Jun 1 00:34:26 2002
|
||||
+++ doc-bsd/ppp.conf.sample Thu Jun 20 23:23:47 2002
|
||||
@@ -22,7 +22,7 @@
|
||||
adsl:
|
||||
set authname <login>
|
||||
set authkey <password>
|
||||
- set device !"pppoa2 -vpi <VPI> -vci <VCI> -v 1"
|
||||
+ set device !"/usr/local/sbin/pppoa2 -vpi <VPI> -vci <VCI> -v 1"
|
||||
accept chap
|
||||
set speed sync
|
||||
set timeout 0
|
|
@ -1,9 +1,8 @@
|
|||
|
||||
** IMPORTANT **
|
||||
|
||||
Please ensure that you have read the Alcatel license agreement at
|
||||
http://www.alcatel.com/consumer/dsl/dvrreg_lx.htm before running
|
||||
this software.
|
||||
Please ensure that you have read the license agreement at
|
||||
http://www.speedtouchdsl.com/dvrreg_lx.htm before running this software.
|
||||
|
||||
To activate this port, create a new profile in /etc/ppp/ppp.conf
|
||||
called ``adsl'' using /usr/local/share/doc/speedtouch/ppp.conf.sample
|
||||
|
|
|
@ -1,15 +1,5 @@
|
|||
Support for the Alcatel Speedtouch USB device. This driver is GPL except
|
||||
for the file that is downloaded from the Alcatel site. This file is
|
||||
restricted, specifically in terms of distribution. See
|
||||
http://www.alcatel.com/consumer/dsl/disclaimer_lx.htm.
|
||||
Unofficial support for Alcatel's Speedtouch USB devices. This driver is
|
||||
licensed under the GPL except for one restricted file:
|
||||
http://www.speedtouchdsl.com/disclaimer_lx.htm
|
||||
|
||||
|
||||
Thanks to
|
||||
|
||||
Benoit Papillault, who made the linux driver.
|
||||
Francois Rogler and Richard Tobin who ported the driver to *BSD
|
||||
Jorgen Lundman and Jon Barlow for their help and their time
|
||||
porting the driver to NetBSD.
|
||||
|
||||
WWW: http://www.xsproject.org/speedtouch/
|
||||
WWW: http://speedtouch.sourceforge.net/
|
||||
|
|
|
@ -9,6 +9,7 @@ share/doc/speedtouch/INSTALL
|
|||
share/doc/speedtouch/INSTALL-de
|
||||
share/doc/speedtouch/INSTALL-fr
|
||||
share/doc/speedtouch/INSTALL-it
|
||||
share/doc/speedtouch/INSTALL-nl
|
||||
share/doc/speedtouch/ppp.conf.sample
|
||||
share/doc/speedtouch/quick-install
|
||||
@exec cat %D/share/doc/speedtouch/quick-install
|
||||
|
|
Loading…
Reference in a new issue