Update py-vorbis to 1.3
This commit is contained in:
parent
acfb1c6640
commit
ef750e6b09
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=87516
5 changed files with 5 additions and 36 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= vorbis
|
||||
PORTVERSION= 1.0
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.andrewchatham.com/pyogg/download/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -15,8 +15,8 @@ DISTNAME= pyvorbis-${PORTVERSION}
|
|||
MAINTAINER= nbm@FreeBSD.org
|
||||
COMMENT= Object-oriented Python bindings for the vorbis library
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_oggmodule.so:${PORTSDIR}/audio/py-ogg
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_oggmodule.so:${PORTSDIR}/audio/py-ogg
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_ogg.so:${PORTSDIR}/audio/py-ogg
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_ogg.so:${PORTSDIR}/audio/py-ogg
|
||||
LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis
|
||||
|
||||
USE_PYTHON= yes
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (pyvorbis-1.0.tar.gz) = 158e38785543f2d945e20f67f77299b9
|
||||
MD5 (pyvorbis-1.3.tar.gz) = 3ddd0dc996b57827c324910cc899d40b
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- src/pyvorbisfile.c.orig Mon Sep 23 16:35:18 2002
|
||||
+++ src/pyvorbisfile.c Mon Sep 23 16:37:20 2002
|
||||
@@ -1,5 +1,17 @@
|
||||
#include <stdio.h>
|
||||
+
|
||||
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
+#if (defined(BSD))
|
||||
+#include <machine/endian.h>
|
||||
+#define __BYTE_ORDER BYTE_ORDER
|
||||
+#define __BIG_ENDIAN BIG_ENDIAN
|
||||
+#else
|
||||
#include <endian.h>
|
||||
+#endif
|
||||
+
|
||||
#include <assert.h>
|
||||
|
||||
#include "general.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- setup.py.orig Mon Sep 23 16:29:24 2002
|
||||
+++ setup.py Mon Sep 23 16:29:34 2002
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
def get_setup():
|
||||
data = {}
|
||||
- r = re.compile(r'(\S+)\s*?=\s*?(.+)')
|
||||
+ r = re.compile(r'(\S+)\s*?=\s*(.+)')
|
||||
|
||||
if not os.path.isfile('Setup'):
|
||||
print "No 'Setup' file. Perhaps you need to run the configure script."
|
|
@ -1 +1 @@
|
|||
lib/%%PYTHON_VERSION%%/site-packages/ogg/vorbismodule.so
|
||||
lib/%%PYTHON_VERSION%%/site-packages/ogg/vorbis.so
|
||||
|
|
Loading…
Reference in a new issue