* Upgrade to 4.0.3.

* Remove USE_REINPLACE (1)
* Fix Build on 4.x. (1)

PR:		ports/95986 (1)
Submitted by:	Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com> (1)
This commit is contained in:
Oliver Braun 2006-04-30 16:30:08 +00:00
parent fd092d0ec0
commit ef8c94bbd0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=160923
4 changed files with 31 additions and 6 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= multitail
PORTVERSION= 3.8.10
PORTVERSION= 4.0.3
CATEGORIES= sysutils
MASTER_SITES= http://www.vanheusden.com/multitail/
EXTRACT_SUFX= .tgz
@ -14,11 +14,16 @@ EXTRACT_SUFX= .tgz
MAINTAINER= obraun@FreeBSD.org
COMMENT= Tail multiple files on console with ncurses
USE_REINPLACE= yes
USE_GMAKE= yes
MAN1= multitail.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
EXTRA_PATCHES= ${FILESDIR}/e-patch-config.c ${FILESDIR}/e-patch-cv.c
.endif
post-patch:
@${REINPLACE_CMD} -e '/^CC/d ; s/^CFLAGS=/CFLAGS+=/' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,/etc/multitail.conf,${PREFIX}/etc/multitail.conf,' \
@ -34,4 +39,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (multitail-3.8.10.tgz) = 1b4cb6288298fe61c4c5147b50bfd48d
SHA256 (multitail-3.8.10.tgz) = f99b77805a96bee639f1a9b39704156b9d1bf75feb9cc32c3218853dee817f67
SIZE (multitail-3.8.10.tgz) = 82860
MD5 (multitail-4.0.3.tgz) = b6017e19aa7cf7e2b4fddd75a596a1a7
SHA256 (multitail-4.0.3.tgz) = 6d74ba52b96f68007fb9598ca9d13ca8e02ab4deec413213243ce2e30698d50c
SIZE (multitail-4.0.3.tgz) = 123820

View file

@ -0,0 +1,10 @@
--- config.c.orig Tue Apr 18 15:54:34 2006
+++ config.c Sun Apr 30 18:19:00 2006
@@ -40,6 +40,7 @@
long long int kb_str_to_value(char *field, char *str)
{
char *mult;
+ #define atoll(a) strtoll((a), (char **)NULL, 10)
long long int bytes = atoll(str);
if (bytes < -1)
error_exit("%s: value cannot be < -1\n", field);

View file

@ -0,0 +1,10 @@
--- cv.c.orig Tue Apr 18 15:54:34 2006
+++ cv.c Sun Apr 30 18:20:44 2006
@@ -81,6 +81,7 @@
case CONVTYPE_DECTOHEX:
{
+ #define atoll(a) strtoll((a), (char **)NULL, 10)
long long int result = atoll(what);
char result_str[128];