Don't spawn a process to run perl, but install perl arch-dependent files

in a standard directory.

PR:		ports/70091
Submitted by:	myself
Approved by:	maintainer.
This commit is contained in:
Thierry Thomas 2004-08-08 22:13:17 +00:00
parent 1882e9f8bb
commit ef98ae7365
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115690
2 changed files with 15 additions and 10 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= wml
PORTVERSION= 2.0.9
PORTREVISION= 1
CATEGORIES= www lang
MASTER_SITES= http://thewml.org/distrib/ \
ftp://thewml.org/distrib/
@ -19,11 +20,12 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-perl=${PERL5}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
PERL_ARCH="${PERL_ARCH}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL_VER= 15
LIBTOOLFILES= wml_backend/p2_mp4h/configure
PLIST_SUB+= ARCH=${LOCAL_PERL_ARCH}
PLIST_SUB+= ARCH=${PERL_ARCH}
CAT1= wml_aux_txt2html.1 wml_aux_tidy.1 wml_p4_gm4.1
@ -58,12 +60,6 @@ MAN7= wml_intro.7 wml_macros.7 wml_tutorial.7 wml_faq.7 wml_tags.7
.include <bsd.port.pre.mk>
.if exists(${PERL5})
LOCAL_PERL_ARCH!= ${PERL5} -MConfig -e 'print "$$Config{archname}"'
.else
LOCAL_PERL_ARCH= ${ARCH}-freebsd
.endif
.if ${ARCH} == "amd64"
BROKEN= "Build fails on amd64 (needs to build shared libraries with -fPIC)"
.endif

View file

@ -1,5 +1,5 @@
--- configure.orig Sat May 8 01:58:52 2004
+++ configure Sat May 8 01:58:59 2004
--- configure.orig Fri Oct 18 23:44:21 2002
+++ configure Thu Aug 5 23:40:57 2004
@@ -1170,7 +1170,7 @@
esac
case " $ac_configure_args " in
@ -9,3 +9,12 @@
esac
fi
done
@@ -2740,7 +2740,7 @@
dummy:
@echo INSTALLPRIVLIB=`echo $(INSTALLPRIVLIB) | $(abs2prefix)`
- @echo INSTALLARCHLIB=`echo $(INSTALLARCHLIB) | $(abs2prefix)`
+ @echo INSTALLARCHLIB=`echo $(INSTALLPRIVLIB) | $(abs2prefix)`/$(PERL_ARCH)
};
}
EOT