- Support CFLAGS properly

- Remove unnecessary USE_BISON
- Utilize NOPORTDOCS

PR:		36892
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2002-04-09 07:40:18 +00:00
parent 2495a33ff5
commit ef999b1dc0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57487
6 changed files with 54 additions and 48 deletions

View file

@ -8,6 +8,7 @@
PORTNAME= gsubedit
PORTVERSION= 0.3
PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,14 +16,28 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_X_PREFIX= yes
USE_BISON= yes
USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gnome
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
@${PERL} -pi -e "s,Bison ,Bison,g" ${WRKSRC}/configure
@${PERL} -pi -e "s,doc/,share/doc/,g" ${WRKSRC}/Makefile.in
@${PERL} -pi -e 's|Bison |Bison|g ; \
s|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|share/pixmaps|share/gnome/pixmaps|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
's|^gsubeditdoc|#gsubeditdoc|g ; \
s|-g -O2|| ; \
s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|'
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog INSTALL README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- pixmaps/Makefile.in.orig Tue Mar 12 01:34:16 2002
+++ pixmaps/Makefile.in Tue Mar 12 01:36:23 2002
@@ -119,7 +119,7 @@
cflags_set = @cflags_set@
cxxflags_set = @cxxflags_set@
-gsubedit_pixmapsdir = $(prefix)/@NO_PREFIX_PACKAGE_PIXMAPS_DIR@
+gsubedit_pixmapsdir = $(prefix)/share/gnome/pixmaps/gsubedit
gsubedit_pixmaps_DATA = \
gsubedit_icon.png

View file

@ -1,13 +1,12 @@
bin/gsubedit
share/doc/gsubedit/ABOUT-NLS
share/doc/gsubedit/AUTHORS
share/doc/gsubedit/COPYING
share/doc/gsubedit/ChangeLog
share/doc/gsubedit/INSTALL
share/doc/gsubedit/README
share/doc/gsubedit/TODO
%%PORTDOCS%%share/doc/gsubedit/AUTHORS
%%PORTDOCS%%share/doc/gsubedit/ChangeLog
%%PORTDOCS%%share/doc/gsubedit/INSTALL
%%PORTDOCS%%share/doc/gsubedit/README
%%PORTDOCS%%share/doc/gsubedit/TODO
share/gnome/apps/Applications/gsubedit.desktop
share/gnome/help/gsubedit/C/index.html
share/gnome/help/gsubedit/C/topic.dat
share/gnome/locale/sv/LC_MESSAGES/gsubedit.mo
share/gnome/pixmaps/gsubedit/gsubedit_icon.png
share/locale/sv/LC_MESSAGES/gsubedit.mo
%%PORTDOCS%%@dirrm share/doc/gsubedit

View file

@ -8,6 +8,7 @@
PORTNAME= gsubedit
PORTVERSION= 0.3
PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,14 +16,28 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_X_PREFIX= yes
USE_BISON= yes
USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gnome
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
@${PERL} -pi -e "s,Bison ,Bison,g" ${WRKSRC}/configure
@${PERL} -pi -e "s,doc/,share/doc/,g" ${WRKSRC}/Makefile.in
@${PERL} -pi -e 's|Bison |Bison|g ; \
s|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|share/pixmaps|share/gnome/pixmaps|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
's|^gsubeditdoc|#gsubeditdoc|g ; \
s|-g -O2|| ; \
s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|'
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog INSTALL README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- pixmaps/Makefile.in.orig Tue Mar 12 01:34:16 2002
+++ pixmaps/Makefile.in Tue Mar 12 01:36:23 2002
@@ -119,7 +119,7 @@
cflags_set = @cflags_set@
cxxflags_set = @cxxflags_set@
-gsubedit_pixmapsdir = $(prefix)/@NO_PREFIX_PACKAGE_PIXMAPS_DIR@
+gsubedit_pixmapsdir = $(prefix)/share/gnome/pixmaps/gsubedit
gsubedit_pixmaps_DATA = \
gsubedit_icon.png

View file

@ -1,13 +1,12 @@
bin/gsubedit
share/doc/gsubedit/ABOUT-NLS
share/doc/gsubedit/AUTHORS
share/doc/gsubedit/COPYING
share/doc/gsubedit/ChangeLog
share/doc/gsubedit/INSTALL
share/doc/gsubedit/README
share/doc/gsubedit/TODO
%%PORTDOCS%%share/doc/gsubedit/AUTHORS
%%PORTDOCS%%share/doc/gsubedit/ChangeLog
%%PORTDOCS%%share/doc/gsubedit/INSTALL
%%PORTDOCS%%share/doc/gsubedit/README
%%PORTDOCS%%share/doc/gsubedit/TODO
share/gnome/apps/Applications/gsubedit.desktop
share/gnome/help/gsubedit/C/index.html
share/gnome/help/gsubedit/C/topic.dat
share/gnome/locale/sv/LC_MESSAGES/gsubedit.mo
share/gnome/pixmaps/gsubedit/gsubedit_icon.png
share/locale/sv/LC_MESSAGES/gsubedit.mo
%%PORTDOCS%%@dirrm share/doc/gsubedit