suitesparse-slip_lu: new port for the module SLIP_LU of SuiteSparse
This commit is contained in:
parent
1273983112
commit
ef9eb0a7f8
4 changed files with 53 additions and 0 deletions
25
math/suitesparse-slip_lu/Makefile
Normal file
25
math/suitesparse-slip_lu/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# Created by: Thierry Thomas (<thierry@pompo.net>)
|
||||
|
||||
PORTNAME= SLIP_LU
|
||||
PORTVERSION= 1.0.2
|
||||
CATEGORIES= math
|
||||
|
||||
COMMENT= Sparse Left-looking Integer-Preserving LU Factorization
|
||||
|
||||
LICENSE= GPLv2+ LGPL3+
|
||||
LICENSE_COMB= dual
|
||||
LICENSE_FILE= ${BUILD_WRKSRC}/License/license.txt
|
||||
|
||||
LIB_DEPENDS= libgmp.so:math/gmp \
|
||||
libmpfr.so:math/mpfr \
|
||||
libamd.so:math/suitesparse-amd \
|
||||
libcolamd.so:math/suitesparse-colamd
|
||||
|
||||
USES= localbase:ldflags
|
||||
OMP_NEEDED= yes
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
|
||||
.include <bsd.port.post.mk>
|
11
math/suitesparse-slip_lu/files/patch-SLIP__LU_Makefile
Normal file
11
math/suitesparse-slip_lu/files/patch-SLIP__LU_Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- SLIP_LU/Makefile.orig 2021-05-17 01:04:52 UTC
|
||||
+++ SLIP_LU/Makefile
|
||||
@@ -25,7 +25,7 @@ C:
|
||||
( cd Demo ; $(MAKE) )
|
||||
|
||||
# compile the dynamic library, and then run the demos and statement coverage
|
||||
-all: C cov
|
||||
+all: C
|
||||
|
||||
# compile the dynamic library only
|
||||
library:
|
11
math/suitesparse-slip_lu/pkg-descr
Normal file
11
math/suitesparse-slip_lu/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
This port installs the module SLIP_LU of SuiteSparse.
|
||||
|
||||
SLIP_LU is software package used to solve a sparse systems of linear equations
|
||||
exactly using the Sparse Left-looking Integer-Preserving LU factorization.
|
||||
|
||||
SLIPLU Purpose: Exactly solve a sparse system of linear equations using a given
|
||||
input matrix and right hand side vector file. This code can output the final
|
||||
solution to a user specified output file in either double precision or full
|
||||
precision rational numbers.
|
||||
|
||||
WWW: http://faculty.cse.tamu.edu/davis/suitesparse.html
|
6
math/suitesparse-slip_lu/pkg-plist
Normal file
6
math/suitesparse-slip_lu/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
include/suitesparse/SLIP_LU.h
|
||||
lib/libsliplu.so
|
||||
lib/libsliplu.so.1
|
||||
lib/libsliplu.so.1.0.2
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SLIP_LU_README.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SLIP_LU_UserGuide.pdf
|
Loading…
Reference in a new issue