x11-toolkits/scintilla & editors/scite: Update to 4.3.0
PR: 243644 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
This commit is contained in:
parent
a1eda1aeff
commit
efaf59e4ad
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=528056
6 changed files with 65 additions and 57 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= scite
|
||||
DISTVERSION= 4.2.3
|
||||
DISTVERSION= 4.3.0
|
||||
CATEGORIES= editors gnome
|
||||
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
|
||||
|
@ -25,12 +25,19 @@ OPTIONS_DEFINE= DOCS
|
|||
PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
|
||||
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk20
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk30
|
||||
MAKEFILE= makefile
|
||||
MAKE_ARGS= GTK3=1
|
||||
|
||||
PORTDATA= *.properties
|
||||
PORTDOCS= *.html *.jpg *.png
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${CHOSEN_COMPILER_TYPE} == clang
|
||||
MAKE_ARGS+= CLANG=1
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's| -Os||g' ${WRKSRC}/makefile
|
||||
@${REINPLACE_CMD} -e 's|$$(SciteDefaultHome)|${DOCSDIR}|' \
|
||||
|
@ -44,4 +51,4 @@ do-install:
|
|||
(cd ${WRKSRC}/../src && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
|
||||
(cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1578437945
|
||||
SHA256 (scite423.tgz) = 7bd651008afe7fb7e2d0cbd28fd8f75803c64b5558f56aa68b035b3f994900b6
|
||||
SIZE (scite423.tgz) = 2644248
|
||||
TIMESTAMP = 1579657322
|
||||
SHA256 (scite430.tgz) = 6401a2c25f8c2a1e0c06279e2f022722374a6aaf37d0b0acebce1a103fafe589
|
||||
SIZE (scite430.tgz) = 2705289
|
||||
|
|
|
@ -1,33 +1,31 @@
|
|||
--- gtk/makefile.orig 2019-06-07 22:35:09 UTC
|
||||
--- gtk/makefile.orig 2020-01-02 00:45:08 UTC
|
||||
+++ gtk/makefile
|
||||
@@ -12,8 +12,8 @@ ifdef CLANG
|
||||
@@ -18,8 +18,6 @@ ifdef CLANG
|
||||
# thread also need to create Position Independent Executable -> search online documentation
|
||||
SANITIZE = address
|
||||
#SANITIZE = undefined
|
||||
-CXX = clang++ -fsanitize=$(SANITIZE) -Wno-deprecated-register
|
||||
-CC = clang -fsanitize=$(SANITIZE)
|
||||
+CXX = $(CXX) -fsanitize=$(SANITIZE) -Wno-deprecated-register
|
||||
+CC = $(CC) -fsanitize=$(SANITIZE)
|
||||
CCWARNINGS = -Wno-empty-body -Wno-string-plus-int
|
||||
else
|
||||
MISLEADING=-Wno-misleading-indentation
|
||||
@@ -29,7 +29,7 @@ endif
|
||||
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
|
||||
CONFIGLIB:=$(shell pkg-config --libs $(GTKVERSION) gthread-2.0 gmodule-no-export-2.0)
|
||||
CONFIGTHREADS:=
|
||||
-gnomeprefix:=$(shell pkg-config --variable=prefix $(GTKVERSION) 2>/dev/null)
|
||||
-CXX = clang++
|
||||
-CC = clang
|
||||
BASE_FLAGS += -fsanitize=$(SANITIZE)
|
||||
WARNINGS += -Wno-deprecated-register
|
||||
WARNINGS += -Wno-empty-body
|
||||
@@ -33,7 +31,7 @@ GTK_VERSION = $(if $(GTK3),gtk+-3.0,gtk+-2.0)
|
||||
# For the Gnome desktop stuff to work, prefix must point to where Gnome thinks it is.
|
||||
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTK_VERSION))
|
||||
CONFIGLIB:=$(shell pkg-config --libs $(GTK_VERSION) gthread-2.0 gmodule-no-export-2.0)
|
||||
-gnomeprefix:=$(shell pkg-config --variable=prefix $(GTK_VERSION) 2>/dev/null)
|
||||
+gnomeprefix:=$(PREFIX)
|
||||
ifndef prefix
|
||||
ifdef gnomeprefix
|
||||
prefix=$(gnomeprefix)
|
||||
@@ -125,8 +125,9 @@ FilePath.o EditorConfig.o SciTEBase.o FileWorker.o Coo
|
||||
ExportHTML.o ExportPDF.o ExportRTF.o ExportTEX.o ExportXML.o \
|
||||
MatchMarker.o StringHelpers.o \
|
||||
PropSetFile.o MultiplexExtension.o DirectorExtension.o SciTEProps.o StyleDefinition.o StyleWriter.o Utf8_16.o \
|
||||
- JobQueue.o GTKMutex.o IFaceTable.o $(COMPLIB) $(LUA_OBJS)
|
||||
- $(CXX) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script $(srcdir)/lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) $(LDLIBS) -lm -lstdc++
|
||||
+ JobQueue.o GTKMutex.o IFaceTable.o $(LUA_OBJS)
|
||||
+ $(CXX) -rdynamic -Wl,--version-script $(srcdir)/lua.vers -DGTK $(CXXFLAGS) $^ -o $@ \
|
||||
@@ -141,8 +139,9 @@ SRC_OBJS = \
|
||||
StyleWriter.o \
|
||||
Utf8_16.o
|
||||
|
||||
-$(PROG): SciTEGTK.o GUIGTK.o Widget.o GTKMutex.o DirectorExtension.o $(SRC_OBJS) $(COMPLIB) $(LUA_OBJS)
|
||||
- $(CXX) $(BASE_FLAGS) -rdynamic -Wl,--as-needed -Wl,--version-script $(srcdir)/lua.vers $^ -o $@ $(CONFIGLIB) $(LIBS) $(LDLIBS)
|
||||
+$(PROG): SciTEGTK.o GUIGTK.o Widget.o GTKMutex.o DirectorExtension.o $(SRC_OBJS) $(LUA_OBJS)
|
||||
+ $(CXX) $(BASE_FLAGS) -rdynamic -Wl,--version-script $(srcdir)/lua.vers $(CXXFLAGS) $^ -o $@ \
|
||||
+ $(LDFLAGS) -lscintilla -lscintilla_lexers -Wl,--as-needed $(CONFIGLIB)
|
||||
|
||||
# Automatically generate header dependencies with "make deps"
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= scintilla
|
||||
DISTVERSION= 4.2.3
|
||||
DISTVERSION= 4.3.0
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
|
||||
DISTNAME= scite${PORTVERSION:S/.//g}
|
||||
|
@ -20,18 +20,22 @@ USES= compiler:c++17-lang gmake gnome iconv pkgconfig tar:tgz
|
|||
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
|
||||
MAKEFILE= makefile
|
||||
USE_LDCONFIG= yes
|
||||
USE_GNOME= gtk20
|
||||
USE_GNOME= gtk30
|
||||
MAKE_ENV= LDFLAGS="${LDFLAGS}"
|
||||
CFLAGS+= -DPIC ${PICFLAG}
|
||||
|
||||
MAJOR= 2
|
||||
MAJOR= 3
|
||||
AGE= 0
|
||||
REVISION= 0
|
||||
MAKE_ARGS= MAJOR="${MAJOR}" AGE="${AGE}" REVISION="${REVISION}"
|
||||
MAKE_ARGS= MAJOR="${MAJOR}" AGE="${AGE}" REVISION="${REVISION}" GTK3=1
|
||||
PLIST_SUB= MAJOR="${MAJOR}" AGE="${AGE}" REVISION="${REVISION}"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${CHOSEN_COMPILER_TYPE} == clang
|
||||
MAKE_ARGS+= CLANG=1
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "sparc64"
|
||||
PICFLAG?= -fPIC
|
||||
.else
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1578437926
|
||||
SHA256 (scite423.tgz) = 7bd651008afe7fb7e2d0cbd28fd8f75803c64b5558f56aa68b035b3f994900b6
|
||||
SIZE (scite423.tgz) = 2644248
|
||||
TIMESTAMP = 1579621912
|
||||
SHA256 (scite430.tgz) = 6401a2c25f8c2a1e0c06279e2f022722374a6aaf37d0b0acebce1a103fafe589
|
||||
SIZE (scite430.tgz) = 2705289
|
||||
|
|
|
@ -1,49 +1,48 @@
|
|||
--- makefile.orig 2019-04-16 20:34:45 UTC
|
||||
--- makefile.orig 2020-01-02 00:45:04 UTC
|
||||
+++ makefile
|
||||
@@ -11,9 +11,7 @@
|
||||
srcdir ?= .
|
||||
@@ -16,8 +16,6 @@ basedir = $(srcdir)/..
|
||||
|
||||
WARNINGS = -Wpedantic -Wall
|
||||
ifdef CLANG
|
||||
-CXX = clang++
|
||||
CXXWARNFLAGS = -Wall -pedantic -Wno-deprecated-register -Wno-missing-braces
|
||||
-CC = clang
|
||||
# Can choose aspect to sanitize: address and undefined can simply change SANITIZE but for
|
||||
# thread also need to create Position Independent Executable -> search online documentation
|
||||
SANITIZE = address
|
||||
@@ -49,7 +47,12 @@ DEL = del /q
|
||||
COMPLIB=$(srcdir)\..\bin\scintilla.a
|
||||
WARNINGS += -Wno-deprecated-register
|
||||
ifdef windir
|
||||
# Turn off some warnings that occur when Clang is being used on Windows where it
|
||||
@@ -58,7 +56,12 @@ DEL = del /q
|
||||
else
|
||||
DEL = rm -f
|
||||
-COMPLIB=$(srcdir)/../bin/scintilla.a
|
||||
endif
|
||||
-COMPLIB=$(basedir)/bin/scintilla.a
|
||||
+COMPLIB_NAME=libscintilla.so
|
||||
+COMPLIB_SONAME=$(COMPLIB_NAME).$(MAJOR)
|
||||
+COMPLIB=$(COMPLIB_SONAME).$(AGE).$(REVISION)
|
||||
+LEXRLIB_NAME=libscintilla_lexers.so
|
||||
+LEXRLIB_SONAME=$(LEXRLIB_NAME).$(MAJOR)
|
||||
+LEXRLIB=$(LEXRLIB_SONAME).$(AGE).$(REVISION)
|
||||
endif
|
||||
|
||||
vpath %.h $(srcdir) $(srcdir)/../src $(srcdir)/../include $(srcdir)/../lexlib
|
||||
@@ -87,7 +90,7 @@ CXXTFLAGS:=--std=gnu++17 $(CTFLAGS) $(REFLAGS)
|
||||
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
|
||||
vpath %.h $(srcdir) $(basedir)/src $(basedir)/include $(basedir)/lexlib
|
||||
vpath %.c $(srcdir)
|
||||
@@ -81,7 +84,7 @@ CXX_ALL_FLAGS =$(DEFINES) $(INCLUDES) $(CXX_BASE_FLAGS
|
||||
CONFIG_FLAGS:=$(shell pkg-config --cflags $(GTK_VERSION))
|
||||
MARSHALLER=scintilla-marshal.o
|
||||
|
||||
-all: $(COMPLIB)
|
||||
+all: $(COMPLIB) $(LEXRLIB)
|
||||
|
||||
clean:
|
||||
$(DEL) *.o $(COMPLIB) *.plist
|
||||
@@ -119,9 +122,11 @@ $(COMPLIB): Accessor.o CharacterSet.o DefaultLexer.o L
|
||||
PropSetSimple.o PlatGTK.o \
|
||||
KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o ScintillaGTKAccessible.o CellBuffer.o CharacterCategory.o ViewStyle.o \
|
||||
RESearch.o RunStyles.o Selection.o Style.o Indicator.o AutoComplete.o UniConversion.o UniqueString.o XPM.o \
|
||||
- $(MARSHALLER) $(LEXOBJS)
|
||||
$(DEL) *.o $(call normalize,$(COMPLIB)) *.plist
|
||||
@@ -158,9 +161,11 @@ GTK_OBJS = \
|
||||
ScintillaGTK.o \
|
||||
ScintillaGTKAccessible.o
|
||||
|
||||
-$(COMPLIB): $(SRC_OBJS) $(LEXLIB_OBJS) $(GTK_OBJS) $(MARSHALLER) $(LEX_OBJS)
|
||||
- $(AR) $(ARFLAGS) $@ $^
|
||||
- $(RANLIB) $@
|
||||
+ $(MARSHALLER)
|
||||
+$(COMPLIB): $(SRC_OBJS) $(GTK_OBJS) $(MARSHALLER)
|
||||
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(COMPLIB_SONAME) -o $@ $^ -Wl,--as-needed $(CONFIGLIBS)
|
||||
+
|
||||
+$(LEXRLIB): $(LEXOBJS)
|
||||
+$(LEXRLIB): $(LEXLIB_OBJS) $(LEX_OBJS)
|
||||
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(LEXRLIB_SONAME) -o $@ $^ -Wl,--as-needed $(CONFIGLIBS)
|
||||
|
||||
# Automatically generate header dependencies with "make deps"
|
||||
|
|
Loading…
Reference in a new issue