net/keama: Kea migration assistant

This commit is contained in:
Dirk Meyer 2022-11-09 19:20:40 +01:00
parent f664b99381
commit efe0b339c9
10 changed files with 110 additions and 0 deletions

View file

@ -307,6 +307,7 @@
SUBDIR += kdenetwork
SUBDIR += kdenetwork-filesharing
SUBDIR += kea
SUBDIR += keama
SUBDIR += keycloak
SUBDIR += kf5-kcalendarcore
SUBDIR += kf5-kcontacts

43
net/keama/Makefile Normal file
View file

@ -0,0 +1,43 @@
PORTNAME= keama
ISCVERSION= 4.4.3-P1
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
CATEGORIES= net
MASTER_SITES= ISC/${PORTNAME}/${PORTVERSION:S/P/-P/g} \
ZI
DISTNAME= dhcp-${ISCVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Kea migration assistant
WWW= https://gitlab.isc.org/isc-projects/dhcp/-/wikis/kea-migration-assistant
LICENSE= MPL20
USES= cpe gmake
CPE_VENDOR= isc
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--localstatedir=/var
CPPFLAGS+= -D_PATH_DHCPD_CONF='\"${PREFIX}/etc/dhcpd.conf\"'
CFLAGS+= -fPIC
BUILD_WRKSRC= ${WRKSRC}/keama
MAN_COMPRESSED= no
SCRIPTS_ENV+= PKG_PREFIX=${PREFIX}
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
PLIST_FILES= sbin/keama man/man8/keama.8.gz \
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.md \
%%PORTDOCS%%%%DOCSDIR%%/README.md \
do-install:
${SETENV} DESTDIR=${STAGEDIR} ${MAKE} -C ${WRKSRC}/keama install
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}/${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/keama/*.md ${STAGEDIR}/${DOCSDIR}/
.include <bsd.port.mk>

3
net/keama/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1664982364
SHA256 (dhcp-4.4.3-P1.tar.gz) = 0ac416bb55997ca8632174fd10737fd61cdb8dba2752160a335775bc21dc73c7
SIZE (dhcp-4.4.3-P1.tar.gz) = 10081055

View file

@ -0,0 +1,10 @@
--- keama/confparse.c.orig 2022-09-28 14:39:15 UTC
+++ keama/confparse.c
@@ -26,6 +26,7 @@
#include "keama.h"
#include <sys/errno.h>
+#include <sys/socket.h>
#include <arpa/inet.h>
#include <assert.h>
#include <ctype.h>

View file

@ -0,0 +1,10 @@
--- keama/data.c.orig 2022-09-28 14:39:15 UTC
+++ keama/data.c
@@ -23,6 +23,7 @@
#include "data.h"
#include <sys/types.h>
+#include <sys/socket.h>
#include <arpa/inet.h>
#include <assert.h>
#include <stdlib.h>

View file

@ -0,0 +1,10 @@
--- keama/eval.c.orig 2022-09-28 14:39:15 UTC
+++ keama/eval.c
@@ -25,6 +25,7 @@
#include <sys/errno.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <arpa/inet.h>
#include <ctype.h>
#include <netdb.h>

View file

@ -0,0 +1,10 @@
--- keama/keama.c.orig 2022-09-28 14:39:15 UTC
+++ keama/keama.c
@@ -22,6 +22,7 @@
*/
#include <sys/errno.h>
+#include <sys/socket.h>
#include <arpa/inet.h>
#include <assert.h>
#include <fcntl.h>

View file

@ -0,0 +1,10 @@
--- keama/parse.c.orig 2022-09-28 14:39:15 UTC
+++ keama/parse.c
@@ -24,6 +24,7 @@
#include "keama.h"
#include <sys/types.h>
+#include <sys/socket.h>
#include <arpa/inet.h>
#include <ctype.h>
#include <netdb.h>

View file

@ -0,0 +1,10 @@
--- keama/reduce.c.orig 2022-09-28 14:39:15 UTC
+++ keama/reduce.c
@@ -25,6 +25,7 @@
#include <sys/errno.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <arpa/inet.h>
#include <ctype.h>
#include <netdb.h>

3
net/keama/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
Kea migration assistant is an experimental extension to ISC DHCP
that is able to read an isc-dhcp configuration
and produce a JSON configuration in Kea format.