- Let the cblas library get overriden from the ports makefile;

- Add a test: target;

- Define -fPIC on amd64.

PR:		93005
Submitted by:	Pedro F. Giffuni <giffunip (at) asme.org>
This commit is contained in:
Thierry Thomas 2006-02-20 08:56:57 +00:00
parent da2dbcdfa1
commit efe40190bb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=156475
2 changed files with 29 additions and 9 deletions

View file

@ -19,10 +19,19 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libcblas.a:${PORTSDIR}/math/atlas
WRKSRC= ${WRKDIR}/${DISTNAME}/UMFPACK
ALL_TARGET= lib
CBLAS_LIBS?= -L${LOCALBASE}/lib -lcblas -latlas
post-extract:
${CP} ${WRKDIR}/${DISTNAME}/AMD/Make/Make.linux \
${WRKDIR}/${DISTNAME}/AMD/Make/Make.freebsd
pre-build:
@${REINPLACE_CMD} -e 's+%%CC%%+${CC}+g ; \
s+%%CFLAGS%%+${CFLAGS}+ ; \
s+%%LOCALBASE%%+${LOCALBASE}+ ; \
s+%%CBLAS_LIBS%%+${CBLAS_LIBS}+ ;' \
${WRKDIR}/${DISTNAME}/AMD/Make/Make.freebsd
do-install:
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/AMD/Lib/libamd.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/Lib/libumfpack.a ${PREFIX}/lib
@ -47,4 +56,15 @@ do-install:
@${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
.if defined(MAINTAINER_MODE)
test: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} hb )
.endif
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif
.include <bsd.port.post.mk>

View file

@ -1,13 +1,13 @@
--- Make/Make.freebsd.orig Fri Mar 18 22:29:13 2005
+++ Make/Make.freebsd Fri Mar 18 22:30:13 2005
--- Make/Make.freebsd.orig Sun Feb 19 15:26:42 2006
+++ Make/Make.freebsd Sun Feb 19 15:29:05 2006
@@ -6,8 +6,8 @@
# if you use the Intel compiler and the Fortran BLAS.
# Using GNU gcc and f77 compilers:
- CC = gcc
- CFLAGS = -O3 -fPIC
+ CC ?= cc
+ CFLAGS ?= -O3 -fPIC
+ CC = %%CC%%
+ CFLAGS = %%CFLAGS%%
# Using Intel's icc and ifc compilers:
# F77 = ifc
@ -17,14 +17,14 @@
# 2: with the ATLAS C-BLAS (http://www.netlib.org/atlas).
-# CONFIG = -DCBLAS -I../ATLAS/include
-# LIB = -lcblas -latlas -lm
+CONFIG = -DCBLAS -I../ATLAS/include -I${LOCALBASE}/include
+LIB = -L${LOCALBASE}/lib -lcblas -latlas -lm
+CONFIG = -DGETRUSAGE -DCBLAS -I../ATLAS/include -I%%LOCALBASE%%/include
+LIB = %%CBLAS_LIBS%% -lm
# 3: with Fortran interface to the ATLAS BLAS
-# CONFIG =
-# LIB = -lf77blas -latlas -lfrtbegin -lg2c -lm
+# CONFIG = -I${LOCALBASE}/include
+# LIB = -L${LOCALBASE}/lib -lf77blas -latlas -lfrtbegin -lg2c -lm
+# CONFIG = -I%%LOCALBASE%%/include
+# LIB = -L%%LOCALBASE%%/lib -lf77blas -latlas -lfrtbegin -lg2c -lm
# 4: with Fortran interface to the BLAS, and Goto's BLAS
- CONFIG =