- Get rid FreeBSD 6.X support
This commit is contained in:
parent
f0abaeb404
commit
f0306011f3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285170
6 changed files with 3 additions and 44 deletions
|
@ -92,9 +92,6 @@ PORTDOCS= *
|
|||
.if ${OSVERSION} < 800502
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rpmio_rpmsq.c
|
||||
.endif
|
||||
.if ${OSVERSION} < 700000
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-lib_fs.c
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
|
||||
LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- lib/fs.c.orig 2010-07-06 07:27:10.000000000 +0200
|
||||
+++ lib/fs.c 2010-07-06 07:27:12.000000000 +0200
|
||||
@@ -134,6 +134,8 @@ exit:
|
||||
|
||||
#else /* HAVE_MNTCTL */
|
||||
|
||||
+#include <sys/mount.h>
|
||||
+
|
||||
/**
|
||||
* Get information for mounted file systems.
|
||||
* @todo determine rdonly for non-linux file systems.
|
|
@ -146,11 +146,6 @@ post-configure:
|
|||
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
|
||||
.endif
|
||||
@echo "DOT_FONTPATH = ${LOCALBASE}/lib/X11/fonts/freefont-ttf" >> ${WRKSRC}/Doxyfile
|
||||
.if ${OSVERSION} < 700000
|
||||
# on FreeBSD 6.x, <sys/mount.h> first requires <sys/param.h> (for NGROUPS)
|
||||
@${REINPLACE_CMD} -e "s:/\* #undef HAVE_SYS_MOUNT_H \*/:#define HAVE_SYS_MOUNT_H 1:" \
|
||||
${WRKSRC}/config.h
|
||||
.endif
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-build:
|
||||
|
|
|
@ -31,9 +31,8 @@ SUB_FILES= pkg-message
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-extract:
|
||||
.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
|
||||
${CP} ${FILESDIR}/os-features-config.h ${WRKSRC}/util/
|
||||
.if ${ARCH} == "sparc64"
|
||||
BROKEN= Does not build on sparc64
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
|
@ -43,8 +42,4 @@ post-patch:
|
|||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.if ${ARCH} == "sparc64"
|
||||
BROKEN= Does not build on sparc64
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -27,12 +27,6 @@ PLIST_SUB= VERSION="${PORTVERSION}"
|
|||
OPTIONS= CFITSIO "Add cfitsio support (for tests only)" Off \
|
||||
PGPLOT "Add pgplot support (for tests only)" Off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 700000
|
||||
EXTRA_PATCHES= ${FILESDIR}/6-patch-configure
|
||||
.endif
|
||||
|
||||
# The configure script unconditionally searches for the cftisio library
|
||||
# and uses it if found.
|
||||
|
||||
|
@ -51,4 +45,4 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's#%%PKGDIR%%#${LOCALBASE}/libdata#g' \
|
||||
${WRKSRC}/GNUmakefile
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.orig 2010-01-03 16:00:48.000000000 +1100
|
||||
+++ configure 2010-01-03 16:02:03.000000000 +1100
|
||||
@@ -9439,7 +9439,7 @@
|
||||
|
||||
SUBDIRS="C Fortran"
|
||||
TSTDIRS="C Fortran"
|
||||
- INSTDIR="pgsbox"
|
||||
+ INSTDIR="Fortran"
|
||||
fi
|
||||
fi
|
||||
|
Loading…
Reference in a new issue