Update to 4.10, fixing the execvp() and pid file issues while I'm here.

PR:		79114, 79120, 80143, 80405
Submitted by:	Florian Hars <hars@bik-gmbh.de>,
		Jim Hatfield <jim.hatfield@insignia.com>,
		Vasil Dimov <vd@datamax.bg>,
		Vsevolod Stakhov <vsevolod@highsecure.ru>
This commit is contained in:
Peter Pentchev 2005-05-12 11:36:41 +00:00
parent 51e03f515b
commit f06998a46e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135126
7 changed files with 29 additions and 39 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= stunnel
PORTVERSION= 4.07
PORTVERSION= 4.10
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \

View file

@ -1,2 +1,2 @@
MD5 (stunnel-4.07.tar.gz) = 7d53af550a1c2e01e146b936e58b8860
SIZE (stunnel-4.07.tar.gz) = 486230
MD5 (stunnel-4.10.tar.gz) = 9de7a62a44083114779ca4e109d70776
SIZE (stunnel-4.10.tar.gz) = 487066

View file

@ -1,19 +1,11 @@
--- tools/Makefile.in.orig Mon Dec 27 13:52:12 2004
+++ tools/Makefile.in Mon Dec 27 13:52:25 2004
@@ -163,7 +163,7 @@
stunnel.spec stunnel.mak stunnel.cnf
--- tools/Makefile.in.orig Wed May 11 18:33:24 2005
+++ tools/Makefile.in Wed May 11 18:34:12 2005
@@ -332,7 +332,7 @@
confdir = $(sysconfdir)/stunnel
-conf_DATA = stunnel.conf-sample stunnel.pem
+conf_DATA = stunnel.conf-sample
docdir = $(datadir)/doc/stunnel
examplesdir = $(docdir)/examples
examples_DATA = ca.html ca.pl importCA.html importCA.sh script.sh \
@@ -337,7 +337,6 @@
install-data-am: install-confDATA install-data-local \
info-am:
-install-data-am: install-confDATA install-data-local \
+install-data-am: install-confDATA \
install-examplesDATA
@$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
install-exec-am:

View file

@ -0,0 +1,17 @@
--- src/client.c.orig Thu May 12 14:01:28 2005
+++ src/client.c Thu May 12 14:04:19 2005
@@ -841,6 +841,14 @@
sigemptyset(&newmask);
sigprocmask(SIG_SETMASK, &newmask, NULL);
#endif
+ if (c->opt->execargs != NULL && c->opt->execargs[0] == NULL) {
+ free(c->opt->execargs);
+ c->opt->execargs = NULL;
+ }
+ if (c->opt->execargs == NULL) {
+ c->opt->execargs = calloc(2, sizeof(c->opt->execargs[0]));
+ c->opt->execargs[0] = c->opt->execname;
+ }
execvp(c->opt->execname, c->opt->execargs);
ioerror(c->opt->execname); /* execv failed */
_exit(1);

View file

@ -1,19 +0,0 @@
--- src/network.c.orig Mon Jan 3 09:16:45 2005
+++ src/network.c Mon Jan 3 09:17:49 2005
@@ -488,10 +488,13 @@
char *s_ntop(char *text, SOCKADDR_UNION *addr) {
char host[IPLEN-6], port[6];
+ int err;
- if(getnameinfo(&addr->sa, addr_len(*addr),
- host, IPLEN-6, port, 6, NI_NUMERICHOST|NI_NUMERICSERV)) {
- sockerror("getnameinfo");
+ err = getnameinfo(&addr->sa, addr_len(*addr),
+ host, IPLEN-6, port, 6, NI_NUMERICHOST|NI_NUMERICSERV);
+ if (err) {
+ s_log(LOG_ERR, "Error resolving the specified address: %s",
+ s_gai_strerror(err));
strcpy(text, "unresolvable IP");
return text;
}

View file

@ -26,7 +26,7 @@
name="stunnel"
rcvar=`set_rcvar`
stunnel_config="!!PREFIX!!/etc/stunnel/${name}.conf"
stunnel_pidfile="!!PREFIX!!/var/stunnel/${name}.pid"
stunnel_pidfile="/var/run/${name}.pid"
command="!!PREFIX!!/sbin/stunnel"
[ -z "$stunnel_enable" ] && stunnel_enable="NO"

View file

@ -26,7 +26,7 @@
name="stunnel"
rcvar=`set_rcvar`
stunnel_config="!!PREFIX!!/etc/stunnel/${name}.conf"
stunnel_pidfile="!!PREFIX!!/var/stunnel/${name}.pid"
stunnel_pidfile="/var/run/${name}.pid"
command="!!PREFIX!!/sbin/stunnel"
[ -z "$stunnel_enable" ] && stunnel_enable="NO"