- Disable check whether GTK3 is supported

- Disable color output of cmake
- Remove DOCS and NLS from OPTIONS_DEFAULT
This commit is contained in:
Nicola Vitale 2013-03-06 17:46:27 +00:00
parent b2cc9d90aa
commit f0766b14e2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=313534
2 changed files with 19 additions and 17 deletions

View file

@ -21,14 +21,16 @@ LIB_DEPENDS= Xtst:${PORTSDIR}/x11/libXtst \
gee:${PORTSDIR}/devel/libgee \
unique:${PORTSDIR}/x11-toolkits/unique
CMAKE_ARGS= -DCMAKE_COLOR_MAKEFILE:BOOL="OFF"
INSTALLS_ICONS= yes
OPTIONS_DEFINE= DOCS MANPAGES NLS
OPTIONS_DEFAULT= DOCS MANPAGES NLS
OPTIONS_DEFAULT= MANPAGES
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
CMAKE_ARGS= -DINSTALL_DOCS:BOOL=ON
CMAKE_ARGS+= -DINSTALL_DOCS:BOOL=ON
.endif
.if ${PORT_OPTIONS:MMANPAGES}

View file

@ -1,30 +1,30 @@
--- ./CMakeLists.txt.orig 2013-01-23 23:33:16.000000000 +0100
+++ ./CMakeLists.txt 2013-01-24 21:41:21.000000000 +0100
@@ -32,13 +32,11 @@
--- ./CMakeLists.txt.orig 2013-03-06 18:35:57.000000000 +0100
+++ ./CMakeLists.txt 2013-03-06 18:36:57.000000000 +0100
@@ -26,7 +26,9 @@
find_package(PkgConfig)
# check whether GTK3 is supported
+if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
pkg_check_modules(GTK3 gtk+-3.0)
+endif (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
if (${GTK3_FOUND})
pkg_check_modules(INDICATOR3 appindicator3-0.1)
pkg_check_modules(UNIQUE REQUIRED unique-3.0)
pkg_check_modules(WNCK REQUIRED libwnck-3.0)
- pkg_check_modules(BAMF REQUIRED libbamf3)
else (${GTK3_FOUND})
pkg_check_modules(GTK2 REQUIRED gtk+-2.0)
@@ -38,7 +40,7 @@
pkg_check_modules(INDICATOR appindicator-0.1)
pkg_check_modules(UNIQUE REQUIRED unique-1.0)
pkg_check_modules(WNCK REQUIRED libwnck-1.0)
- pkg_check_modules(BAMF REQUIRED libbamf)
+# pkg_check_modules(BAMF REQUIRED libbamf)
endif (${GTK3_FOUND})
pkg_check_modules(GIO REQUIRED gio-unix-2.0)
@@ -180,13 +178,11 @@
if (${GTK3_FOUND})
LIST(APPEND VALA_PKGS gtk+-3.0)
LIST(APPEND VALA_PKGS gdk-x11-3.0)
- LIST(APPEND VALA_PKGS libbamf3)
LIST(APPEND VALA_PKGS libwnck-3.0)
LIST(APPEND VALA_PKGS unique-3.0)
@@ -186,7 +188,7 @@
else (${GTK3_FOUND})
LIST(APPEND VALA_PKGS gtk+-2.0)
LIST(APPEND VALA_PKGS gdk-x11-2.0)
- LIST(APPEND VALA_PKGS bamf)
+# LIST(APPEND VALA_PKGS bamf)
LIST(APPEND VALA_PKGS libwnck-1.0)
LIST(APPEND VALA_PKGS unique-1.0)
endif (${GTK3_FOUND})