Add p5-POE-Component-LaDBI 1.2.0,

perl extension for asynchronous
non-blocking DBI calls in POE.
This commit is contained in:
Sergey Skvortsov 2004-03-30 15:50:30 +00:00
parent 4350c75ac8
commit f07849a27d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105711
6 changed files with 82 additions and 0 deletions

View file

@ -167,6 +167,7 @@
SUBDIR += p5-Metadata
SUBDIR += p5-Mysql
SUBDIR += p5-Mysql-Diff
SUBDIR += p5-POE-Component-LaDBI
SUBDIR += p5-Pg
SUBDIR += p5-ResourcePool-Resource-DBI
SUBDIR += p5-SQL-Abstract

View file

@ -0,0 +1,41 @@
# New ports collection makefile for: POE-Component-LaDBI
# Date created: 09 February 2004
# Whom: Sergey Skvortsov <skv@protey.ru>
#
# $FreeBSD$
#
PORTNAME= POE-Component-LaDBI
PORTVERSION= 1.2.0
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= POE
PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Perl extension for asynchronous non-blocking DBI calls in POE
BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= POE::Component::LaDBI.3 POE::Component::LaDBI::Commands.3 \
POE::Component::LaDBI::Engine.3 \
POE::Component::LaDBI::Request.3 \
POE::Component::LaDBI::Response.3
.include <bsd.port.pre.mk>
post-extract:
${RM} ${WRKSRC}/*.pl
post-patch:
@${PERL} -pi -e 's!(?=read_answer_yes\()!0 and !;' ${WRKSRC}/Makefile.PL
.if ${PERL_LEVEL} < 500600
IGNORE= "Perl 5.6 or newer required. Install lang/perl5.8 or lang/perl5 and try again."
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (POE-Component-LaDBI-1.2.0.tar.gz) = 2de7741c35f7289b4ddb120cf1868116
SIZE (POE-Component-LaDBI-1.2.0.tar.gz) = 24655

View file

@ -0,0 +1,19 @@
--- Makefile.PL.orig Tue Mar 30 19:41:17 2004
+++ Makefile.PL Tue Mar 30 19:42:44 2004
@@ -9,7 +9,7 @@
our $BASE_CFG_FN;
our $NO_DB_TESTS_FN;
-require "ladbi_config.pl";
+=for unused
if (0 and read_answer_yes("Do you want to test this module against a Database?"))
{
@@ -42,6 +42,7 @@
}
+=cut
#exit 0;

View file

@ -0,0 +1,7 @@
POE Component that spawns a perl subprocess to handle non-blocking
access to the DBI API.
WWW: http://search.cpan.org/dist/POE-Component-LaDBI/
-- Sergey Skvortsov
skv@FreeBSD.org

View file

@ -0,0 +1,12 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/LaDBI/.packlist
%%SITE_PERL%%/POE/Component/LaDBI.pm
%%SITE_PERL%%/POE/Component/LaDBI/Commands.pm
%%SITE_PERL%%/POE/Component/LaDBI/Engine.pm
%%SITE_PERL%%/POE/Component/LaDBI/Request.pm
%%SITE_PERL%%/POE/Component/LaDBI/Response.pm
@dirrm %%SITE_PERL%%/POE/Component/LaDBI
@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/LaDBI
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true