Fix plist and take the opportunity to make the port respect CFLAGS

This commit is contained in:
Kris Kennaway 2001-03-10 06:35:23 +00:00
parent 18471966b6
commit f078732dfd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39386
4 changed files with 32 additions and 8 deletions

View file

@ -1,8 +1,14 @@
--- dlxsim/Makefile.orig Sat Dec 26 13:14:21 1998
+++ dlxsim/Makefile Sat Dec 26 13:14:41 1998
@@ -11,7 +11,7 @@
CC = cc
CFLAGS = -g -I. -Itcl
--- dlxsim/Makefile.orig Tue Dec 18 12:26:43 1990
+++ dlxsim/Makefile Fri Mar 9 22:23:17 2001
@@ -7,11 +7,10 @@
LIBS = tcl/tcl.a
#LIBS = tcl/tcl.a -lBSD
-CC = gcc
-CC = cc
-CFLAGS = -g -I. -Itcl
+CC ?= cc
+CFLAGS += -g -I. -Itcl
DEST = /tmp_mnt/home/ginger/pnh/bly/bin/$(MACHINE)/
-DEST = ../bin
+DEST = ../bin/

View file

@ -1,6 +1,12 @@
--- dlxsim/tcl/Makefile.orig Tue Dec 18 12:24:38 1990
+++ dlxsim/tcl/Makefile Sat Dec 26 13:11:18 1998
@@ -13,9 +13,8 @@
+++ dlxsim/tcl/Makefile Fri Mar 9 22:26:53 2001
@@ -8,14 +8,13 @@
#LIBS = -lBSD
#CFLAGS = -I. -DTCL_VERSION=\"2.1\" -DSUN
-CFLAGS = -I. -DTCL_VERSION=\"2.1\"
+CFLAGS += -I. -DTCL_VERSION=\"2.1\"
OBJS = glob.o tclBasic.o tclCmdAH.o tclCmdIZ.o tclExpr.o \
tclGlob.o tclProc.o tclUtil.o

View file

@ -1,5 +1,16 @@
--- gcc/Makefile.orig Tue Aug 14 12:29:46 1990
+++ gcc/Makefile Sat Dec 26 13:49:36 1998
+++ gcc/Makefile Fri Mar 9 22:25:52 2001
@@ -21,8 +21,8 @@
# Variables that exist for you to override.
# See below for how to change them for certain systems.
-CFLAGS = -g $(XCFLAGS)
-CC = cc
+CFLAGS += -g $(XCFLAGS)
+CC ?= cc
BISON = bison
BISONFLAGS = -v
AR = ar
@@ -45,9 +45,11 @@
# Directory where sources are, from where we are.
srcdir = .

View file

@ -6,3 +6,4 @@ share/doc/dlx/dlxsim.tex
share/doc/dlx/manual.tex
share/doc/dlx/report.tex
share/doc/dlx/report2.tex
@dirrm share/doc/dlx