sysutils/fusefs-sshfs: Update version 3.3.0=>3.3.1
- Add NDEBUG [1] PR: 223338 [1] Submitted by: rozhuk.im@gmail.com [1] Relnotes: https://github.com/libfuse/sshfs/releases
This commit is contained in:
parent
c3d0e41e71
commit
f09f8484f0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=458485
5 changed files with 11 additions and 27 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sshfs
|
||||
PORTVERSION= 3.3.0
|
||||
PORTVERSION= 3.3.1
|
||||
DISTVERSIONPREFIX= ${PORTNAME}-
|
||||
CATEGORIES= sysutils
|
||||
PKGNAMEPREFIX= fusefs-
|
||||
|
@ -21,6 +21,7 @@ USE_GITHUB= yes
|
|||
GH_ACCOUNT= libfuse
|
||||
|
||||
USE_GNOME= glib20
|
||||
CFLAGS+= -DNDEBUG
|
||||
|
||||
PLIST_FILES= bin/sshfs \
|
||||
man/man1/sshfs.1.gz
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1507553211
|
||||
SHA256 (libfuse-sshfs-sshfs-3.3.0_GH0.tar.gz) = 6cb256a894d0284a4ca9967c9f0c35c5c761e8a7496b81343aac0d45d73c1466
|
||||
SIZE (libfuse-sshfs-sshfs-3.3.0_GH0.tar.gz) = 54703
|
||||
TIMESTAMP = 1515443900
|
||||
SHA256 (libfuse-sshfs-sshfs-3.3.1_GH0.tar.gz) = 5310cb14424ba2101e389bd5463a97fbea044674d1cd3275e1a4f5cba2016668
|
||||
SIZE (libfuse-sshfs-sshfs-3.3.1_GH0.tar.gz) = 54928
|
||||
|
|
|
@ -1,19 +1,13 @@
|
|||
--- meson.build.orig 2017-09-20 17:08:27 UTC
|
||||
--- meson.build.orig 2017-10-25 18:32:34 UTC
|
||||
+++ meson.build
|
||||
@@ -58,15 +58,10 @@ executable('sshfs', sshfs_sources,
|
||||
if rst2man.found()
|
||||
custom_target('manpages', input: [ 'sshfs.rst' ], output: [ 'sshfs.1' ],
|
||||
command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
|
||||
- install_dir: join_paths(get_option('mandir'), '1'))
|
||||
+ install_dir: join_paths(get_option('mandir'), 'man1'))
|
||||
else
|
||||
@@ -63,10 +63,5 @@ else
|
||||
message('rst2man not found, not building manual page.')
|
||||
endif
|
||||
-
|
||||
|
||||
-meson.add_install_script('utils/install_helper.sh',
|
||||
- get_option('sbindir'),
|
||||
- get_option('bindir'))
|
||||
-
|
||||
|
||||
-
|
||||
subdir('test')
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- sshfs.c.orig 2017-09-20 17:08:27 UTC
|
||||
--- sshfs.c.orig 2018-01-08 21:05:08 UTC
|
||||
+++ sshfs.c
|
||||
@@ -965,7 +965,7 @@ static int pty_master(char **name)
|
||||
@@ -971,7 +971,7 @@ static int pty_master(char **name)
|
||||
{
|
||||
int mfd;
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- test/meson.build.orig 2017-09-20 17:08:27 UTC
|
||||
+++ test/meson.build
|
||||
@@ -2,7 +2,7 @@ test_scripts = [ 'conftest.py', 'pytest.ini', 'test_ss
|
||||
'util.py' ]
|
||||
custom_target('test_scripts', input: test_scripts,
|
||||
output: test_scripts, build_by_default: true,
|
||||
- command: ['cp', '-fP', '--preserve=mode',
|
||||
+ command: ['cp', '-fPp',
|
||||
'@INPUT@', meson.current_build_dir() ])
|
||||
|
||||
# Provide something helpful when running 'ninja test'
|
Loading…
Reference in a new issue