This commit is contained in:
Thierry Thomas 2014-09-24 21:33:15 +00:00
parent bcaf0be955
commit f0dad4527a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=369209
4 changed files with 24 additions and 8 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= toxcore
PORTVERSION= 0.140908
PORTREVISION= 1
PORTVERSION= 0.140924
CATEGORIES= net-im net-p2p
MAINTAINER= thierry@FreeBSD.org
@ -14,7 +13,6 @@ LICENSE= GPLv3
BUILD_DEPENDS= checkmk:${PORTSDIR}/devel/libcheck
LIB_DEPENDS= libvpx.so:${PORTSDIR}/multimedia/libvpx \
libopus.so:${PORTSDIR}/audio/opus \
libopenal.so.1:${PORTSDIR}/audio/openal-soft \
libv4l2.so:${PORTSDIR}/multimedia/libv4l \
libswscale.so:${PORTSDIR}/multimedia/ffmpeg
@ -22,12 +20,12 @@ USE_GITHUB= yes
GH_ACCOUNT= irungentoo
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= a0302b7
GH_COMMIT= 744f51e
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
AUTOMAKE_ARGS= -a -c -f
CONFIGURE_ARGS= --enable-testing
USES= pkgconfig pathfix libtool
USES= libtool openal:soft pathfix pkgconfig
USE_SDL= yes
USE_LDCONFIG= yes
PATHFIX_MAKEFILEIN= Makefile.am

View file

@ -1,2 +1,2 @@
SHA256 (toxcore-0.140908.tar.gz) = 424900cb7fb6526969ad314b86e073c62eed9e84b252fd6bf6294ac92781b530
SIZE (toxcore-0.140908.tar.gz) = 288829
SHA256 (toxcore-0.140924.tar.gz) = 8c0937938f0d91ce63f3b941c726d1cb588e67d71b33a4a948f635c761cb8109
SIZE (toxcore-0.140924.tar.gz) = 326683

View file

@ -0,0 +1,14 @@
--- testing/test_avatars.c.orig 2014-09-24 03:00:12.000000000 +0200
+++ testing/test_avatars.c 2014-09-24 22:18:32.000000000 +0200
@@ -47,7 +47,11 @@
#include <unistd.h>
#include <time.h>
#include <stdbool.h>
+#if defined(__linux__)
#include <linux/limits.h>
+#elif defined(__FreeBSD__)
+#include <sys/syslimits.h>
+#endif
#include <sys/stat.h>
#include <unistd.h>
#include <errno.h>

View file

@ -2,6 +2,7 @@ bin/DHT_bootstrap
include/tox/tox.h
include/tox/toxav.h
include/tox/toxdns.h
include/tox/toxencryptsave.h
lib/libtoxav.a
%%SODIUM%%lib/libtoxav.so
%%SODIUM%%lib/libtoxav.so.0
@ -14,6 +15,9 @@ lib/libtoxdns.a
%%SODIUM%%lib/libtoxdns.so
%%SODIUM%%lib/libtoxdns.so.0
%%SODIUM%%lib/libtoxdns.so.0.0.0
lib/libtoxencryptsave.a
%%SODIUM%%lib/libtoxencryptsave.so
%%SODIUM%%lib/libtoxencryptsave.so.0
%%SODIUM%%lib/libtoxencryptsave.so.0.0.0
libdata/pkgconfig/libtoxav.pc
libdata/pkgconfig/libtoxcore.pc
@dirrm include/tox