xmpp-client is a simple XMPP client written in pure Go. It supports the OTR
protocol. WWW: https://github.com/agl/xmpp-client
This commit is contained in:
parent
9148f42914
commit
f0e3f4a236
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383174
7 changed files with 81 additions and 0 deletions
|
@ -180,6 +180,7 @@
|
|||
SUBDIR += uTox
|
||||
SUBDIR += vacuum-im
|
||||
SUBDIR += vqcc-gtk
|
||||
SUBDIR += xmpp-client
|
||||
SUBDIR += yoono
|
||||
SUBDIR += zephyr
|
||||
|
||||
|
|
29
net-im/xmpp-client/Makefile
Normal file
29
net-im/xmpp-client/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xmpp-client
|
||||
PORTVERSION= 20150208
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= http://c-s.li/ports/
|
||||
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
|
||||
xmpp-20150105.tar.gz
|
||||
|
||||
MAINTAINER= cs@FreeBSD.org
|
||||
COMMENT= XMPP client with OTR support
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/code.google.com/p/go.crypto/bcrypt.a:${PORTSDIR}/security/go.crypto \
|
||||
${LOCALBASE}/${GO_LIBDIR}/code.google.com/p/go.net/dict.a:${PORTSDIR}/net/go.net
|
||||
|
||||
PLIST_FILES= bin/xmpp-client
|
||||
GO_PKGNAME= github.com/agl/${PORTNAME}
|
||||
|
||||
post-extract:
|
||||
@${MKDIR} ${GO_WRKSRC:H}
|
||||
@${LN} -sf ${WRKSRC} ${GO_WRKSRC}
|
||||
@${LN} -sf ${WRKDIR}/xmpp-20150105 ${GO_WRKDIR_SRC}/github.com/agl/xmpp
|
||||
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
|
||||
.include <bsd.port.post.mk>
|
4
net-im/xmpp-client/distinfo
Normal file
4
net-im/xmpp-client/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
SHA256 (xmpp-client-20150208.tar.gz) = 9a2f079ee5b075d1af073e1dd566d4e2f2844d4383fa84668e94c41c33d9cba7
|
||||
SIZE (xmpp-client-20150208.tar.gz) = 23272
|
||||
SHA256 (xmpp-20150105.tar.gz) = f7b8867ebd943f859f5c98594874f282d3b6066af741e4a0eeaab7dfb1347f36
|
||||
SIZE (xmpp-20150105.tar.gz) = 12825
|
15
net-im/xmpp-client/files/patch-config.go
Normal file
15
net-im/xmpp-client/files/patch-config.go
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- config.go.orig 2015-03-07 22:36:57.219206000 +0100
|
||||
+++ config.go 2015-03-07 22:39:28.246637000 +0100
|
||||
@@ -12,9 +12,9 @@
|
||||
"strings"
|
||||
|
||||
"github.com/agl/xmpp"
|
||||
- "golang.org/x/crypto/otr"
|
||||
- "golang.org/x/crypto/ssh/terminal"
|
||||
- "golang.org/x/net/proxy"
|
||||
+ "code.google.com/p/go.crypto/otr"
|
||||
+ "code.google.com/p/go.crypto/ssh/terminal"
|
||||
+ "code.google.com/p/go.net/proxy"
|
||||
)
|
||||
|
||||
type Config struct {
|
11
net-im/xmpp-client/files/patch-input.go
Normal file
11
net-im/xmpp-client/files/patch-input.go
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- input.go.orig 2015-03-07 22:39:38.830132000 +0100
|
||||
+++ input.go 2015-03-07 22:39:59.824941000 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
"strings"
|
||||
"sync"
|
||||
|
||||
- "golang.org/x/crypto/ssh/terminal"
|
||||
+ "code.google.com/p/go.crypto/ssh/terminal"
|
||||
)
|
||||
|
||||
type uiCommand struct {
|
17
net-im/xmpp-client/files/patch-ui.go
Normal file
17
net-im/xmpp-client/files/patch-ui.go
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- ui.go.orig 2015-03-07 22:40:10.096733000 +0100
|
||||
+++ ui.go 2015-03-07 22:41:07.136470000 +0100
|
||||
@@ -22,10 +22,10 @@
|
||||
"time"
|
||||
|
||||
"github.com/agl/xmpp"
|
||||
- "golang.org/x/crypto/otr"
|
||||
- "golang.org/x/crypto/ssh/terminal"
|
||||
- "golang.org/x/net/html"
|
||||
- "golang.org/x/net/proxy"
|
||||
+ "code.google.com/p/go.crypto/otr"
|
||||
+ "code.google.com/p/go.crypto/ssh/terminal"
|
||||
+ "code.google.com/p/go.net/html"
|
||||
+ "code.google.com/p/go.net/proxy"
|
||||
)
|
||||
|
||||
var configFile *string = flag.String("config-file", "", "Location of the config file")
|
4
net-im/xmpp-client/pkg-descr
Normal file
4
net-im/xmpp-client/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
xmpp-client is a simple XMPP client written in pure Go. It supports the OTR
|
||||
protocol.
|
||||
|
||||
WWW: https://github.com/agl/xmpp-client
|
Loading…
Reference in a new issue