Unbreak with perl5 from base on 4.x.
Noticed by: pointyhat Perl-helpdesk: mat
This commit is contained in:
parent
6c5643deb1
commit
f0e454a762
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109245
2 changed files with 14 additions and 2 deletions
|
@ -21,8 +21,9 @@ MAN3= Crypt::Anubis.3
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= "Does not compile"
|
||||
.if ${PERL_LEVEL} < 500600
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's/^our (\S+)/use vars qw{$$1};$$1/g' ${WRKSRC}/Anubis.pm
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
11
security/p5-Crypt-Anubis/files/patch-anubis.c
Normal file
11
security/p5-Crypt-Anubis/files/patch-anubis.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- _anubis.c.orig Sun May 16 10:04:36 2004
|
||||
+++ _anubis.c Sun May 16 10:05:13 2004
|
||||
@@ -976,7 +976,7 @@
|
||||
void print_data(char *str, u8 *val, int len);
|
||||
int compare_blocks(u8 *m1, u8 *m2, int len_bits); /* 0=equal, 1=not eq. */
|
||||
|
||||
-int main(void)
|
||||
+int main _((int argc, char** argv, char** env))
|
||||
{
|
||||
struct NESSIEstruct subkeys;
|
||||
u8 key[KEYSIZEB];
|
Loading…
Reference in a new issue