MFH: r461513
Update to 3.4.8 - Set PORTNAME to python and add PKGNAMESUFFIX - Update Makefile and PLIST to be similar with python36 - Sort USES - Remove CPE_*: all of them are default values - Update PLIST_FILES: do not use %% - Fix shebang: - Update SHEBANG_FILES - Remove over-patched shebang fix of Lib/cgi.py - Update http:// links in Makefile comments and patch files Changes: https://docs.python.org/3.4/whatsnew/changelog.html Security: 0fe70bcd-2ce3-46c9-a64b-4a7da097db07 Approved by: ports-secteam (riggs)
This commit is contained in:
parent
eef1b1eceb
commit
f10e8bdd15
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q1/; revision=461594
8 changed files with 4951 additions and 4937 deletions
|
@ -1,10 +1,11 @@
|
|||
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= python34
|
||||
PORTNAME= python
|
||||
PORTVERSION= ${PYTHON_PORTVERSION}
|
||||
CATEGORIES= lang python ipv6
|
||||
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
|
||||
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
|
||||
DISTNAME= Python-${PORTVERSION}
|
||||
DIST_SUBDIR= python
|
||||
|
||||
|
@ -13,15 +14,17 @@ COMMENT= Interpreted object-oriented programming language
|
|||
|
||||
LICENSE= PSFL
|
||||
|
||||
USES= cpe ncurses pathfix pkgconfig readline:port ssl tar:xz shebangfix
|
||||
USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
|
||||
PATHFIX_MAKEFILEIN= Makefile.pre.in
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
|
||||
SHEBANG_FILES= Lib/lib2to3/tests/data/*.py Lib/encodings/*.py
|
||||
python_CMD= ${PREFIX}/bin/python${PORTVERSION:R}
|
||||
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
|
||||
|
||||
CPE_VENDOR= python
|
||||
CPE_PRODUCT= ${CPE_VENDOR}
|
||||
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
|
||||
PYTHON_VER= ${PYTHON_PORTVERSION:R}
|
||||
PYTHON_VERSION= python${PYTHON_VER}
|
||||
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
|
||||
|
||||
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
|
||||
CONFIGURE_ARGS+= --enable-shared --without-ensurepip
|
||||
|
@ -36,11 +39,13 @@ MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
|
|||
MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
SUB_LIST= PYTHON_SUFFIX=${PORTVERSION:R:S/.//g}
|
||||
SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
|
||||
|
||||
PLIST_SUB= ABI=${ABIFLAGS} \
|
||||
XYZDOT=${PYTHON_PORTVERSION} \
|
||||
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
|
||||
XY=${PYTHON_SUFFIX} \
|
||||
XYDOT=${PYTHON_VER} \
|
||||
XYZDOT=${PORTVERSION} \
|
||||
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
|
||||
|
||||
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS TSC
|
||||
OPTIONS_DEFAULT= LIBFFI PYMALLOC THREADS
|
||||
|
@ -68,7 +73,7 @@ LIBFFI_LIB_DEPENDS= libffi.so:devel/libffi
|
|||
|
||||
# Use CPPFLAGS over CFLAGS due to -I ordering, causing elementtree and pyexpat
|
||||
# to break in Python 2.7, or preprocessor complaints in Python >= 3.3
|
||||
# Upstream Issue: http://bugs.python.org/issue6299
|
||||
# Upstream Issue: https://bugs.python.org/issue6299
|
||||
NLS_USES= gettext
|
||||
NLS_CPPFLAGS= -I${LOCALBASE}/include
|
||||
NLS_LIBS= -L${LOCALBASE}/lib -lintl
|
||||
|
@ -93,13 +98,13 @@ ABIFLAGS:= d${ABIFLAGS}
|
|||
.endif
|
||||
|
||||
.if !empty(ABIFLAGS)
|
||||
PLIST_FILES+= bin/python3.4%%ABI%%
|
||||
PLIST_FILES+= bin/python3.4%%ABI%%-config
|
||||
PLIST_FILES+= libdata/pkgconfig/python-3.4%%ABI%%.pc
|
||||
PLIST_FILES+= bin/python${PYTHON_VER}${ABIFLAGS} \
|
||||
bin/python${PYTHON_VER}${ABIFLAGS}-config \
|
||||
libdata/pkgconfig/python-${PYTHON_VER}${ABIFLAGS}.pc
|
||||
.endif
|
||||
|
||||
# http://bugs.python.org/issue22521
|
||||
# http://bugs.python.org/issue23042
|
||||
# https://bugs.python.org/issue22521
|
||||
# https://bugs.python.org/issue23042
|
||||
.if ${ARCH} == i386 && !${PORT_OPTIONS:MLIBFFI}
|
||||
BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
|
||||
.endif
|
||||
|
@ -108,7 +113,7 @@ BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
|
|||
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
|
||||
.endif
|
||||
|
||||
# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
|
||||
# See https://bugs.freebsd.org/115940 and https://bugs.freebsd.org/193650
|
||||
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
|
||||
PLIST_SUB+= NO_NIS="@comment "
|
||||
DISABLED_EXTENSIONS+= nis
|
||||
|
@ -124,15 +129,11 @@ post-patch:
|
|||
"s|lib_dirs,\ \'readline\'|[\'${LOCALBASE}/lib\',\ \'.\'],\ \'readline\'|" \
|
||||
${WRKSRC}/setup.py
|
||||
.endif
|
||||
${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
|
||||
${WRKSRC}/Lib/cgi.py
|
||||
|
||||
post-install:
|
||||
.if ! ${PORT_OPTIONS:MDEBUG}
|
||||
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
|
||||
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: https://bugs.python.org/issue17975
|
||||
.endif
|
||||
for i in ${STAGEDIR}${PREFIX}/lib/python3.4/lib-dynload/*.so; do \
|
||||
${STRIP_CMD} $$i; done # Strip shared extensions
|
||||
# This code block exists for the qemu-user enabled cross build environment.
|
||||
# When using this environment in poudriere, CC is not set to the default
|
||||
# of /usr/bin/cc and a cross-compile toolchain is used. We need to hand
|
||||
|
@ -140,11 +141,13 @@ post-install:
|
|||
# FreeBSD base system provides. sbruno 02Aug2017
|
||||
.if ${CC} == /nxb-bin/usr/bin/cc
|
||||
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
|
||||
${STAGEDIR}${PREFIX}/lib/python3.4/_sysconfigdata.py
|
||||
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata.py
|
||||
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
|
||||
${STAGEDIR}${PREFIX}/lib/python3.4/config-3.4m/Makefile
|
||||
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
|
||||
.endif
|
||||
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
|
||||
${STRIP_CMD} $$i; done # Strip shared extensions
|
||||
${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
|
||||
${STAGEDIR}${PREFIX}/lib/libpython3.4${ABIFLAGS}.so.1-gdb.py
|
||||
${STAGEDIR}${PREFIX}/lib/libpython${PYTHON_VER}${ABIFLAGS}.so.1-gdb.py
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# Mk/Uses/python.mk includes this file, don't remove it!
|
||||
# $FreeBSD$
|
||||
|
||||
PYTHON_PORTVERSION= 3.4.7
|
||||
PYTHON_PORTVERSION= 3.4.8
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1502303602
|
||||
SHA256 (python/Python-3.4.7.tar.xz) = 8714cf2b56dd36922dec8fa184d4936e1001c22fb439798cb73dda069e129d1b
|
||||
SIZE (python/Python-3.4.7.tar.xz) = 14511368
|
||||
TIMESTAMP = 1518277532
|
||||
SHA256 (python/Python-3.4.8.tar.xz) = 29a472fa902c7b2add152f5e1e82e0885a8d360645689c1db5d1949a7e8ac3ea
|
||||
SIZE (python/Python-3.4.8.tar.xz) = 14576444
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
# Description: Some python extensions can't be compiled with clang 3.4
|
||||
# Issue ID: http://bugs.python.org/issue20767
|
||||
# Issue ID: https://bugs.python.org/issue20767
|
||||
# Submitted by: antoine
|
||||
|
||||
--- ./Lib/distutils/unixccompiler.py.orig 2014-03-09 15:25:15.921204441 +1100
|
||||
|
|
|
@ -35,6 +35,17 @@
|
|||
NO_AS_NEEDED= @NO_AS_NEEDED@
|
||||
LDLAST= @LDLAST@
|
||||
SGI_ABI= @SGI_ABI@
|
||||
@@ -822,8 +825,8 @@ Objects/unicodeobject.o: $(srcdir)/Objec
|
||||
Objects/dictobject.o: $(srcdir)/Objects/stringlib/eq.h
|
||||
Objects/setobject.o: $(srcdir)/Objects/stringlib/eq.h
|
||||
|
||||
-$(OPCODETARGETS_H): $(OPCODETARGETGEN_FILES)
|
||||
- $(OPCODETARGETGEN) $(OPCODETARGETS_H)
|
||||
+#$(OPCODETARGETS_H): $(OPCODETARGETGEN_FILES)
|
||||
+# $(OPCODETARGETGEN) $(OPCODETARGETS_H)
|
||||
|
||||
Python/ceval.o: $(OPCODETARGETS_H) $(srcdir)/Python/ceval_gil.h
|
||||
|
||||
@@ -1080,12 +1077,6 @@
|
||||
else true; \
|
||||
fi
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
# Backport patch 0001 from Issue #20210
|
||||
# Issue: http://bugs.python.org/issue20210
|
||||
# Issue: https://bugs.python.org/issue20210
|
||||
# By: Thomas Petazzoni
|
||||
|
||||
--- ./Makefile.pre.in.orig 2014-03-24 22:45:17.908886504 +1100
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
http://bugs.python.org/issue24557
|
||||
https://bugs.python.org/issue24557
|
||||
assume egd unless OPENSSL_NO_EGD is defined-remove configure check
|
||||
|
||||
--- Modules/_ssl.c.orig 2016-06-25 21:52:32 UTC
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue