Add xmms-avi 1.2.2, an avifile based .avi and .asf file playback
plugin for XMMS. Very cool! PR: 24939 Submitted by: Roman Shterenzon <roman@xpert.com>
This commit is contained in:
parent
b68b01559f
commit
f11ccbb44d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40077
13 changed files with 117 additions and 0 deletions
|
@ -243,6 +243,7 @@
|
|||
SUBDIR += xmagv
|
||||
SUBDIR += xmandel
|
||||
SUBDIR += xmfract
|
||||
SUBDIR += xmms-avi
|
||||
SUBDIR += xmms-gforce
|
||||
SUBDIR += xmorph
|
||||
SUBDIR += xmountains
|
||||
|
|
38
graphics/xmms-avi/Makefile
Normal file
38
graphics/xmms-avi/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# Ports collection makefile for: xmms-avi
|
||||
# Date created: Feb 6 2000
|
||||
# Whom: Roman Shterenzon <roman@xpert.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xmms-avi
|
||||
PORTVERSION= 1.2.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.xmms.org/files/plugins/avi-xmms/ \
|
||||
ftp://ftp.sunet.se/pub/multimedia/xmms/plugins/avi-xmms/ \
|
||||
ftp://ftp.fu-berlin.de/unix/sound/xmms/plugins/avi-xmms/
|
||||
DISTNAME= avi-xmms-${PORTVERSION}
|
||||
|
||||
MAINTAINER= roman@xpert.com
|
||||
|
||||
BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
|
||||
LIB_DEPENDS= aviplay.0:${PORTSDIR}/graphics/avifile
|
||||
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
|
||||
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
USE_X_PREFIX= yes
|
||||
USE_GTK= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi.orig -e "s|SDL/SDL.h|SDL11/SDL.h|g" ${WRKSRC}/src/ctrackbar.cpp
|
||||
@${PERL} -pi.orig -e "s|lc_r|pthread|g" ${WRKSRC}/configure
|
||||
|
||||
# This is to avoid libtool running ldconfig -m ${X11BASE}/lib/xmms/Input
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/libavixmms.so ${PREFIX}/lib/xmms/Input
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/xmms-avi/distinfo
Normal file
1
graphics/xmms-avi/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (avi-xmms-1.2.2.tar.gz) = 0532dce534cf6f7ba1d1563547128659
|
12
graphics/xmms-avi/files/patch-configure
Normal file
12
graphics/xmms-avi/files/patch-configure
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- configure.orig Wed Feb 7 22:07:08 2001
|
||||
+++ configure Wed Feb 7 22:08:06 2001
|
||||
@@ -2192,7 +2192,8 @@
|
||||
no_sdl=yes
|
||||
else
|
||||
SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
|
||||
- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
|
||||
+# Having Xxf86vm and friends makes libtool unhappy and unable to create .so
|
||||
+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv//'`
|
||||
|
||||
sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
|
||||
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
|
1
graphics/xmms-avi/pkg-comment
Normal file
1
graphics/xmms-avi/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An avifile based .avi and .asf file playback plugin for XMMS
|
5
graphics/xmms-avi/pkg-descr
Normal file
5
graphics/xmms-avi/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
An avifile and SDL based .avi and .asf file playback plugin for XMMS.
|
||||
|
||||
WWW: http://www.xmms.org/
|
||||
|
||||
Roman Shterenzon <roman@xpert.com>
|
1
graphics/xmms-avi/pkg-plist
Normal file
1
graphics/xmms-avi/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
lib/xmms/Input/libavixmms.so
|
38
multimedia/xmms-avi/Makefile
Normal file
38
multimedia/xmms-avi/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# Ports collection makefile for: xmms-avi
|
||||
# Date created: Feb 6 2000
|
||||
# Whom: Roman Shterenzon <roman@xpert.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xmms-avi
|
||||
PORTVERSION= 1.2.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.xmms.org/files/plugins/avi-xmms/ \
|
||||
ftp://ftp.sunet.se/pub/multimedia/xmms/plugins/avi-xmms/ \
|
||||
ftp://ftp.fu-berlin.de/unix/sound/xmms/plugins/avi-xmms/
|
||||
DISTNAME= avi-xmms-${PORTVERSION}
|
||||
|
||||
MAINTAINER= roman@xpert.com
|
||||
|
||||
BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
|
||||
LIB_DEPENDS= aviplay.0:${PORTSDIR}/graphics/avifile
|
||||
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
|
||||
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
USE_X_PREFIX= yes
|
||||
USE_GTK= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi.orig -e "s|SDL/SDL.h|SDL11/SDL.h|g" ${WRKSRC}/src/ctrackbar.cpp
|
||||
@${PERL} -pi.orig -e "s|lc_r|pthread|g" ${WRKSRC}/configure
|
||||
|
||||
# This is to avoid libtool running ldconfig -m ${X11BASE}/lib/xmms/Input
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/libavixmms.so ${PREFIX}/lib/xmms/Input
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/xmms-avi/distinfo
Normal file
1
multimedia/xmms-avi/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (avi-xmms-1.2.2.tar.gz) = 0532dce534cf6f7ba1d1563547128659
|
12
multimedia/xmms-avi/files/patch-configure
Normal file
12
multimedia/xmms-avi/files/patch-configure
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- configure.orig Wed Feb 7 22:07:08 2001
|
||||
+++ configure Wed Feb 7 22:08:06 2001
|
||||
@@ -2192,7 +2192,8 @@
|
||||
no_sdl=yes
|
||||
else
|
||||
SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
|
||||
- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
|
||||
+# Having Xxf86vm and friends makes libtool unhappy and unable to create .so
|
||||
+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv//'`
|
||||
|
||||
sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
|
||||
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
|
1
multimedia/xmms-avi/pkg-comment
Normal file
1
multimedia/xmms-avi/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An avifile based .avi and .asf file playback plugin for XMMS
|
5
multimedia/xmms-avi/pkg-descr
Normal file
5
multimedia/xmms-avi/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
An avifile and SDL based .avi and .asf file playback plugin for XMMS.
|
||||
|
||||
WWW: http://www.xmms.org/
|
||||
|
||||
Roman Shterenzon <roman@xpert.com>
|
1
multimedia/xmms-avi/pkg-plist
Normal file
1
multimedia/xmms-avi/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
lib/xmms/Input/libavixmms.so
|
Loading…
Reference in a new issue