- Update to 0.50
PR: 122495 Submitted by: Ports Fury
This commit is contained in:
parent
c1ed82c60f
commit
f13e2a4626
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212084
15 changed files with 43 additions and 169 deletions
|
@ -7,37 +7,35 @@
|
|||
#
|
||||
|
||||
PORTNAME= qfsm
|
||||
PORTVERSION= 0.46
|
||||
PORTVERSION= 0.50
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A graphical tool for designing finite state machines
|
||||
|
||||
USE_QT_VER= 3
|
||||
USE_PERL5_BUILD=yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --with-qt-dir=${QT_PREFIX}
|
||||
|
||||
QTCPPFLAGS= ${PTHREAD_CFLAGS}
|
||||
QTCFGLIBS= ${PTHREAD_LIBS}
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= corelib gui qt3support svg xml \
|
||||
moc_build porting_build qmake_build uic_build uic3_build
|
||||
INSTALLS_ICONS= yes
|
||||
USE_XORG= xi
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS/s| doc/user||g' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/qfsm.pro
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC} \
|
||||
&& ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKE_ARGS} qfsm.pro
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${PREFIX}/bin/qfsm
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/user/*.docbook ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/user/*.html ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/user/*.pdf ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/user/*.png ${DOCSDIR}
|
||||
@(cd ${WRKSRC}/doc/user && ${COPYTREE_SHARE} . ${DOCSDIR})
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/*.fsm ${EXAMPLESDIR}
|
||||
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (qfsm-0.46.tar.gz) = aab30b51185d458112cc669dbeb879c6
|
||||
SHA256 (qfsm-0.46.tar.gz) = 6201cdf0dc1d56e01018677b90b8f544269dbd3e3fd142445d78106c730095f2
|
||||
SIZE (qfsm-0.46.tar.gz) = 821488
|
||||
MD5 (qfsm-0.50.tar.gz) = 5172f474b8e018ff86fdbb65bf6c7c53
|
||||
SHA256 (qfsm-0.50.tar.gz) = 033933d31d237ec0ccbb48fca4022b2f2a1e6c0c9302d7f954cd1bc66c8708ee
|
||||
SIZE (qfsm-0.50.tar.gz) = 1644095
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/Convert.cpp.orig Mon Dec 29 05:35:44 2003
|
||||
+++ src/Convert.cpp Wed Mar 17 00:06:42 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <qstring.h>
|
||||
#include <qregexp.h>
|
||||
#include "Convert.h"
|
|
@ -1,13 +0,0 @@
|
|||
--- src/Draw.cpp.orig Fri Aug 17 05:07:21 2007
|
||||
+++ src/Draw.cpp Wed Oct 3 14:30:19 2007
|
||||
@@ -16,8 +16,8 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
-#include <float.h>
|
||||
+#include <cmath>
|
||||
+#include <cfloat>
|
||||
#include <qnamespace.h>
|
||||
#include <qptrlist.h>
|
||||
#include <qpainter.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- src/GState.cpp.orig Fri Aug 17 05:05:36 2007
|
||||
+++ src/GState.cpp Wed Oct 3 14:33:54 2007
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
|
||||
#include <qpen.h>
|
||||
#include <qbrush.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- src/GTransition.cpp.orig Mon Dec 29 05:35:44 2003
|
||||
+++ src/GTransition.cpp Wed Mar 17 00:08:16 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
|
||||
#include "GTransition.h"
|
||||
#include "GState.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- src/ICheck.cpp.orig Tue Feb 3 02:50:35 2004
|
||||
+++ src/ICheck.cpp Wed Mar 17 00:08:59 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <qcursor.h>
|
||||
#include "ICheck.h"
|
||||
#include "Machine.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- src/ListBoxItems.cpp.orig Mon Dec 29 05:35:44 2003
|
||||
+++ src/ListBoxItems.cpp Wed Mar 17 00:09:39 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <qlistbox.h>
|
||||
#include <qpen.h>
|
||||
#include <qpainter.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- src/Machine.h.orig Fri Aug 17 05:06:26 2007
|
||||
+++ src/Machine.h Wed Oct 3 14:34:14 2007
|
||||
@@ -19,7 +19,7 @@
|
||||
#ifndef MACHINE_H
|
||||
#define MACHINE_H
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <qptrlist.h>
|
||||
#include <qobject.h>
|
||||
#include <qstringlist.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- src/OptGeneralDlgImpl.cpp.orig Mon Dec 29 05:35:44 2003
|
||||
+++ src/OptGeneralDlgImpl.cpp Tue Mar 16 23:47:47 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <stdlib.h>
|
||||
+#include <cstdlib>
|
||||
#include <qdir.h>
|
||||
#include <qstringlist.h>
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
--- src/State.cpp.orig Sat Mar 6 22:22:17 2004
|
||||
+++ src/State.cpp Wed Mar 17 00:10:25 2004
|
||||
@@ -16,8 +16,8 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
-#include <string.h>
|
||||
+#include <cmath>
|
||||
+#include <cstring>
|
||||
|
||||
#include "State.h"
|
||||
#include "Transition.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- src/Transition.cpp.orig Tue Feb 3 01:36:43 2004
|
||||
+++ src/Transition.cpp Tue Mar 16 23:48:26 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <stdlib.h>
|
||||
+#include <cstdlib>
|
||||
//#include <typeinfo>
|
||||
|
||||
#include "Transition.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- src/TransitionInfoBin.cpp.orig Mon Dec 29 05:35:44 2003
|
||||
+++ src/TransitionInfoBin.cpp Tue Mar 16 23:49:09 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <stdlib.h>
|
||||
+#include <cstdlib>
|
||||
#include <typeinfo>
|
||||
#include "IOInfoBin.h"
|
||||
#include "IOInfoASCII.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- src/main.cpp.orig Mon Jan 17 06:23:41 2005
|
||||
+++ src/main.cpp Wed Jan 19 21:39:30 2005
|
||||
@@ -16,7 +16,7 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
-#include <stdlib.h>
|
||||
+#include <cstdlib>
|
||||
#include <iostream>
|
||||
#include <qtranslator.h>
|
||||
#include <qapplication.h>
|
|
@ -1,9 +1,12 @@
|
|||
bin/qfsm
|
||||
share/applications/qfsm.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.qfsm.docbook.swo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/addstate.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/addtrans.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/copy.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cut.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc_Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/integrity_check.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/machine_properties.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/new.png
|
||||
|
@ -12,8 +15,10 @@ share/applications/qfsm.desktop
|
|||
%%PORTDOCS%%%%DOCSDIR%%/paste.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/print.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qfsm.docbook
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qfsm.fo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qfsm.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qfsm.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qfsm.rtf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/save.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/select.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/simulate.png
|
||||
|
@ -21,15 +26,22 @@ share/applications/qfsm.desktop
|
|||
%%PORTDOCS%%%%DOCSDIR%%/state_properties.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/straighten.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/toolbar.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/toolbar2.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/toolbar3.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/transition_properties.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/undo.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/working_area.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/working_area.xcf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/working_area2.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/zoom.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/zoomin.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/zoomout.png
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ascii_example.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ascii_example2.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bin_example.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datum.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/float.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/integer.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_example.fsm
|
||||
share/icons/hicolor/32x32/apps/qfsm.png
|
||||
share/icons/hicolor/32x32/mimetypes/x-qfsm.png
|
||||
share/icons/hicolor/48x48/apps/qfsm.png
|
||||
|
@ -41,19 +53,19 @@ share/mimelnk/application/x-qfsm.desktop
|
|||
%%DATADIR%%/French.qm
|
||||
%%DATADIR%%/German.qm
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm share/mimelnk/application
|
||||
@dirrm share/mimelnk
|
||||
@dirrm share/icons/hicolor/64x64/mimetypes
|
||||
@dirrm share/icons/hicolor/64x64/apps
|
||||
@dirrm share/icons/hicolor/64x64
|
||||
@dirrm share/icons/hicolor/48x48/mimetypes
|
||||
@dirrm share/icons/hicolor/48x48/apps
|
||||
@dirrm share/icons/hicolor/48x48
|
||||
@dirrm share/icons/hicolor/32x32/mimetypes
|
||||
@dirrm share/icons/hicolor/32x32/apps
|
||||
@dirrm share/icons/hicolor/32x32
|
||||
@dirrm share/icons/hicolor
|
||||
@dirrm share/icons
|
||||
@dirrmtry share/mimelnk/application
|
||||
@dirrmtry share/mimelnk
|
||||
@dirrmtry share/icons/hicolor/64x64/mimetypes
|
||||
@dirrmtry share/icons/hicolor/64x64/apps
|
||||
@dirrmtry share/icons/hicolor/64x64
|
||||
@dirrmtry share/icons/hicolor/48x48/mimetypes
|
||||
@dirrmtry share/icons/hicolor/48x48/apps
|
||||
@dirrmtry share/icons/hicolor/48x48
|
||||
@dirrmtry share/icons/hicolor/32x32/mimetypes
|
||||
@dirrmtry share/icons/hicolor/32x32/apps
|
||||
@dirrmtry share/icons/hicolor/32x32
|
||||
@dirrmtry share/icons/hicolor
|
||||
@dirrmtry share/icons
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrmtry share/applications
|
||||
|
|
Loading…
Reference in a new issue