Add net/p5-Net-NTP

Approved by:	swills (mentor)
Sponsored by:	Netflix
This commit is contained in:
Brad Davis 2017-03-31 14:32:02 +00:00
parent 21c9ca161e
commit f13fc84959
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437360
5 changed files with 38 additions and 0 deletions

View file

@ -675,6 +675,7 @@
SUBDIR += p5-Net-NBsocket
SUBDIR += p5-Net-NIS
SUBDIR += p5-Net-NIS-Listgroup
SUBDIR += p5-Net-NTP
SUBDIR += p5-Net-Nessus-XMLRPC
SUBDIR += p5-Net-Nmsg
SUBDIR += p5-Net-OAuth

19
net/p5-Net-NTP/Makefile Normal file
View file

@ -0,0 +1,19 @@
# Created by: brd@FreeBSD.org
# $FreeBSD$
PORTNAME= Net-NTP
PORTVERSION= 1.5
CATEGORIES= net
MASTER_SITES= CPAN
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for decoding NTP server responses
NO_ARCH= yes
USE_PERL5= configure
USES= perl5
PLIST_FILES= %%SITE_PERL%%/Net/NTP.pm \
%%PERL5_MAN3%%/Net::NTP.3.gz
.include <bsd.port.mk>

3
net/p5-Net-NTP/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1490969857
SHA256 (Net-NTP-1.5.tar.gz) = b16817f88ecc75f155aea3dcf8874d4b8bcc0c9d249e1bc1e12ce7cfa5e7d9aa
SIZE (Net-NTP-1.5.tar.gz) = 6459

View file

@ -0,0 +1,10 @@
--- lib/Net/NTP.pm.orig 2017-03-30 18:32:06 UTC
+++ lib/Net/NTP.pm
@@ -179,6 +179,7 @@ sub get_ntp_response {
alarm(0);
};
alarm 0;
+ die $@ if $@;
my $rectime = time; # T4
my $pkt = Net::NTP::Packet->decode($data, $xmttime, $rectime);

5
net/p5-Net-NTP/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
All this module does is send a packet to an NTP server and
then decode the packet received into it's respective parts
- as outlined in RFC5905 (superseding RFC1305 and RFC2030).
WWW: http://search.cpan.org/dist/Net-NTP/